Pole Nazwa pliku nie uaktualnia automatycznie po otwarciu dokumentu w programie Word

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 832897 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

Po otwarciu dokumentu w jednej z wersji Microsoft Wyraz, który jest wymieniony w sekcji "Dotyczy" tego artykułu, nazwa pliku pole (i ścieżkę, jeśli ma zastosowanie) nie powoduje aktualizacji nazwy i lokalizacji plik, który właśnie otwartym.

Przyczyna

To zachowanie jest zmiana projektu w programie Microsoft Word 2002 i później, aby umożliwić dokument programu Word zawierający pole Nazwa pliku, aby otworzyć więcej szybko.

Obejście problemu

Aby obejść ten problem, użyj jednej z następujących metody.

Metoda 1: Ręcznie zaktualizować pola

Aby ręcznie zaktualizować pole, wybierz pole, które znajduje się w dokumencie programu Word, a następnie naciśnij klawisz F9.

Metoda 2: Utwórz makro automatycznie zaktualizować pole

Firma Microsoft podaje przykłady programowania wyłącznie, bez jakichkolwiek gwarancji wyrażonych wprost lub domyślnie. Obejmuje, ale nie jest ograniczona do domniemanych gwarancji jakości lub przydatności do określonego celu. W tym artykule założono, że czytelnik jest obeznany z językiem programowania, przy czym obrazuje i narzędzia, które są używane do tworzenia i debugowania procedur. Wykwalifikowani pracownicy pomocy technicznej firmy Microsoft mogą pomóc w wyjaśnieniu jak działa określona procedura. Jednak nie będą modyfikować tych przykładów ani dodawać żadnej funkcji i konstruować nowych procedur w celu spełnienia szczególnych wymagań.

Aby automatycznie zaktualizować pole, które jest zawarte w dokumencie programu Word, Utwórz makro AutoOpen. Aby to zrobić, wykonaj następujące kroki:
  1. Uruchom program Word i otworzyć dokument, który zawiera pola nie będzie automatycznie aktualizacji.
  2. W Program Microsoft Office Word 2003 lub Word 2002, na w Narzędzia menu, wskaż Makro, a następnie Kliknij przycisk Makra.

    W Program Microsoft Office Word 2007, kliknij przycisk Deweloper a następnie kliknijMakra w Kod Grupa.
  3. W Makra okno dialogowe należy wykonać te kroki:
    1. W Nazwa makra pole typu AutoOpen.
    2. Zmiana Makra w Aby Twoje Nazwa pliku dokumentu.
    3. Kliknij przycisk Tworzenie.
  4. W arkuszu kodu w edytorze Microsoft Visual Basic można powinien być teraz widoczny początku makra AutoOpen. Na przykład należy zobacz:
    Sub AutoOpen()
    '
    ' AutoOpen Macro
    ' Macro created date by username
    '
    
    End Sub
    
  5. Wpisz, lub skopiuj i wklej następujący kod makra do sieci AutoOpen makr:
       Dim aStory As Range
       Dim aField As Field
    
       For Each aStory In ActiveDocument.StoryRanges
    
          For Each aField In aStory.Fields
             aField.Update
          Next aField
    
       Next aStory
    
  6. Makro AutoOpen powinien wyglądać w poniższym przykładzie:
    Sub AutoOpen()
    '
    ' AutoOpen Macro
    ' Macro created date by username
    '
    
       Dim aStory As Range
       Dim aField As Field
    
       For Each aStory In ActiveDocument.StoryRanges
    
          For Each aField In aStory.Fields
             aField.Update
          Next aField
    
       Next aStory
    
    End Sub
    
  7. Na Plik menu, kliknij przycisk ZapiszNazwa pliku.
  8. Na Plik menu, kliknij przycisk Zamknij i Powróć do programu Microsoft Word.
  9. W Program Word 2003 lub Word 2002, na w Narzędzia menu, wskaż Makro, a następnie Kliknij przycisk Zabezpieczenia.

    W Program Word 2007, kliknij przycisk Deweloper a następnie kliknijZabezpieczenia makr w Kod Grupa.
  10. W Program Word 2003 lub Word 2002, na w Poziom zabezpieczeń Karta, zmień poziom zabezpieczeńŚredni, a następnie kliknij przycisk OK.

    W Word 2007, w obszarze Ustawienia makr, kliknij, aby zaznaczyćWłącz wszystkie makra Opcja.
  11. Zamknij dokument.
  12. Otwórz dokument programu Word.
  13. Kliknij przycisk Włącz makra wOstrzeżenie o zabezpieczeniach okno dialogowe.
Pole należy teraz automatycznie zaktualizować w program Word dokument.

Więcej informacji

Pole FILENAME będą aktualizowane automatycznie, przełączenie do podglądu wydruku lub drukowanie dokumentu.

Aby uzyskać więcej informacji kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
211629Pola, które są aktualizowane podczas otwierania, ponownie podzielić lub drukowania dokumentu
Aby uzyskać więcej informacji na temat AutoOpen makra kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
286310Zachowanie makra AutoExec i AutoLoad w programie Word

Właściwości

Numer ID artykułu: 832897 - Ostatnia weryfikacja: 18 września 2011 - Weryfikacja: 3.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office Word 2007
  • Microsoft Word 2002 Standard Edition
Słowa kluczowe: 
kbprb kbmt KB832897 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł nie został przetłumaczony przez człowieka, tylko przez oprogramowanie do tłumaczenia maszynowego firmy Microsoft. Firma Microsoft oferuje zarówno artykuły tłumaczone przez ludzi, jak i artykuły tłumaczone maszynowo, dzięki czemu każdy użytkownik może uzyskać dostęp do całej zawartości bazy wiedzy Knowledge Base we własnym języku. Prosimy jednak pamiętać, że artykuły przetłumaczone maszynowo nie zawsze są doskonałe. Mogą zawierać błędy słownictwa, składni i gramatyki, przypominające błędy robione przez osoby, dla których język użytkownika nie jest językiem ojczystym. Firma Microsoft nie odpowiada za wszelkie nieścisłości, błędy lub szkody spowodowane nieprawidłowym tłumaczeniem zawartości oraz za wykorzystanie tej zawartości przez klientów. Oprogramowanie do tłumaczenia maszynowego jest często aktualizowane przez firmę Microsoft.
Anglojęzyczna wersja tego artykułu to:832897

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com