Article ID: 832911 - Last Review: December 3, 2007 - Revision: 2.6

FIX: Users sometimes receive an "HTTP 401.3 unauthorized due to access control list (ACL) on resource" error message when they visit your Web site

Hotfix download is availableHotfix Download Available
View and request hotfix downloads

On This Page

Expand all | Collapse all

SYMPTOMS

If you have Microsoft Windows Intergrated Authentication enabled in Microsoft Internet Information Server (IIS) 6.0, users sometimes receive the following error message in their browsers:
HTTP 401.3 Unauthorized due to access control list (ACL) on resource
If a user makes the same request again later by using the same credentials, the later request will work correctly.

CAUSE

This problem occurs because the IIS worker process is recycled during the NTLM authentication handshake with the client. The state of the NTLM authentication is stored with the worker process. Therefore, the state of any NTLM authentication that is in process is lost when the recycle action occurs.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

If you are also experiencing the symptoms that Microsoft Knowledge Base article 832139 describes, apply hotfix 832139 before you apply this hotfix.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
832139  (http://support.microsoft.com/kb/832139/ ) FIX: IIS 6.0 serves stale content if a Web site has both the IP address and the Host Headers set

Restart requirement

You must restart your computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name
   ----------------------------------------------------
   11-Dec-2003  19:17  5.2.3790.111  334,336  Http.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 1.

APPLIES TO
  • Microsoft Internet Information Services 6.0
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbhotfixserver kbqfe kberrmsg kbfix kbbug kbqfe kbwinserv2003presp1fix KB832911
 

Article Translations

 

Related Support Centers