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An Office program is slow or may appear to stop responding (hang) when you open a file from a network location

Article ID:833041
Last Review:January 26, 2007
Revision:3.3

SYMPTOMS

When you try to open a file from a network location in one of the Microsoft Office programs listed in the "Applies To" section of this article, the Office program may run very slowly or may appear to stop responding (hang).

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CAUSE

This behavior may occur if the connection to the network location is lost during the time that your Office program is opening the file.

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WORKAROUND

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows

To work around this behavior, add the EnableShellDataCaching value to the Microsoft Windows registry.

To do this, follow these steps:
1.Close your Office programs.
2.Click Start, and then click Run.
3.In the Open box, type regedit, and then click OK.
4.Locate, and then click to select the following registry key:

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Office 2003

HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\Open Find

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Office 2007

HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\Open Find
5.After you select the key that is specified in step 4, point to New on the Edit menu, and then click DWORD Value.
6.Type EnableShellDataCaching, and then press ENTER.
7.Right-click EnableShellDataCaching, and then click Modify.
8.In the Value data box, type 1, and then click OK.

Note Any non-zero number in the Value data box will turn on caching. A zero number or blank (default) will turn off caching.
9.On the File menu, click Exit to quit Registry Editor.

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MORE INFORMATION

This situation may occur after you click Open in the Open dialog box (on the File menu, click Open) to open a file from a network location (for example, a network server). During the process of opening the file, you lose your network connection or the network location that contains the file that you are trying to open goes down. During the process of opening the file, your Office program tries to add the file name and the path information of the file that you are trying to open to the Windows recent file list. Because the network location (path) does not now exist, the Office program may run slowly and may appear to stop responding (hang).

Note This situation may also occur if your connection to your network is slow because your Office program has to make multiple queries to the network to obtain the correct file information.

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APPLIES TO
Microsoft Office Excel 2003
Microsoft Office PowerPoint 2003
Microsoft Office Word 2003
Microsoft Office Excel 2007
Microsoft Office Word 2007
Microsoft Office Publisher 2007

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Keywords: 
kbregistry kbnetwork kbopenfile kbprb KB833041

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