Office-ohjelma toimii hitaasti tai saattaa vaikuttaa lopettavan vastaamisen (jumittuvan), kun tiedosto avataan verkkosijainnista

Artikkeleiden käännökset Artikkeleiden käännökset
Artikkelin tunnus: 833041 - Näytä tuotteet, joita tämä artikkeli koskee.
Laajenna kaikki | Kutista kaikki

Oire

Kun yrität avata tiedoston verkkosijainnista jossakin tämän artikkelin alussa luetellussa Microsoft Office -ohjelmassa, Office-ohjelma saattaa toimia hyvin hitaasti tai vaikuttaa lopettavan vastaamisen (jumittuvan).

Saat lisätietoja samankaltaisesta tilanteesta napsauttamalla seuraavaa artikkelin numeroa, jolloin pääset lukemaan artikkelin Microsoft Knowledge Base -tietokannassa:  
2570623 Excel 2003:n Office-tiedostojen tarkistamistoiminto (OFV) avaa työkirjoja aiempaa hitaaminen verkosta

Syy

Tämä ongelma voi ilmetä, jos yhteys verkkosijaintiin menetetään silloin, kun Office-ohjelma avaa tiedostoa.

Workaround

Tärkeää Tässä osassa, tavassa tai tehtävässä olevissa vaiheissa kerrotaan, miten rekisteriä muokataan. Vakavia ongelmia saattaa kuitenkin ilmetä, jos rekisteriä muokataan virheellisesti. Varmista siis, että noudatat ohjeita huolellisesti. Varmuuskopioi rekisteri varmuuden vuoksi ennen sen muokkaamista. Tällöin voit palauttaa sen, jos ongelmia ilmenee. Lisätietoja rekisterin varmuuskopioimisesta ja palauttamisesta saat napsauttamalla seuraavaa artikkelin numeroa, jolloin pääset lukemaan artikkelin Microsoft Knowledge Base -tietokannassa:
322756 Rekisterin varmuuskopioiminen ja palauttaminen Windows XP:ssä
Jos haluat, että tämä toiminta kierretään puolestasi, siirry Korjaa ongelma puolestani -osaan. Jos haluat korjata tämän ongelman mieluummin itse, siirry Haluan korjata ongelman itse -osaan.

Korjaa ongelma puolestani



Jos haluat, että tämä ongelma korjataan automaattisesti, napsauta Fix it -ratkaisun painiketta tai linkkiä. Valitse Tiedostojen lataaminen -valintaikkunassa Suorita ja noudata sitten ohjatun Fix it -toiminnon ohjeita.


Korjaa tämä ongelma
Microsoftin Fix it -ratkaisu 50637


Huomautuksia
  • Tämä ohjattu toiminto saattaa olla vain englanninkielinen. Automaattinen korjaus toimii kuitenkin myös muiden Windowsin kieliversioiden kanssa.
  • Jos et ole käyttämässä tietokonetta, jossa tämä ongelma ilmenee, tallenna Fix it -ratkaisu muistitikkuun tai CD-levylle ja suorita se sitten tietokoneessa, jossa ongelma ilmenee.

Siirry sitten Korjasiko tämä ongelman? -osaan.



Haluan korjata ongelman itse


Voit kiertää tämän ongelman lisäämällä EnableShellDataCaching-arvon Microsoft Windowsin rekisteriin.

Voit tehdä tämän seuraavasti:
  1. Sulje Office-ohjelmat.
  2. Napsauta Käynnistä-painiketta ja valitse sitten Suorita.
  3. Kirjoita Avaa-ruutuun regedit ja valitse sitten OK.
  4. Etsi seuraava rekisteriavain ja valitse se napsauttamalla sitä:

    Office 2003

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\Open Find

    Office 2007

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\Open Find
  5. Kun olet valinnut vaiheessa 4 kuvatun avaimen, valitse Muokkaa-valikosta Uusi ja valitse sitten DWORD-arvo.
  6. Kirjoita EnableShellDataCaching ja paina sitten ENTER-näppäintä.
  7. Napsauta hiiren kakkospainikkeella EnableShellDataCaching-arvoa ja valitse sitten Muokkaa.
  8. Kirjoita Arvon data -ruutuun 1 ja valitse sitten OK.

    Huomautus Jos Arvon data -ruudun arvo on muu kuin nolla (0), välimuisti otetaan käyttöön. Jos arvo on nolla (0) tai tyhjä (oletusarvo), välimuistia ei käytetä.
  9. Sulje Rekisterieditori valitsemalla Tiedosto-valikosta Lopeta.

Korjasiko tämä ongelman?

  • Tarkista, onko ongelma korjattu. Jos ongelma on korjattu, sinun ei tarvitse tehdä muita tässä osassa kuvattuja toimia. Jos ongelmaa ei ole korjattu, voit ottaa yhteyttä tukeen.
  • Arvostamme palautettasi. Voit antaa meille palautetta tai ilmoittaa tähän ratkaisuun liittyvistä ongelmista jättämällä kommentin Fix it for me (Korjaa ongelma puolestani) -blogiin tai lähettämällä meille sähköpostiviestin.

Enemmän tietoa

Tämä voi tapahtua sen jälkeen, kun olet avannut tiedoston verkkosijainnista (esimerkiksi verkkopalvelimesta) valitsemalla Tiedosto-valikosta Avaa ja sen jälkeen näyttöön tulevasta Avaa-valintaikkunasta Avaa. Tiedoston avaamisprosessin aikana verkkoyhteys menetetään tai avattavan tiedoston sisältävän verkkosijainnin yhteys katkeaa. Office-ohjelmasi yrittää tiedoston avaamisen aikana lisätä tiedoston nimen ja polkusijainnin Windowsin viimeksi käytettyjen tiedostojen luetteloon. Koska verkkosijaintia (polkua) ei enää ole, Office-ohjelma saattaa toimia hitaasti ja vaikuttaa lopettavan vastaamisen (jumittuvan).

Huomautus Tämä tilanne voi ilmetä myös, jos verkkoyhteytesi on hidas, koska Office-ohjelmasi on tehtävä verkkoon useita kyselyitä tiedoston tietojen hankkimisen yhteydessä.
Huomautus Tämä on niin sanottu nopeasti julkaistava (?fast publish?) artikkeli, joka on laadittu suoraan Microsoftin tukiorganisaatiossa. Tässä olevat tiedot toimitetaan sellaisenaan vastauksena esiin tulleisiin ongelmiin. Koska aineisto on tuotu saataville nopeasti, se saattaa sisältää painovirheitä ja tietoja saatetaan muokata milloin tahansa ilman erillistä ilmoitusta. Lue muut huomioon otettavat seikat käyttöehdoista.

Ominaisuudet

Artikkelin tunnus: 833041 - Viimeisin tarkistus: 10. huhtikuuta 2012 - Versio: 1.0
Artikkelin tiedot koskevat seuraavia tuotteita:
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Excel 2007
  • Microsoft Office Word 2007
  • Microsoft Office Publisher 2007
Hakusanat: 
kbregistry kbnetwork kbopenfile kbprb kbmsifixme kbfixme KB833041

Anna palautetta

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com