"Word was unable to open the data source" error message in Word Mail Merge when you use an Access parameter query in Access 2002

Article translations Article translations
Article ID: 833064 - View products that this article applies to.
This article applies only to a Microsoft Access database (.mdb).

Novice: Requires knowledge of the user interface on single-user computers.
Expand all | Collapse all

On This Page

SYMPTOMS

When you use Microsoft Access 2002 to try to merge the data from a parameter query, you may receive the following error message. This error message may occur when you use Microsoft Word Mail Merge Wizard with Microsoft Word Mail Merge files.

Word was unable to open the data source.

WORKAROUND

To work around the problem, start Word Mail Merge from the Word environment instead of from the Access environment. You may use one of the following methods:

Method 1: Use the parameter query as the data source

You can create a Word Mail Merge document by using the Access parameter query from the Word environment. To do this, follow these steps:
  1. Create a Word document or open a Word document.
  2. On the Tools menu, click Options, and then click the General tab.
  3. Click to select the Confirm conversion at Open check box, and then click OK.
  4. On the Tools menu, point to Letters and Mailings, and then click Mail Merge Wizard.
  5. In the right pane, click the document type that you want in the Select document type list box, and then click Next: Starting document.
  6. In the Select starting document list box, click the document that you want to use.

    Note For any option other than Use the current document, you must select the appropriate template or the appropriate existing document before you continue.
  7. Click Next: Select recipients.
  8. In the Select recipients list box, click Use an existing list, and then click Browse.
  9. Locate the Access database that contains the parameter query that you want to use as your data source. Open this Access database.
  10. In the Confirm Data Source dialog box, click MS Access Databases via DDE (*.mdb;*.mde), and then click OK.
  11. In the Microsoft Access dialog box, click the Queries tab, click the parameter query that you want to use, and then click OK.

    The Enter Parameter Value dialog box appears.

    Note If the Enter Parameter Value dialog box does not appear, press ALT+TAB one time. If Word does not respond, press ALT+TAB one time.
  12. In the Enter Parameter Value dialog box, enter the required parameter value, and then click OK.
  13. In the Mail Merge Recipients dialog box, click OK.

    Note If the Mail Merge Recipients dialog box does not appear, press ALT+TAB one time.
  14. Complete the Word Mail Merge.
Method 2: Export the parameter query and then use the exported document as the data source

You can also work around this problem by exporting the parameter query to a file and then use the file as the data source in Word Mail Merge. To do this, follow these steps:
  1. Start Access 2002.
  2. Open an Access database with the parameter query that you want to use.
  3. In the Database window, click Queries in the Objects section.
  4. In the right pane, click the parameter query that you want to use.
  5. On the File menu, click Export.
  6. In the Save as type combo box, click Microsoft Word Merge (*.txt).
  7. In the File name box, type a name for the Word Mail Merge file, and then click Export.
  8. In the Enter Parameter Value dialog box, enter the required parameter value, and then click OK.
  9. In a Word document, include this file as the data source for the recipients.

MORE INFORMATION

Steps to Reproduce the Problem

  1. Start Access 2002.
  2. Open the Northwind.mdb sample database.
  3. In the Database window, click Queries in the Objects section.
  4. In the right pane, click the Invoices Filter query.
  5. On the Tools menu, point to Office Links, and then click Merge It with Microsoft Word.
  6. In the Microsoft Word Mail Merge Wizard dialog box, click Create a new document and then link the data to it, and then click OK.
  7. In the Confirm Data Source dialog box, click MS Access Database via DDE (*.mdb;*.mde) in the Open data source list box, and then click OK.

    When you view the Database window in Access, you may receive the error message that is mentioned in the "Symptoms" section.

REFERENCES

286847 WD2002: First mail merge recipient is duplicated when you connect to the data source through the DDE method

Properties

Article ID: 833064 - Last Review: April 20, 2006 - Revision: 3.0
APPLIES TO
  • Microsoft Access 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
Keywords: 
kberrmsg kbtshoot kbmerge kbprb kbquery KB833064

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com