Microsoft Internet Explorer peut cesser de répondre jusqu'à six minutes

Traductions disponibles Traductions disponibles
Numéro d'article: 833301 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Symptômes

Microsoft Internet Explorer ou Windows Internet Explorer peut cesser de répondre jusqu'à six minutes.

Cause

Ce problème peut se produire si Internet Explorer ou de l'objet XMLHTTP Microsoft COM utilise Microsoft Win32 Internet (WinInet) API pour les opérations de HTTP. Lorsqu'un programme ou objet qui utilise WinInet effectue une opération POST, et la connexion est fermée ou réinitialiser avant une réponse est renvoyée par le serveur le POST a été envoyé à, WinInet peut établir une nouvelle connexion. L'opération POST peut être répétée, mais aucune partie du corps de l'opération POST n'est envoyée à nouveau.

Ce problème est susceptible de se produire sur des liaisons lentes si le délai de connexion au serveur-côté a la valeur très faible. Par conséquent, la fin de serveur peut fermer la connexion TCP pendant le temps le serveur est en attente de la demande client à l'arrivée.

Contournement

Pour pouvoir résoudre ce problème, vous le délai de serveur plu le délai d'attente du client. Lorsque vous effectuez cette opération, du côté client ferme la connexion inactive avant que le côté serveur a atteint le délai d'attente.

Microsoft Internet Information Server (IIS) 5 et versions ultérieures ont un délai d'un serveur côté expiration par défaut de 2 minutes. Pour savoir comment définir le délai d'attente des connexions dans IIS, site le suivant Microsoft Web afficher la page Paramètres connexion délai Web :
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/31a2f39c-4d59-4cba-905c-60e7af657e49.mspx
Internet Explorer 5 et versions ultérieures ont un délai d'un client côté expiration par défaut de 1 minute.

Propriétés

Numéro d'article: 833301 - Dernière mise à jour: mercredi 18 octobre 2006 - Version: 2.5
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Internet Explorer 6.0 SP1
  • Microsoft Internet Explorer 5.01 SP4
  • Windows Internet Explorer 7 for Windows Server 2003 IA64
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
Mots-clés : 
kbmt kbprb KB833301 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 833301
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com