Servicios de Message Queue Server no puede enviar mensajes a una cola de destino después de realizar cambios en las direcciones IP

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Id. de artículo: 833512 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de que copia el registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows
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Síntomas

Microsoft Message Queue Server (también conocido como MSMQ) correctamente no se puede enviar mensajes a una cola de destino si se cumplen las condiciones siguientes:
  • La dirección IP del equipo receptor ha cambiado.
  • Un equipo diferente ha asumido la dirección IP que anteriormente era propiedad por el equipo receptor.

Causa

Este problema se produce porque el remitente no reintenta la resolución de nombres.

Solución

Microsoft Windows 2000

Información de la actualización de seguridad

Para resolver este problema, aplique la actualización de seguridad que se describe en el siguiente artículo de Microsoft Knowledge Base:
892944MS05-017: Una vulnerabilidad en MSMQ podría permitir la ejecución de código
Información del registro
Debe realizar cambios en el registro después de aplicar esta actualización de seguridad. Para obtener más información, consulte la sección "".

Microsoft Windows XP

Información de Service Pack

Para resolver este problema, obtenga el Service Pack más reciente para Windows XP. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente de Windows XP
Información del registro
Debe realizar cambios en el registro después de aplicar este service pack. Para obtener más información, consulte la sección "".

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
No se necesita ningún requisito previo.
Requisito de reinicio
Debe reiniciar el equipo después de aplicar este hotfix.
Información del registro
Debe realizar cambios en el registro después de aplicar este hotfix. Para obtener más información, consulte la sección "".
Información de archivo
La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
   Date         Time   Version     Size     File name
   -------------------------------------------------------------------------------
   15-Dec-2003  17:31  5.1.0.1041   67,456  Mqac.sys
   15-Dec-2003  20:37  5.1.0.1041  130,048  Mqad.dll
   15-Dec-2003  20:37  5.1.0.1041   14,848  Mqise.dll
   15-Dec-2003  20:37  5.1.0.1041  608,256  Mqqm.dll
   15-Dec-2003  20:37  5.1.0.1041  165,888  Mqrt.dll
   15-Dec-2003  20:37  5.1.0.1041   88,576  Mqsec.dll
   15-Dec-2003  17:31  5.1.0.1041   98,816  Mqtgsvc.exe
   15-Dec-2003  20:37  5.1.0.1041  467,456  Mqutil.dll
   15-Dec-2003  19:01  5.4.1.0     429,336  Windowsxp-kb833512-x86-enu-symbols.exe
   15-Dec-2003  19:01  5.4.1.0     799,000  Windowsxp-kb833512-x86-enu.exe

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Este problema se corrigió en Windows XP Service Pack 2.

Este problema se corrigió en Windows Server 2003 Service Pack 1.

Más información

En este escenario, hay un remitente y dos receptores (receptor A y B de receptor). Receptor A se conecta a una red mediante una conexión de red privada virtual (VPN). El remitente envía los mensajes correctamente. Receptor A desconecta de la red. Receptor B se conecta a la red y obtiene la dirección IP que utilizaba anteriormente el receptor a. Receptor A también puede volver a conectar y obtener una nueva dirección IP. El remitente continúa enviando mensajes destinados para el receptor A la dirección IP utilizada ahora por el receptor B. El remitente no reintenta la resolución de nombres porque se ha almacenado en caché el resultado anterior. Receptor B rechaza los mensajes, pero el remitente sigue enviar mensajes a receptor B. Debe reiniciar el servicio de Message Queue Server en el equipo del remitente para resolver el problema.

Cambios del registro

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Junto a aplicar la actualización adecuada, debe establecer los parámetros del registro en el receptor y del remitente. El siguiente cambio del registro es necesario en el lado receptor para que el receptor publicará una sesión si recibe un mensaje de una cola no locales. Este cambio significa que el receptor no devolverá que una confirmación de sesión y el remitente se cerrará la sesión un breve período de tiempo más adelante. Es estándar en el lado del remitente para cerrar una sesión si no se recibe una confirmación en un período de tiempo de espera especificado. El remitente intenta establecer una sesión. Siga estos pasos y después salga del Editor del Registro:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic en la siguiente clave del Registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSMQ\Parameters
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en REG_DWORD .
  4. Escriba CloseSessionOnNonLocal y, a continuación, presione ENTRAR.
  5. En el menú Edición , haga clic en Modificar .
  6. Escriba 1 y, a continuación, haga clic en Aceptar .
Debe realizar el siguiente cambio para forzar el remitente para omitir su caché de dirección y realizar siempre la resolución de nombres antes de establece una sesión en el registro.Siga estos pasos y después salga del Editor del Registro:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic en la siguiente clave del Registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSMQ\Parameters
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en REG_DWORD .
  4. Escriba ForceNameResolutionDirect y, a continuación, presione ENTRAR.
  5. En el menú Edición , haga clic en Modificar .
  6. Escriba 1 y, a continuación, haga clic en Aceptar .
Esta corrección también agrega el registro para el código de resolución de nombre. Este cambio se habilita agregando el siguiente valor del registro.Siga estos pasos y después salga del Editor del Registro:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic en la siguiente clave del Registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSMQ\Parameters\Debug
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en REG_DWORD .
  4. Escriba QMLogging y, a continuación, presione ENTRAR.
  5. En el menú Edición , haga clic en Modificar .
  6. Escriba 0 x 20 y, a continuación, haga clic en Aceptar .
Nota El valor de QMLogging es específica de Windows 2000. Los valores CloseSessionOnNonLocal y ForceNameResolutionDirect son para Windows 2000 y Windows Server 2003.

Los siguientes parámetros del registro también son necesarios para vaciar el DNS y cachés de resolución de nombres NetBIOS. En caso contrario, una dirección IP en la caché puede pertenecer a un equipo diferente:
  • HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netbt\Parameters\CacheTimeout = (DWORD) 0
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dnscache\Parameters\MaxCacheEntryTtlLimit = (DWORD) 1
Nota La clave de registro MaxCacheEntryTtlLimit es específica de Windows 2000. En Windows Server 2003, esta clave del registro se denomina MaxCacheTtl. Para obtener más información acerca de la clave del registro de MaxCacheTtl, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
318803Cómo deshabilitar la caché de DNS del cliente en Windows XP y Windows Server 2003
Para obtener más información acerca de la terminología relativa de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 833512 - Última revisión: martes, 15 de abril de 2008 - Versión: 10.1
La información de este artículo se refiere a:
  • Microsoft Message Queue Server 3.0
  • Microsoft Message Queue Server 2.0
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows XP Professional
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbtshoot kbwinxpsp2fix kbwin2000presp5fix kbbug kbfix kbwinxppresp2fix kbqfe KB833512 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 833512

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