Accodamento messaggi sono Impossibile a inviare messaggi a una coda di destinazione dopo la modifica di indirizzo IP

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importante Vengono fornite informazioni su come modificare il Registro di sistema. Assicurarsi di backup del Registro di sistema prima di modificarlo. Verificare che come ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322756Come eseguire il backup e il ripristino del Registro di sistema in Windows
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Sintomi

Microsoft Message Queuing (noto anche come MSMQ) Impossibile correttamente inviare messaggi a una coda di destinazione se sono vere entrambe le condizioni seguenti:
  • L'indirizzo IP del computer di destinazione Ŕ cambiato.
  • Un altro computer ha assunto l'indirizzo IP che Ŕ stato in precedenza proprietÓ computer di destinazione.

Cause

Questo problema si verifica poichÚ il mittente non si riconnette la risoluzione dei nomi.

Risoluzione

Microsoft Windows 2000

Informazioni sull'aggiornamento di protezione

Per risolvere il problema, applicare l'aggiornamento di protezione descritta nel seguente articolo della Microsoft Knowledge Base:
892944MS05-017: Una vulnerabilitÓ in MSMQ pu˛ consentire attacchi di esecuzione di codice
Informazioni del Registro di sistema
Una volta applicato questo aggiornamento per la protezione, Ŕ necessario apportare modifiche al Registro di sistema. Per ulteriori informazioni, vedere la sezione "".

Microsoft Windows XP

Informazioni sul Service pack

Per risolvere il problema, procurarsi l'ultimo service pack per Windows XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322389Come ottenere il service pack pi¨ recente per Windows XP
Informazioni del Registro di sistema
Dopo avere applicato questo service pack, Ŕ necessario apportare modifiche al Registro di sistema. Per ulteriori informazioni, vedere la sezione "".

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.
Prerequisiti
Non Ŕ richiesto alcun prerequisito.
NecessitÓ di riavvio
╚ necessario riavviare il computer dopo aver applicato questo hotfix.
Informazioni del Registro di sistema
Dopo aver applicato questo hotfix, Ŕ necessario apportare modifiche al Registro di sistema. Per ulteriori informazioni, vedere la sezione "".
Informazioni sui file
La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e le ore per questi file sono indicati in UTC (Coordinated Universal Time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello Data e ora nel Pannello di controllo.
   Date         Time   Version     Size     File name
   -------------------------------------------------------------------------------
   15-Dec-2003  17:31  5.1.0.1041   67,456  Mqac.sys
   15-Dec-2003  20:37  5.1.0.1041  130,048  Mqad.dll
   15-Dec-2003  20:37  5.1.0.1041   14,848  Mqise.dll
   15-Dec-2003  20:37  5.1.0.1041  608,256  Mqqm.dll
   15-Dec-2003  20:37  5.1.0.1041  165,888  Mqrt.dll
   15-Dec-2003  20:37  5.1.0.1041   88,576  Mqsec.dll
   15-Dec-2003  17:31  5.1.0.1041   98,816  Mqtgsvc.exe
   15-Dec-2003  20:37  5.1.0.1041  467,456  Mqutil.dll
   15-Dec-2003  19:01  5.4.1.0     429,336  Windowsxp-kb833512-x86-enu-symbols.exe
   15-Dec-2003  19:01  5.4.1.0     799,000  Windowsxp-kb833512-x86-enu.exe

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

Questo problema Ŕ stato corretto in Windows XP Service Pack 2.

Questo problema Ŕ stato corretto in Windows Server 2003 Service Pack 1.

Informazioni

In questo scenario, Ŕ disponibile uno dei mittenti e due destinatari (ricezione A e B di ricezione). Destinatario A connette a una rete utilizzando una connessione di rete privata virtuale (VPN). Il mittente invia i messaggi correttamente. Ricevitore A si disconnette dalla rete. Destinatario B si connette alla rete e ottiene l'indirizzo IP utilizzato in precedenza dal ricevitore a. UN destinatario pu˛ anche riconnettersi e ottenere un nuovo indirizzo IP. Il mittente continua a inviare i messaggi destinati per la ricezione all'indirizzo IP viene utilizzato b di ricezione. Il mittente non si riconnette la risoluzione dei nomi perchÚ Ŕ stato memorizzato nella cache il risultato precedente. Destinatario B rifiuta i messaggi, ma il mittente continua inviare messaggi a b di ricezione. ╚ necessario riavviare il servizio di Accodamento messaggi sul computer del mittente per risolvere il problema.

Modifiche apportate al Registro di sistema

avviso Pu˛ causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema Ŕ a rischio e pericolo dell'utente.

Oltre ad applicare l'aggiornamento appropriato, Ŕ necessario impostare i parametri del Registro di sistema, il destinatario e mittente. La seguente modifica del Registro di sistema Ŕ richiesta sul lato destinatario in modo che il destinatario verrÓ rilasciata una sessione se riceve un messaggio per una coda non locale. Questa modifica significa che il destinatario non verrÓ restituito che un riconoscimento di sessione e al mittente verrÓ chiusa la sessione in un secondo momento un breve periodo di tempo. ╚ standard per il lato del mittente per chiudere una sessione se non si riceve una conferma in un periodo di timeout specificato. Il mittente tenta di ristabilire una sessione. Attenersi alla procedura riportata di seguito, quindi chiudere l'editor del Registro di sistema:
  1. Fare clic su Start , scegliere Esegui , digitare regedit e quindi fare clic su OK .
  2. Individuare e selezionare la seguente chiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSMQ\Parameters
  3. Scegliere Nuovo dal menu Modifica , quindi REG_DWORD .
  4. Digitare CloseSessionOnNonLocal e quindi premere INVIO.
  5. Nel menu Modifica , fare clic su Modifica .
  6. Digitare 1 e quindi fare clic su OK .
╚ necessario apportare seguente Registro di sistema passare per forzare il mittente di ignorare la cache di indirizzo e di eseguire sempre la risoluzione dei nomi prima viene stabilita una sessione.Attenersi alla procedura riportata di seguito, quindi chiudere l'editor del Registro di sistema:
  1. Fare clic su Start , scegliere Esegui , digitare regedit e quindi fare clic su OK .
  2. Individuare e selezionare la seguente chiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSMQ\Parameters
  3. Scegliere Nuovo dal menu Modifica , quindi REG_DWORD .
  4. Digitare ForceNameResolutionDirect e quindi premere INVIO.
  5. Nel menu Modifica , fare clic su Modifica .
  6. Digitare 1 e quindi fare clic su OK .
Questa correzione aggiunge inoltre la registrazione per il codice di risoluzione del nome. Questa modifica Ŕ attivata per aggiungere il seguente valore del Registro di sistema.Attenersi alla procedura riportata di seguito, quindi chiudere l'editor del Registro di sistema:
  1. Fare clic su Start , scegliere Esegui , digitare regedit e quindi fare clic su OK .
  2. Individuare e selezionare la seguente chiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSMQ\Parameters\Debug
  3. Scegliere Nuovo dal menu Modifica , quindi REG_DWORD .
  4. Digitare QMLogging e quindi premere INVIO.
  5. Nel menu Modifica , fare clic su Modifica .
  6. Digitare 0 x 20 e quindi fare clic su OK .
Nota Il valore QMLogging Ŕ specifico per Windows 2000. I valori CloseSessionOnNonLocal e ForceNameResolutionDirect sono per Windows 2000 e per Windows Server 2003.

I seguenti parametri del Registro di sistema sono inoltre necessari per scaricare il DNS e la risoluzione dei nomi NetBIOS memorizza nella cache. In caso contrario, un indirizzo IP nella cache pu˛ appartenere a un altro computer:
  • HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netbt\Parameters\CacheTimeout = (DWORD) 0
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dnscache\Parameters\MaxCacheEntryTtlLimit = (DWORD) 1
Nota La chiave del Registro di sistema di MaxCacheEntryTtlLimit Ŕ specifico di Windows 2000. In Windows Server 2003, Ŕ Ŕ che questa chiave del Registro di sistema denominata MaxCacheTtl. Per ulteriori informazioni sulla chiave del Registro di sistema MaxCacheTtl, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
318803Come disattivare la cache DNS sul lato client in Windows XP e Windows Server 2003
Per ulteriori informazioni sulla terminologia di aggiornamento software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

ProprietÓ

Identificativo articolo: 833512 - Ultima modifica: martedý 15 aprile 2008 - Revisione: 10.1
Le informazioni in questo articolo si applicano a:
  • Microsoft Message Queuing 3.0
  • Microsoft Message Queuing 2.0
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows XP Professional
Chiavi:á
kbmt kbautohotfix kbhotfixserver kbtshoot kbwinxpsp2fix kbwin2000presp5fix kbbug kbfix kbwinxppresp2fix kbqfe KB833512 KbMtit
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Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 833512
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