Article ID: 833714 - Last Review: April 30, 2012 - Revision: 10.0

Error message when you try to edit an Office document in a document library: "'Edit Document' requires a Windows SharePoint Services-compatible application"

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For a Microsoft SharePoint Team Services from Microsoft version of this article, see 840024  (http://support.microsoft.com/kb/840024/ ) .

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SYMPTOMS

When you try to edit a Microsoft Office document that is stored in a document library of a Microsoft Windows SharePoint Services Web site, you may receive one of the following error messages, depending on the version of Office that you are running.

2007 Microsoft Office suites

'Edit Document' requires a Windows SharePoint Services-compatible application and Microsoft Internet Explorer 6.0 or greater.

Microsoft Office 2003 and earlier versions of Office

'Edit Document' requires a Windows SharePoint Services-compatible application and Microsoft Internet Explorer 5.0 or greater.
For example, you experience these symptoms if you click a Microsoft Word document in the document library, and then click Edit in Microsoft Office Word.

Additionally, when you click New Document in the document library, you may receive the following error message:
The document could not be created. The required application may not be installed properly, or the template for this Document Library cannot be opened. Please try the following: 1. Check the General Settings for this Document Library for the name of the template, and install the application necessary for opening the template. If the application was set to install on first use, run the application and then try creating a new document again. 2. If you have permission to modify this Document Library, go to General Settings for the library and configure a new template.

CAUSE

This issue may occur if one or more of the following conditions are true:
  • Microsoft Office XP or later is not installed on the computer.
  • Office XP or a later version of Office is installed on the computer. However, the SharePoint support component that is included in Office Tools is not installed on the computer.

    That is, either Microsoft SharePoint Support or Windows SharePoint Services Support (as appropriate to your version of Office) is not installed on the computer.
  • The Owssupp.dll file is not registered correctly in Microsoft Windows.

RESOLUTION

To resolve this issue, use one of the following methods, as appropriate for your situation.

Method 1: Install Office XP or a later version of Office

Install Office XP or a later version of Office on your computer. When you install Office, make sure that you also install the SharePoint support component that is included in Office Tools in the Setup program. In Office XP, this component is named Microsoft SharePoint Support. In Office 2003 and in later versions of Office, this component is named Windows SharePoint Services Support.

For more information about how to install the SharePoint support component that is included in Office Tools, see the "Method 2: Install SharePoint support" section.

Method 2: Install SharePoint support

To install SharePoint support, do one of the following, as appropriate to the version of Office that is installed on your computer.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

If Office XP is installed on the computer, follow these steps:
  1. Click Start, and then click Control Panel.
  2. Click Add or Remove Programs.
  3. In the list of currently installed programs, click Microsoft Office XP, and then click Change.
  4. Click Add or Remove Features - Change which features are installed or remove specific features, and then click Next.
  5. In the Features to install box, expand Office Tools, click the down arrow next to Microsoft SharePoint Support, and then click Run from My Computer.
  6. Click Update.
If Office 2003 is installed on the computer, follow these steps:
  1. Click Start, and then click Control Panel.
  2. Click Add or Remove Programs.
  3. In the list of currently installed programs, click Microsoft Office 2003, and then click Change.
  4. Click Add or Remove Features, and then click Next.
  5. Click to select the Choose advanced customization of application check box, and then click Next.
  6. In the Choose update options for applications and tools box, expand Office Tools, click the down arrow next to Windows SharePoint Services Support, and then click Run from My Computer.
  7. Click Update.
If a 2007 Office suite is installed on the computer, follow these steps:
  1. Click Start, and then click Control Panel.
  2. Click Add or Remove Programs.
  3. In the list of currently installed programs, click Microsoft Office suite 2007, and then click Change.
  4. Click Add or Remove Features, and then click Continue.
  5. Expand Office Tools.
  6. Click the down arrow next to Windows SharePoint Services Support, and then click Run from My Computer.
  7. Click Continue.

Method 3: Register the Owssupp.dll file

To have us register the Owssupp.dll file for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. In the File Download dialog box, click Run, and then follow the steps in the Fix it wizard.


Fix this problem
Microsoft Fix it 50667


Notes
  • The Fix it solution does not work if the Owssupp.dll file does not exist on your computer.
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

Note For Office 2003 and Office 2007 an error occurs in steps 4 and 6. This error is benign and the appropriate modifications have occurred. The error message reads similarly to: "DllRegisterServer in C:\Program Files\Microsoft Office\OFFICE11OWSSUPP.DLL failed. Return code was: 0x80070716.

  1. Click Start, and then click Run.
  2. In the Open box, type cmd, and then click OK.
  3. By default, the Owssupp.dll file is located in one the following folders, as appropriate for your version of Office:
    • If Office XP is installed on the computer: Drive:\Program Files\Microsoft Office\Office10
    • If Office 2003 is installed on the computer: Drive:\Program Files\Microsoft Office\Office11
    • If the 2007 Office suite is installed on the computer: Drive:\Program Files\Microsoft Office\Office12
  4. Type the following line, and then press ENTER:
    regsvr32 -u owssupp.dll
  5. Click OK when you receive the message that states that the operation was successful.
  6. Type the following line, and then press ENTER:
    regsvr32 owssupp.dll
  7. Click OK when you receive the message that states that the operation was successful.
  8. Type exit to exit Command Prompt.

    Did this fix the problem?

    • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support (http://support.microsoft.com/contactus) .
    • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me (http://blogs.technet.com/fixit4me/) " blog or send us an email (mailto:fixit4me@microsoft.com?Subject=KB) .

Method 4: Running a repair of Office 2003 or Office 2007

  1. Click Start, and then click Control Panel.
  2. Click Add or Remove Programs.
  3. In the list of currently installed programs, click Microsoft Office 2003 or Microsoft Office 2007, and then click Change.
  4. Click Reinstall or Repair.
  5. Click OK.

MORE INFORMATION

For more information about Windows SharePoint Services, visit the following Microsoft Web site:
http://technet.microsoft.com/windowsserver/sharepoint/default.aspx (http://technet.microsoft.com/windowsserver/sharepoint/default.aspx)

APPLIES TO
  • Microsoft Windows SharePoint Services 2.0
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Keywords: 
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