Article ID: 833889 - Last Review: July 24, 2007 - Revision: 2.6

Remote Administrators cannot browse collections, packages, or other nodes when connected to a Windows NT 4.0-based SMS 2.0 site server that has been upgraded to SMS 2.0 Service Pack 5

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SYMPTOMS

When you install Active Directory client extensions on a Microsoft Windows NT 4.0-based Systems Management Server (SMS) 2.0 site server computer that has been upgraded to SMS 2.0 Service Pack 5, remote SMS administrators can use the SMS Administrator console to connect to the site database. However, the SMS administrators cannot expand and browse collections, packages, or any other nodes in the SMS administrator console.

CAUSE

This problem occurs because of a change that was implemented in SMS 2.0 Service Pack 5 to support Microsoft Windows Server 2003 users. With this change, an external provider calls the GetUserNameEx function. Previously, the user name that was passed in by Windows Management Instrumentation (WMI) called the function. This change was necessary because the user name format that is used by WMI in Windows Server 2003 is in DNS format. SMS expects the domain\user format. However, on a Windows NT 4.0-based computer that has Active Directory client extensions installed, this change may cause the GetUserNameEx function to return an empty string for the user name.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   25-Feb-2003  21:50  2.0.1493.5180     290,784  Extnprov.dll     
   06-Aug-2000  09:51  2000.80.194.0     274,489  Ntwdblib.dll     
   23-Feb-2003  10:05  2.0.1493.5011     855,312  Preinst.exe      
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates


Note The following log entry in the Smsprov.log file on a Windows NT 4.0-based computer is expected and does not indicate a problem:
Error: Failed to LoadLibrary secur32.dll, error = 126. Using the user name passed from WMI

APPLIES TO
  • Microsoft Systems Management Server 2.0 Service Pack 5
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbsms200sp6fix kbfix kbbug KB833889