Un deadlock si verifica quando un programma che utilizza WMI chiama LoadLibrary() la o la funzione FreeLibrary() in Windows 2000

Traduzione articoli Traduzione articoli
Identificativo articolo: 834010 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo Ŕ stato archiviato. L?articolo, quindi, viene offerto ?cosý come Ŕ? e non verrÓ pi¨ aggiornato.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Si supponga che un programma di Microsoft ASP.NET o un programma che utilizza un provider di Strumentazione gestione Windows (WMI) effettua chiamate dirette o indirette per la funzione LoadLibrary o per la funzione FreeLibrary per caricare una DLL. Quindi, la DLL chiama il RegisterTraceGuids o la funzione UnRegisterTraceGuids nella funzione DllMain esportazione. In questo scenario, un blocco critico pu˛ verificarsi nel programma di ASP.NET o nel programma che utilizza un provider WMI.

Ad esempio, Microsoft Internet Explorer, Pannello di controllo e lo strumento Installazione applicazioni potrebbe non risponda (si blocchi) dopo l'installazione di Windows 2000 Service Pack 3 (SP3) o Service Pack 4 (SP4). Quando si arresta il servizio Registro di sistema remoto, in questo modo i programmi che non rispondono pi¨ per riprendere. Questo problema pu˛ verificarsi in ambienti in cui sono installata un soluzione, ad esempio PerfMan o SiteScope, di monitoraggio delle prestazioni remota.

Inoltre, quando si verifica questo problema, Microsoft Visual Basic script potrebbero non funzionare correttamente e viene non visualizzato alcun messaggio di errore. Inoltre, l'utilitÓ di pianificazione non pu˛ eseguire.

Cause

Questo problema pu˛ verificarsi dopo avere applicato l'hotfix descritto nel seguente articolo della Microsoft Knowledge Base riportato di seguito:
812714Gli utenti in modalitÓ remota non Ŕ possibile monitorare contatori del disco se non sono sono connessi come amministratori

Risoluzione

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico.

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta di servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

Prerequisiti

Non Ŕ richiesto alcun prerequisito.

NecessitÓ di riavvio

╚ necessario riavviare il computer dopo aver applicato questo hotfix.

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Date e ore per questi file sono indicati nella coordinated universal time (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
   Date         Time   Version            Size    File name
   ----------------------------------------------------------
   06-Feb-2004  22:28  5.0.2195.6862      73,488  Wmicore.dll      

Workaround

Per risolvere questo problema, arrestare il servizio Registro di sistema remoto e avviare Internet Explorer o il Pannello di controllo. Per arrestare il servizio Registro di sistema remoto, attenersi alla seguente procedura:
  1. Fare clic con il pulsante destro del mouse su Risorse del computer e quindi scegliere Gestisci
  2. In Gestione Computer espandere servizi e applicazioni e quindi fare clic su servizi .
  3. Nel riquadro servizi fare clic su Registro di sistema remoto e scegliere Arresta .

Informazioni

Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft
I prodotti di terze parti che in questo articolo viene descritto sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia, implicita o di altra natura, relativa alle prestazioni o all'affidabilitÓ di questi prodotti.

ProprietÓ

Identificativo articolo: 834010 - Ultima modifica: sabato 8 febbraio 2014 - Revisione: 7.5
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Chiavi:á
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbqfe kbwin2000presp5fix kbprb kbfix kbbug KB834010 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 834010
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com