Um impasse ocorre quando um programa que utiliza WMI chama o LoadLibrary() ou a função FreeLibrary() no Windows 2000

Traduções de Artigos Traduções de Artigos
Artigo: 834010 - Ver produtos para os quais este artigo se aplica.
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Suponha que um programa do Microsoft ASP.NET ou um programa que utiliza um fornecedor de Windows Management Instrumentation (WMI) efectua chamadas directas ou indirectas para a função LoadLibrary ou para a função FreeLibrary para carregar uma DLL. Em seguida, a DLL chamadas RegisterTraceGuids ou a função UnRegisterTraceGuids na função de exportação DllMain . Neste cenário, um bloqueio pode ocorrer no programa ASP.NET ou no programa que utiliza um fornecedor WMI.

Por exemplo, Microsoft Internet Explorer, painel de controlo e a ferramenta Adicionar/remover programas poderão deixar de responder (não reagir) depois de instalar o Microsoft Windows 2000 Service Pack 3 (SP3) ou Service Pack 4 (SP4). Quando pára o serviço Registo remoto, permite que os programas que deixaram de responder para continuar. Este problema poderá ocorrer em ambientes onde um desempenho remoto monitorização solução, tal como PerfMan ou SiteScope, está instalado.

Além disso, quando este problema ocorre, scripts do Microsoft Visual Basic podem não funcionar correctamente e não recebe nenhuma mensagem de erro. Além disso, não pode executar a ferramenta Programador de tarefas.

Causa

Este problema poderá ocorrer depois de aplicar a correcção descrita no seguinte artigo na base de dados de conhecimento da Microsoft:
812714Os utilizadores remotamente não é possível monitorizar contadores de disco se estes não iniciados sessão como administradores

Resolução

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentada, submeta um pedido para o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisito de reinício

Tem de reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas no formato de universal hora (UTC) coordenada Coordinated. Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário na ferramenta Data e hora no painel de controlo.
   Date         Time   Version            Size    File name
   ----------------------------------------------------------
   06-Feb-2004  22:28  5.0.2195.6862      73,488  Wmicore.dll      

Como contornar

Para contornar este problema, pare o serviço Registo remoto e reinicie o Internet Explorer ou o painel de controlo. Para parar o serviço Registo remoto, siga estes passos:
  1. Clique com o botão direito do rato em Meu computador e, em seguida, clique em Gerir
  2. Em Gestão de computadores , expanda Serviços e aplicações e, em seguida, clique em Serviços .
  3. No painel Serviços , clique em Registo remoto e, em seguida, clique em Parar .

Mais Informação

Para obter informações adicionais, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft
Os produtos de outros fabricantes explicado neste artigo são fabricados por empresas independentes da Microsoft. A Microsoft não oferece nenhuma garantia, expressa ou implícita, relativamente ao desempenho ou fiabilidade destes produtos.

Propriedades

Artigo: 834010 - Última revisão: 3 de fevereiro de 2014 - Revisão: 7.5
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Palavras-chave: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbqfe kbwin2000presp5fix kbprb kbfix kbbug KB834010 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 834010

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com