Um deadlock ocorre quando um programa que usa o WMI chama o LoadLibrary() ou a função FreeLibrary() no Windows 2000

Traduções deste artigo Traduções deste artigo
ID do artigo: 834010 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Suponha que um programa do Microsoft ASP.NET ou um programa que usa um provedor de WMI (Instrumentação de gerenciamento do Windows) faz chamadas diretas ou indiretas para a função LoadLibrary ou para a função FreeLibrary para carregar uma DLL. Em seguida, a DLL chama RegisterTraceGuids ou a função UnRegisterTraceGuids na função de exportação DllMain . Nesse cenário, um deadlock pode ocorrer no programa de ASP.NET ou no programa que usa um provedor de WMI.

Por exemplo, Microsoft Internet Explorer, painel de controle e a ferramenta Adicionar ou remover programas podem parar de responder (paralisar) após a instalação do Microsoft Windows 2000 Service Pack 3 (SP3) ou Service Pack 4 (SP4). Quando você parar o serviço Registro remoto, isso permite que os programas que têm parou de responder para continuar. Esse problema pode ocorrer em ambientes onde um solução, como PerfMan ou SiteScope, de monitoramento de desempenho remoto está instalado.

Além disso, quando esse problema ocorre, scripts do Microsoft Visual Basic podem não funcionar corretamente, e você não receber nenhuma mensagem de erro. Além disso, a ferramenta Agendador de tarefas não pode executar.

Causa

Esse problema pode ocorrer depois de aplicar o hotfix descrito no seguinte artigo na Base de dados de Conhecimento da Microsoft:
812714Os usuários remotamente não é possível monitorar contadores de disco se eles não estiverem conectados como administradores

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibido, envie uma solicitação para suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version            Size    File name
   ----------------------------------------------------------
   06-Feb-2004  22:28  5.0.2195.6862      73,488  Wmicore.dll      

Como Contornar

Para contornar esse problema, interromper o serviço Registro remoto e inicie o Internet Explorer ou no painel de controle. Para interromper o serviço Registro remoto, execute estas etapas:
  1. Clique com o botão direito do mouse Meu computador e, em seguida, clique em Gerenciar
  2. Em Gerenciamento do computador , expanda Serviços e aplicativos e em seguida, clique em serviços .
  3. No painel de serviços , clique em Registro remoto e, em seguida, clique em Parar .

Mais Informações

Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software
Os produtos de terceiros mencionados neste artigo são fabricados por empresas que são independentes da Microsoft. A Microsoft não oferece garantia, implícita ou não, em relação ao desempenho ou à confiabilidade desses produtos.

Propriedades

ID do artigo: 834010 - Última revisão: sábado, 26 de outubro de 2013 - Revisão: 7.5
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Palavras-chave: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbqfe kbwin2000presp5fix kbprb kbfix kbbug KB834010 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 834010

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com