WMI kullanan bir program Windows 2000'de LoadLibrary() veya FreeLibrary() işlevini çağırdığında, kilitlenme oluşuyor

Makale çevirileri Makale çevirileri
Makale numarası: 834010 - Bu makalenin geçerli olduğu ürünleri görün.
Bu makale arşivlenmiştir. "Olduğu gibi" sunulmaktadır ve bundan sonra güncelleştirilmeyecektir.
Hepsini aç | Hepsini kapa

Bu Sayfada

Belirtiler

Bir Microsoft ASP.NET program ya da bir Windows Yönetim Gereçleri (WMI) sağlayıcısını kullanan bir program doğrudan veya dolaylı FreeLibrary işlevi, bir DLL yüklenemedi veya LoadLibrary işlevini çağrılar olduğunu varsayalım. Ardından, DLL DllMain verme işlevi RegisterTraceGuids veya UnRegisterTraceGuids işlevini çağırır. Bu senaryoda, ASP.NET program veya bir WMI Sağlayıcısı'nı kullanan bir program bir kilitlenme oluşabilir.

Örneğin, Microsoft ınternet Explorer, Denetim Masası ve Program Ekle/Kaldır aracı, Microsoft Windows 2000 Service Pack 3 (SP3) veya Service Pack 4 (SP4) yüklendikten sonra (askıda kalabilir) yanıt vermeyebilir. Bu, Uzak Kayıt Defteri hizmetini durdurduğunuzda, devam etmek için yanıt vermeyen programlar verir. Çözüm, PerfMan veya SiteScope, izleme, uzak bir performans'ın yüklü olduğu ortamlarda, bu sorun oluşabilir.

Ayrıca, bu sorun oluştuğunda, Microsoft Visual Basic komut dosyaları doğru çalışmayabilir ve hiçbir hata iletisi alırsınız. Ayrıca, Görev Zamanlayıcısı aracını çalışmayabilir.

Neden

Bu sorun, Microsoft Bilgi Bankası'ndaki aşağıdaki makalede açıklanan düzeltmeyi uyguladıktan sonra oluşabilir:
812714Kullanıcılar Yönetici Olarak Oturum Açtıklarında Disk Sayaçlarını Uzaktan İzleyemiyor

Çözüm

Düzeltme bilgileri

Desteklenen bir düzeltme Microsoft'tan edinilebilir. Ancak bu düzeltmenin, yalnızca bu makalede anlatılan sorunu gidermesi amaçlanmıştır. Bu düzeltmeyi yalnızca bu sorunla karşılaşan sistemlere uygulayın.

Düzeltme karşıdan yüklenebilir ise bu Bilgi Bankası makalesinin başında "Düzeltme karşıdan yüklenebilir" bölümü bulunur. Bu bölüm görünmüyorsa, düzeltmeyi edinmek üzere Microsoft Müşteri Hizmetleri ve Destek ekibine bir istekte bulunun.

Not Ek sorunlar oluşursa veya tüm sorun giderme işlemi gerekmiyorsa, ayrı bir hizmet isteği oluşturmanız gerekebilir. Ek destek sorularına ve bu düzeltme için geçerli olmayan sorunlara normal destek ücretleri uygulanır. Microsoft Müşteri Hizmetleri ve Destek telefon numaralarının tam listesi veya ayrı bir hizmet isteği oluşturmak için, aşağıdaki Microsoft Web sitesini ziyaret edin:
http://support.microsoft.com/contactus/?ws=support
Not "Düzeltme karşıdan yüklenebilir" formunda, düzeltmenin kullanılabilir olduğu diller görüntülenir. Kendi dilinizi görmüyorsanız, bunun nedeni bu düzeltme, seçtiğiniz dil için kullanılamaz.

ÖNKOŞULLAR

Herhangi bir önkoşul bulunmamaktadır.

Yeniden başlatma gereksinimi

Bu düzeltmeyi yükledikten sonra bilgisayarınızı yeniden başlatmanız gerekir.

Düzeltme Değiştirme Bilgileri

Bu düzeltme başka bir düzeltmenin yerini almaz.

DOSYA BİLGİLERİ

Bu düzeltmenin İngilizce sürümü, aşağıdaki tabloda listelenen dosya özniteliklerine (veya daha yeni dosya özniteliklerine) sahiptir. Bu dosyaların tarihleri ve saatleri Koordinatlı Evrensel Saat'e (UTC) göre listelenir. Dosya bilgilerini görüntülediğinizde yerel saate dönüştürülür. UTC ve yerel saat arasındaki farkı bulmak için <a0></a0>, Denetim Masası'ndaki Tarih ve Saat aracında saat dilimi sekmesini kullanın.
   Date         Time   Version            Size    File name
   ----------------------------------------------------------
   06-Feb-2004  22:28  5.0.2195.6862      73,488  Wmicore.dll      

Pratik Çözüm

Bu soruna geçici bir çözüm bulmak için <a0></a0>, Uzak Kayıt Defteri hizmetini durdurun ve sonra ınternet Explorer'ı veya Denetim Masası'nı başlatın. Uzak Kayıt Defteri hizmetini durdurmak için aşağıdaki adımları izleyin:
  1. Bilgisayarım ' ı sağ tıklatın ve sonra Yönet ' i tıklatın.
  2. Bilgisayar Yönetimi altındaki Hizmetler ve uygulamalar'ı genişletin ve sonra Hizmetler'i tıklatın.
  3. Hizmetleri bölmesinde Uzak kayıt defteri ' ni tıklatın ve sonra da <a2>Durdur</a2>'ı tıklatın.

Daha fazla bilgi

Ek bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
824684Microsoft yazılım güncelleştirmelerini açıklamak için kullanılan standart terminolojinin açıklaması
Bu makalede adı geçen üçüncü taraf ürünleri Microsoft'tan bağımsız şirketler tarafından üretilmektedir. Microsoft bu ürünlerin performans veya güvenilirliğiyle ilgili hiçbir garanti vermemektedir.

Özellikler

Makale numarası: 834010 - Last Review: 3 Şubat 2014 Pazartesi - Gözden geçirme: 7.5
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Anahtar Kelimeler: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbwin2000presp5fix kbprb kbfix kbbug KB834010 KbMttr
Machine-translated Article
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:834010

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com