El acceso a recursos de red es más lento en Windows XP que en versiones anteriores de Windows

Seleccione idioma Seleccione idioma
Id. de artículo: 834350 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

En un equipo basado en Microsoft Windows XP, puede experimentar más lenta de acceso a recursos de red que experimenta en un equipo basado en Microsoft Windows 2000. Por ejemplo, si ejecuta un programa de aplicaciones para usuario de base de datos de Microsoft Access en un equipo basado en Windows XP, este programa puede tener acceso a la base de datos de back-end más lento que cuando se ejecuta el mismo programa de acceso en un equipo basado en Windows 2000.

Causa

Este problema se produce si los archivos de red utilizan la sintaxis de nombre de archivo largo en lugar de la sintaxis de nombre de archivo corto 8.3. En concreto, el componente redirector de bloque de mensajes de servidor (SMB) de Windows XP no almacena en caché información de ruta de acceso de los nombres de archivo largos. En esta situación, Windows XP envía dos paquetes SMB para cada GetFileAttributes llamada a función.

Solución

Información del Service pack

Para resolver este problema, obtenga el service pack más reciente para Windows XP. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389 Cómo obtener el service pack más reciente para Windows XP

Información de la revisión

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplicar esta revisión sólo a los sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, se recomienda que espere la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de la revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si necesita solucionar un problema, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión en cuestión. Para obtener una lista completa de los números de teléfono de soporte técnico y servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para los que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Debe tener Windows XP Service Pack 1 instalado para poder aplicar este hotfix. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente para Windows XP

Requisito de reinicio

Debe reiniciar el equipo después de aplicar esta revisión.

Información de sustitución de la revisión

Este hotfix no sustituye a ninguna otra revisión.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o posterior) que se enumeran en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Cuando vea la información de archivo, se convierte en hora local. Para ver la diferencia entre la hora UTC y la hora local, utilice el Zona horaria ficha de la herramienta fecha y hora en el Panel de Control.
Ediciones de Windows XP de 32 bits
 Date           Time   Version        Size    File name 
-------------------------------------------------------------- 
07-Jul-2004     02:25  5.1.2600.1547  92,160  Cscdll.dll 
07-Jul-2004     02:15  5.1.2600.1551 426,112  Mrxsmb.sys 
07-Jul-2004     02:15  5.1.2600.1547 166,016  Rdbss.sys
Ediciones de Windows XP 64-bit
Date         Time    Version          Size      File name
---------------------------------------------------------------------------
07-Jul-2004  03:29   5.1.2600.1547    237,056   Cscdll.dll IA-64     SP1QFE  
07-Jul-2004  02:19   5.1.2600.1551  1,287,552   Mrxsmb.sys IA-64     SP1QFE  
26-Jun-2004  13:48   5.1.2600.1547    495,616   Rdbss.sys IA-64      SP1QFE  
07-Jul-2004  03:25   5.1.2600.1547     92,160   Wcscdll.dll x86       WOW 


Importante Esta sección, el método o la tarea contiene pasos que le indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, copia de seguridad del registro antes de modificarlo. Luego puede restaurar el registro si surge algún problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Cómo hacer copia de seguridad y restaurar el registro en Windows
Importante Además de instalar la revisión anterior, debe agregar la siguiente información al registro para resolver este problema. Para ello, siga estos pasos:
  1. Haga clic en Inicio, haga clic en Ejecutar, tipo Regedit en el Abrir cuadro y, a continuación, haga clic en ACEPTAR.
  2. Busque y haga clic en la siguiente clave del registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MrxSmb\Parameters
  3. Haga clic en Editar, haga clic en Nuevoy, a continuación, haga clic en Valor DWORD.
  4. Tipo InfoCacheLevel Para reemplazar Nuevo valor #1, y, a continuación, presione ENTRAR.
  5. Haga clic en el InfoCacheLevel Valor DWORD en el panel derecho, haga clic en Editary, a continuación, haga clic en Modificar.
  6. Bajo Información del valor, seleccione hexadecimal y escriba 10y, a continuación, haga clic en ACEPTAR.
  7. Salga del Editor del registro.

    NotaInfoCacheLevel puede tener cualquiera de los siguientes valores en notación hexadecimal. El valor predeterminado es 1.
    • 0 = Deshabilita el almacenamiento en caché para todos los archivos y carpetas
    • 1 = Habilita el almacenamiento en caché para archivos con nombre de archivo corto (8.3) - valor por defecto
    • 10 = Permite almacenar en caché para todos los archivos

Solución

Para solucionar temporalmente este problema, utilice la sintaxis para cambiar el nombre de los archivos en red de nomenclatura 8.3.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Más información

Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 834350 - Última revisión: miércoles, 16 de enero de 2013 - Versión: 7.0
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition
Palabras clave: 
kbautohotfix kbHotfixServer kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug kbmt KB834350 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 834350

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com