Nástroj pro odstranění skrytých dat pro sadu Office 2003 a Office XP

Překlady článku Překlady článku
ID článku: 834427 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Nástroj pro odstranění skrytých dat je možné použít k odstranění osobních nebo skrytých dat, která nemusí být v dokumentu aplikace sady Microsoft Office ihned viditelná.

Nástroj pro odstranění skrytých dat lze spustit pro jednotlivé soubory v aplikaci sady Microsoft Office XP nebo Microsoft Office 2003. Tento nástroj lze také spustit pro více souborů najednou z příkazového řádku. Aby bylo možné nástroj spustit, musí být v obou případech v počítači nainstalovaný program, kterým byl dokument vytvořen.

Poznámka: Otevřete-li v aplikaci Word nebo Excel soubory, které byly uloženy pomocí Nástroje pro odstranění skrytých dat, zobrazí se následující dialogové okno:
Soubor <nazev_souboru> by měl být otevřen jen pro čtení, pokud v něm nepotřebujete uložit změny. Otevřít jen pro čtení?
Pokud klepnete na tlačítko Ano, soubor nebude možné upravovat. Pokud klepnete na tlačítko Ne, soubor bude možné upravovat. Bude možné zadat nová metadata.

Další informace o Nástroji pro odstranění skrytých dat a o jeho získání naleznete na následujícím webu společnosti Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyId=144E54ED-D43E-42CA-BC7B-5446D34E5360&displaylang=cs
Další informace o dalších známých problémech a tématech nepopsaných v souboru ReadMe naleznete v následujících článcích znalostní báze Microsoft Knowledge Base:
834636 Známé problémy týkající se Nástroje pro odstranění skrytých dat pro sady Office 2003 a Office XP (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
842684 Známé problémy týkající se Nástroje pro odstranění skrytých dat verze 1.1 pro sady Office 2003 a Office XP (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Chcete-li zjistit verzi Nástroje pro odstranění skrytých dat nainstalovanou v počítači, postupujte takto:
  1. Klepněte na tlačítko Start a potom na příkaz Ovládací panely.
  2. Klepněte na panel Přidat nebo odebrat programy.
  3. V seznamu aktuálně nainstalovaných programů klepněte na položku Nástroj pro odstranění skrytých dat a potom klepněte na odkaz Klepnutím zde zobrazíte informace o podpoře.
  4. Podle následující tabulky určete verzi vydání Nástroje pro odstranění skrytých dat nainstalovanou v počítači.

    Zmenšit tuto tabulkuRozšířit tuto tabulku
    Verze vydáníVerze
    Nástroj pro odstranění skrytých dat 1.111.0.6361.0
    Nástroj pro odstranění skrytých dat 1.06.00.2600.0000

Další informace

Následující text je obsah souboru ReadMe z Nástroje pro odstranění skrytých dat. Tento soubor naleznete po instalaci nástroje v následující složce:
cesta\Program Files\Microsoft Office\Remove Hidden Data Tool\1033

Soubor Readme sady Microsoft Office 2003: Nástroj pro odstranění skrytých dat

© 2003 Microsoft Corporation. Všechna práva vyhrazena.

Tento dokument obsahuje nejnovější informace o doplňku pro odstranění skrytých dat sady Microsoft Office 2003. V části Obsah je uveden přehled všech informací obsažených v tomto souboru. Nejnovější informace specifické pro jednotlivé produkty sady Office naleznete v souborech Readme k těmto produktům.

Nástroj pro odstranění skrytých dat je doplněk pro sady Microsoft Office 2003 nebo Microsoft Office XP, který uživatelům umožňuje trvale odstranit skrytá data a data spolupráce ze souborů aplikací Microsoft Word, Microsoft Excel a Microsoft PowerPoint.

Použití tohoto dokumentu

Chcete-li soubor Readme zobrazit na obrazovce, maximalizujte okno prohlížeče. Chcete-li soubor Readme vytisknout, klepněte na tlačítko Tisk na panelu nástrojů.

Obsah

Přehled

Pokud elektronicky distribuujete dokumenty sady Office, může se stát, že dokumenty obsahují informace, které nechcete sdílet veřejně, například informace umožňující spolupracovat při vytváření a úpravách dokumentů s ostatními uživateli nebo skryté informace, na jejichž základě lze zjistit, kdo s dokumentem pracoval.

Nástroj pro odstranění skrytých dat lze použít k odebrání osobních nebo skrytých informací, které nemusí být bezprostředně patrné při prohlížení dokumentu v aplikaci sady Microsoft Office.

Nástroj pro odstranění skrytých dat lze pro jednotlivé dokumenty spustit v rámci aplikace sady Office XP nebo Office 2003. Další možností je spustit Nástroj pro odstranění skrytých dat hromadně pro několik souborů z příkazového řádku. V obou případech je ke spuštění nástroje nutné, aby v počítači byla nainstalovaná aplikace, v níž byl dokument vytvořen.

Poznámky

Nástroj pro odstranění skrytých dat byste měli pro jednotlivé soubory spustit až v okamžiku, kdy jste připraveni je publikovat. Důvodem je skutečnost, že nástroj odstraňuje některá data využívaná v rámci sady Office pro funkce spolupráce, jako jsou funkce Sledování změn, Komentáře nebo Odeslat na revizi, a po odstranění skrytých dat nebudou tyto funkce spolupráce fungovat.

Nástroj pro odstranění skrytých dat je navržen k odebrání určitých typů dat ze souborů sady Office, a to trvale, automaticky a bez zobrazení výzvy k potvrzení prováděné operace. Ve výchozím nastavení nástroj vyzve uživatele k uložení souboru pod novým názvem.

Změněný soubor byste vždy měli ukládat pod novým názvem a nepřepisovat původní soubor novým dokumentem. Zachováte tak kopii souboru obsahující původní data.

Chcete-li změnit jazyk, který Nástroj pro odstranění skrytých dat používá, je třeba nástroj odinstalovat a stáhnout novou kopii Nástroje pro odstranění skrytých dat v požadovaném jazyce. Nová jazyková verze po dokončení instalace nahradí původní verzi nástroje. Všechny kopie Nástroje pro odstranění skrytých dat v libovolném jazyce však obsahují anglickou verzi, a podporují tak použití z příkazového řádku.

Tento nástroj nemůže odebrat skrytá data z následujících typů souborů:
  • dokumenty používající oprávnění správy přístupových práv,
  • zamčené dokumenty,
  • dokumenty s digitálním podpisem,
  • sdílené sešity.
Pokud se pokusíte spustit tento nástroj pro soubor splňující nejméně jednu z těchto podmínek, bude nástroj ukončen a zobrazí se chybová zpráva. Původní soubor zůstane nezměněn.

Požadavky na systém

Podporované operační systémy: Microsoft Windows XP SP1 nebo novější, Microsoft Windows 2000 SP4 nebo novější nebo Microsoft Windows Server 2003

Tento software ke stažení lze použít pro následující aplikace sady Office:
  • Microsoft Office Word 2003,
  • Microsoft Office Excel 2003,
  • Microsoft Office PowerPoint 2003,
  • Microsoft Word 2002 SP2 nebo novější,
  • Microsoft Excel 2002 SP2 nebo novější,
  • Microsoft PowerPoint 2002 SP2 nebo novější.
Chcete-li doplněk spustit, musíte mít nainstalovanou aplikaci, v níž byl příslušný dokument vytvořen. Dále musí být používaná verze sady Office stejná nebo novější než verze dokumentu, pro který chcete Nástroj pro odstranění skrytých dat spustit. Můžete například spustit nástroj pro dokument sady Office 2000 pomocí sady Office 2003, ale nemůžete jej spustit pro dokument sady Office 2003 pomocí sady Office XP.

Nástroj pro odstranění skrytých dat lze použít pro dokumenty aplikace Word, tabulky aplikace Excel, prezentace aplikace PowerPoint a také pro webové stránky a jednosouborové webové stránky vytvořené pomocí aplikace Word, Excel nebo PowerPoint. Nelze jej použít pro ostatní formáty dokumentů.

Typy dat, které lze tímto nástrojem odebrat

Následující typy dat jsou odebrány automaticky.
  • komentáře,
  • předchozí autoři a editoři,
  • uživatelské jméno,
  • osobní souhrnné informace,
  • značky revize – nástroj přijme všechny revize označené v dokumentu. Následkem toho bude obsah dokumentu odpovídat zobrazení Konečný se značkami na panelu nástrojů Revize,
  • odstraněný text – tato data jsou odebrána automaticky,
  • verze,
  • makra v jazyce VB – z modulů budou odstraněny popisy a komentáře,
  • číslo ID sloužící k identifikaci dokumentu pro účely sloučení změn zpět do původního dokumentu,
  • směrovací adresy,
  • záhlaví e-mailových zpráv,
  • komentáře ke scénářům,
  • jedinečné identifikátory (pouze dokumenty sady Office 97).
Poznámka: Nástroj pro odstranění skrytých dat rovněž zapne funkci Odebrat osobní informace. Chcete-li získat další informace o této funkci, vyhledejte v nápovědě k aplikaci téma Odebrání osobních informací.

Známé problémy

  • Excel: V aplikaci Excel 2002 nejsou cesty k tiskárnám odebírány, v aplikaci Excel 2003 však ano.
  • Excel: Může se stát, že z jednosouborové webové stránky aplikace Excel nebude odebrán odkaz na externí sešit.
  • Pokud je Nástroj pro odstranění skrytých dat nečekaně ukončen, může se zobrazit prázdné okno programu Poznámkový blok a v dočasném adresáři může zůstat ponechán soubor protokolu. Chcete-li zavřít okno programu Poznámkový blok, použijte příkaz Konec v nabídce Soubor. Chcete-li odebrat soubor protokolu, odstraňte obsah dočasného adresáře ve složce místního nastavení.
  • Pokud Nástroj pro odstranění skrytých dat ukončíte dříve, než dokončí kontrolu souboru, mohou v cílovém adresáři zůstat některé dočasné soubory. Chcete-li tyto soubory odebrat, odstraňte je z cílového adresáře.
  • Jednosouborové webové stránky, které byly tímto nástrojem zkontrolovány, mohou obsahovat název náhodně vytvořeného dočasného souboru ve tvaru file:///c:/<číslo>/. Číslo použité v tomto názvu je založeno na názvu souboru jednosouborové webové stránky a nelze jej použít k identifikaci vašeho počítače.
  • Existující skrytá náhodná čísla používaná ke zvýšení přesnosti sloučení a ukládaná v souborech aplikace Word nebudou odebrána.
  • Pokud spustíte Nástroj pro odstranění skrytých dat z příkazového řádku, nebude fungovat pro dokumenty XML vytvořené v aplikaci Word, Excel nebo PowerPoint.

Základní použití

Po dokončení instalace Nástroje pro odstranění skrytých dat otevřete dokument, který chcete zkontrolovat, a pak v nabídce Soubor klepněte na příkaz Odstranit skrytá data.

Poznámka: Pokud se příkaz Odstranit skrytá data v nabídce Soubor nezobrazí, postupujte takto:
  1. V nabídce Nástroje klepněte na příkaz Možnosti a pak klepněte na kartu Zabezpečení.
  2. Ve skupinovém rámečku Zabezpečení maker klepněte na tlačítko Zabezpečení maker.
  3. Klepněte na kartu Důvěryhodné zdroje.
  4. Zaškrtněte políčko Důvěřovat všem nainstalovaným doplňkům a šablonám a pak dvakrát klepněte na tlačítko OK.
Po zadání názvu souboru nástroj odstraní skrytá data automaticky. Další informace naleznete v části Typy dat, které lze tímto nástrojem odebrat.

Poznámky

Změněný soubor byste vždy měli ukládat pod novým názvem a nepřepisovat původní soubor novým dokumentem. Zachováte tak kopii souboru obsahující původní data.

Nástroj pro odstranění skrytých dat nepodporuje ukládání dokumentů jako šablon.

Příkazový řádek

Chcete-li Nástroj pro odstranění skrytých dat spustit z příkazového řádku, postupujte takto:
  1. Před spuštěním nástroje příkazového řádku ukončete všechny instance aplikací Excel, Word, Outlook a PowerPoint.
  2. V nabídce Start klepněte na příkaz Spustit.
  3. Zadejte příkaz cmd a potom stiskněte klávesu ENTER.
  4. Přejděte do adresáře, který obsahuje soubor OFFRHD.EXE. Ve výchozím nastavení se jedná o adresář, do kterého jste nainstalovali Nástroj pro odstranění skrytých dat.
  5. Na příkazovém řádku zadejte syntaxi úlohy, kterou chcete provést.
Poznámky

Přestože aplikace dokumentu není viditelná, běží na pozadí. Pokud aplikace otevře dialogové okno, Nástroj pro odstranění skrytých dat bude pozastaven, dokud se dialogové okno nezavře. Pokud dialogové okno zůstane otevřeno déle než 120 sekund, bude aplikace ukončena a Nástroj pro odstranění skrytých dat přejde k dalšímu souboru nebo se ukončí (pokud zpracoval poslední soubor).

Jako příznak uvádějící parametry můžete zadat buď lomítko (/), nebo pomlčku (-). V příznacích nejsou rozlišována velká a malá písmena.

Pokud zadáte více příznaků, bude rozpoznán pouze první z nich.

Musíte nejprve zadat parametr /zdroj a za ním nepovinný parametr /cíl. Všechny ostatní parametry můžete zadávat v libovolném pořadí.

Pokud za názvem zdrojového adresáře uvedete lomítko (/), dojde v nástroji k chybě.

Syntaxe příkazu OFFRHD.EXE:
OFFRHD [/?] zdroj [cíl] [/O] [/R] [/F:typ_souboru] [/L: soubor_protokolu] [/A]
Zmenšit tuto tabulkuRozšířit tuto tabulku
ParametrPopis
zdrojPovinné. Určuje jednotku, adresář a soubory, pro které chcete odebrat osobní údaje. Tímto parametrem může být libovolná platná úplná cesta.
cílNepovinné. Určuje umístění prohledaných souborů. Pokud tento parametr nezadáte, budou všechny soubory uloženy do stejného adresáře s příponou představující aktuální datum. Příklad: -C010503 by představovalo 5. ledna 2003. Pokud cílový soubor již existuje, bude přepsán.
/OUrčuje, že nebude zobrazena žádná výzva k potvrzení, že chcete přepsat existující soubor.
/RUrčuje, že bude prohledán obsah zdrojového adresáře a jeho podadresářů.
/F:typ_souboruUrčuje formát cílových souborů.
/F:HUrčuje formát HTML.
/F:MUrčuje formát MHTML.
/F:BUrčuje binární formát dokumentu. Pokud tento parametr nezadáte, bude soubor ve výchozím nastavení uložen ve stejném formátu jako zdrojový soubor.
/L:soubor_protokoluUrčuje umístění k uložení souboru protokolu. Pokud tento parametr nezadáte, bude po dokončení práce nástroje protokol zobrazen.
/AUrčuje, že nástroj vytvoří hlášení o problémech, které byly v souboru nalezeny, ale neodebere žádná data.
/:?Zobrazí seznam všech parametrů, které jsou k dispozici.

Soubor protokolu

Jakmile Nástroj pro odstranění skrytých dat dokončí kontrolu souborů, zobrazí se soubor protokolu s výsledky kontroly. Tento soubor můžete uložit pro pozdější použití.

Použití Nástroje pro odstranění skrytých dat technologií IRM

V rámci sady Office 2003 nelze používat Nástroj k odstranění skrytých dat u dokumentů chráněných technologií IRM, pokud nejste vlastníky dokumentu nebo nemáte oprávnění ke změnám s možností přístupu k obsahu prostřednictvím kódu programu.

Chcete-li poskytnout oprávnění ke spuštění Nástroje pro odstranění skrytých dat pro dokumenty chráněné technologií IRM, postupujte takto:
  1. V nabídce Soubor klepněte na příkazy Oprávnění, Omezit oprávnění jako.
  2. Vyberte uživatelský účet (zpravidla vlastní), který chcete použít k vytvoření nebo otevření obsahu, a pak klepněte na tlačítko OK.
  3. V dialogovém okně Oprávnění klepněte na tlačítko Další možnosti.
  4. Nyní klepněte na uživatelský účet, kterému chcete udělit přístup. (Uživatelský účet musí mít pro dokument oprávnění ke změně, jinak nebude možné Nástroj pro odstranění skrytých dat použít.)
  5. Klepněte na možnost Přístup k obsahu prostřednictvím kódu programu a pak klepněte na tlačítko OK.

Vlastnosti

ID článku: 834427 - Poslední aktualizace: 28. května 2007 - Revize: 3.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Word 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
Klíčová slova: 
kbcommandline kbconfig kbtooltip kbinfo KB834427

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com