Outil de suppression des métadonnées de Microsoft Office 2003 et Office XP

Traductions disponibles Traductions disponibles
Numéro d'article: 834427 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Résumé

Le complément de suppression des métadonnées est un outil que vous pouvez utiliser pour supprimer des données personnelles ou masquées qui pourraient ne pas être immédiatement visibles lorsque vous consultez le document dans votre programme Microsoft Office.

Vous pouvez exécuter le complément de suppression des métadonnées sur des fichiers individuels à partir de votre programme Microsoft Office XP ou Microsoft Office 2003. Vous pouvez également exécuter le complément sur plusieurs fichiers simultanément à partir de la ligne de commande. Dans les deux cas, pour pouvoir exécuter l'outil, le programme que vous avez utilisé pour créer le document doit être installé.

Remarque La boîte de dialogue suivante s'affiche dans Word et dans Excel lorsque vous ouvrez des fichiers qui ont été sauvegardés à l'aide de l'outil de suppression des métadonnées :
<nom_fichier> devrait être ouvert en lecture seule, sauf si des modifications doivent y être apportées. Ouvrir en lecture seule ?
Si vous cliquez sur Oui, le fichier ne sera pas modifiable. Si vous cliquez sur Non, le fichier sera modifiable. Cela permet l'entrée de nouvelles métadonnées.

Pour plus d'informations sur le complément de suppression des métadonnées et sur la façon de l'obtenir, reportez-vous au site Web de Microsoft à l'adresse suivante (en anglais) :
http://www.microsoft.com/downloads/details.aspx?displaylang=fr&FamilyID=144e54ed-d43e-42ca-bc7b-5446d34e5360
Pour plus d'informations sur d'autres problèmes connus et d'autres thèmes qui ne sont pas abordés dans le fichier Lisezmoi, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft.
834636 Problèmes connus relatifs au complément de suppression des métadonnées de Microsoft Office 2003 et Office XP
842684 Problèmes connus relatifs à la version 1.1 du complément de suppression des métadonnées de Microsoft Office 2003 et Office XP

Pour déterminer la version de l'outil de suppression des métadonnées installée sur votre ordinateur, procédez comme suit :
  1. Cliquez sur Démarrer, puis sur Panneau de configuration.
  2. Cliquez sur Ajout/Suppression de programmes.
  3. Dans la liste de programmes installés actuellement, cliquez sur Outil de suppression des métadonnées, puis sur le lien Cliquer ici pour obtenir des informations sur le support technique.
  4. Consultez le tableau suivant pour déterminer la version de l'outil de suppression des métadonnées installée.

    Réduire ce tableauAgrandir ce tableau
    Version commercialeNuméro de version
    Outil de suppression des métadonnées 1.111.0.6361.0
    Outil de suppression des métadonnées 1.06.00.2600.0000

Plus d'informations

Le document ci-dessous constitue le fichier Lisezmoi du complément de suppression des métadonnées. Ce fichier Lisezmoi est situé dans le dossier suivant après l'installation du complément de suppression des métadonnées :
chemin\Program Files\Microsoft Office\Remove Hidden Data Tool\1036

Fichier Lisezmoi de Microsoft Office 2003 : Complément de suppression des métadonnées

© 2003 Microsoft Corporation. Tous droits réservés.

Ce document fournit des informations de dernière minute sur le complément de suppression des métadonnées de Microsoft Office 2003. La section Sommaire répertorie l'ensemble des informations contenues dans ce fichier ; pour obtenir les dernières informations spécifiques à un produit système Office particulier, consultez le fichier Lisezmoi relatif à ce produit.

L'outil de suppression des métadonnées est un complément des éditions de Microsoft Office 2003 ou de Microsoft Office XP qui permet aux utilisateurs de supprimer définitivement des données masquées et des données de collaboration de leurs fichiers Microsoft Word, Microsoft Excel et Microsoft PowerPoint.

Comment utiliser ce document

Pour afficher le fichier Lisezmoi à l'écran, agrandissez la fenêtre de l'explorateur. Pour l'imprimer, cliquez sur le bouton Imprimer de la barre d'outils.

Sommaire

Présentation

Lorsque vous distribuez un document Office électroniquement, le document peut contenir des informations que vous ne souhaitez pas partager publiquement, telles que des informations qui vous permettent de collaborer à la rédaction ou à la modification du document, ou des informations masquées qui permettent d'effectuer le suivi des personnes qui ont travaillé sur le document.

Le complément de suppression des métadonnées est un outil qui vous permet de supprimer des informations personnelles ou masquées qui pourraient ne pas être immédiatement visibles lorsque vous visualisez le document dans l'application Microsoft Office.

Vous pouvez exécuter le complément de suppression des métadonnées sur des fichiers individuels à partir d'une application Office XP ou Office System 2003. Vous pouvez également l'exécuter sur plusieurs fichiers à partir de la ligne de commande. Dans les deux cas, l'application qui a servi à créer le document doit être installée pour que vous puissiez exécuter l'outil.

Remarques

Exécutez le complément de suppression des métadonnées sur les fichiers juste avant de les publier. En effet, certaines des informations supprimées par l'outil sont utilisées par Office pour des fonctionnalités de collaboration, telles que les fonctionnalités Suivi des modifications, Commentaires et Envoyer pour révision, et ces fonctionnalités de collaboration ne fonctionneront pas après l'utilisation du complément de suppression des métadonnées.

Le complément de suppression des métadonnées est conçu pour supprimer définitivement certains types de données de fichiers Office, automatiquement et sans demander confirmation. Par défaut, il vous demandera d'enregistrer le fichier sous un nouveau nom de fichier.

Il est conseillé de toujours effectuer l'enregistrement sous un nouveau nom de fichier, plutôt que de remplacer le fichier d'origine par le nouveau document, afin de conserver une copie du document contenant les données d'origine.

Pour modifier la langue utilisée par le complément de suppression des métadonnées, vous devrez désinstaller le complément, puis télécharger une nouvelle copie du complément pour cette langue. Une fois le nouveau complément dans la langue appropriée installé, il remplacera la version de langue d'origine du complément. Toutes les copies du complément de suppression des métadonnées, quelle qu'en soit la langue, comprennent une version en anglais, afin de prendre en charge l'outil de ligne de commande.

Cet outil ne permet pas de supprimer des données masquées contenues dans les types de fichiers suivants :
  • Documents utilisant des autorisations de gestion des droits
  • Documents protégés
  • Documents signés numériquement
  • Classeurs partagés
Si vous essayez d'exécuter cet outil sur un fichier qui remplit une ou plusieurs de ces conditions, l'outil mettra fin à l'opération et affichera un message d'erreur. Le fichier d'origine reste inchangé.

Configuration requise

Systèmes d'exploitation pris en charge : Microsoft Windows XP SP1 ou version ultérieure, Microsoft Windows 2000 SP4 ou version ultérieure, ou Microsoft Windows Server 2003

Ce téléchargement fonctionne avec les applications Office suivantes :
  • Microsoft Office Word 2003
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Word 2002, SP2 ou version ultérieure
  • Microsoft Excel 2002, SP2 ou version ultérieure
  • Microsoft PowerPoint 2002, SP2 ou version ultérieure
L'application dans laquelle le document a été créé doit être installée pour pouvoir exécuter le complément. De plus, la version de Microsoft Office dont vous disposez doit être identique ou ultérieure à la version du document sur lequel vous voulez exécuter l'outil de suppression des métadonnées. Par exemple, vous pouvez exécuter cet outil sur un document Office 2000 si vous utilisez Microsoft Office 2003, mais vous ne pouvez pas l'exécuter sur un document Office 2003 si vous utilisez Microsoft Office XP.

L'outil de suppression des métadonnées fonctionne avec les documents Word, les feuilles de calcul Excel et les présentations PowerPoint, ainsi qu'avec les pages Web et les pages Web à fichier unique créées par Word, Excel et PowerPoint. Il ne fonctionne pas avec d'autres formats de document.

Types de données pouvant être supprimées par ce complément

Les types de données suivants sont supprimés automatiquement.
  • Commentaires.
  • Auteurs et éditeurs précédents.
  • Nom de l'utilisateur.
  • Informations personnelles sur la synthèse.
  • Marques de révision. L'outil accepte toutes les révisions spécifiées dans le document. Par conséquent, le contenu du document correspondra à l'affichage Final avec marques de la barre d'outils Révision.
  • Texte supprimé. Ces données sont supprimées automatiquement.
  • Versions.
  • Macros VB. Les descriptions et commentaires sont supprimés des modules.
  • Le numéro de référence (ID) utilisé pour identifier votre document en vue de fusionner les modifications dans le document d'origine.
  • Bordereaux de routage.
  • En-têtes de messages électroniques.
  • Commentaires de scénarios.
  • Identificateurs uniques (documents Office 97 uniquement).
Remarque L'outil de suppression des métadonnées active également la fonctionnalité Supprimer les informations personnelles. Pour plus d'informations sur cette fonctionnalité, recherchez « Supprimer les informations personnelles » dans l'aide de l'application.

Problèmes connus

  • Excel : Dans Excel 2002, les chemins d'accès des imprimantes ne sont pas supprimés ; ils le sont toutefois dans Excel 2003.
  • Excel : Il est possible que le lien vers un classeur de prise en charge externe ne soit pas nettoyé dans une page Web à fichier unique créée par Microsoft Excel.
  • Si le complément de suppression des métadonnées se ferme de façon inattendue, il est possible qu'une fenêtre de Bloc-notes vide s'affiche et qu'un fichier journal soit conservé dans votre répertoire temporaire. Pour fermer la fenêtre du Bloc-notes, cliquez sur Fichier, puis sur Quitter dans le Bloc-notes. Pour supprimer le fichier journal, supprimez le contenu du répertoire temporaire dans votre dossier de paramètres locaux.
  • Si vous fermez le complément de suppression des métadonnées avant qu'il n'ait terminé de vérifier un document, il est possible qu'un ou plusieurs fichiers temporaires soient conservés dans le répertoire de destination. Pour faire disparaître ces fichiers, supprimez-les du répertoire de destination.
  • Les pages Web à fichier unique qui ont été vérifiées par cet outil peuvent contenir le nom d'un fichier temporaire généré de façon aléatoire sous la forme fichier: //c:/<numéro>/. Le numéro utilisé dans ce nom est basé sur le nom de fichier de la page Web à fichier unique et ne peut pas être suivi jusqu'à votre ordinateur.
  • Les nombres aléatoires masqués existants, utilisés pour améliorer l'exactitude de la fusion et stockés dans des fichiers Word, ne sont pas supprimés.
  • Lorsque le complément de suppression des métadonnées est exécuté à partir de la ligne de commande, il ne fonctionne pas sur les documents XML créés dans Word, Excel ou PowerPoint.

Utilisation de base

Après avoir installé le complément de suppression des métadonnées, ouvrez le document que vous souhaitez vérifier, puis, dans le menu Fichier, cliquez sur Supprimer les données masquées.

Remarque Si la commande Supprimer les données masquées n'apparaît pas dans le menu Fichier, vérifiez les éléments suivants :
  1. Dans le menu Outils, cliquez sur Options, puis sur l'onglet Sécurité.
  2. Sous Sécurité des macros, cliquez sur Sécurité des macros.
  3. Cliquez sur l'onglet Éditeurs approuvés.
  4. Activez la case à cocher Faire confiance à tous les modèles et compléments installés, puis cliquez sur OK à deux reprises.
Une fois le nom de fichier spécifié, l'outil supprimera automatiquement les données masquées spécifiées. Pour plus d'informations, reportez-vous à la section Types de données pouvant être supprimées par ce complément.

Remarques

Il est conseillé de toujours effectuer l'enregistrement sous un nouveau nom de fichier, plutôt que de remplacer le fichier d'origine par le nouveau document, afin de conserver une copie du document contenant les données d'origine.

Le complément de suppression des métadonnées ne prend pas en charge l'enregistrement de documents en tant que modèles.

Ligne de commande

Pour exécuter le complément de suppression des métadonnées à partir de la ligne de commande, procédez comme suit :
  1. Fermez toutes les instances de Microsoft Excel, Word, Outlook et PowerPoint avant de lancer l'outil de ligne de commande.
  2. Dans le menu Démarrer, cliquez sur Exécuter.
  3. Tapez cmd, puis appuyez sur ENTRÉE.
  4. Activez le répertoire contenant le fichier OFFRHD.EXE. Par défaut, il s'agit du répertoire dans lequel vous avez installé le complément de suppression des métadonnées.
  5. À l'invite de commandes, tapez la syntaxe de la commande à exécuter.
Remarques

Bien que l'application de votre document ne soit pas visible, elle est exécutée en arrière-plan. Si l'application affiche une boîte de dialogue, l'exécution du complément de suppression des métadonnées est suspendue jusqu'à la fermeture de la boîte de dialogue. Si cette dernière reste ouverte plus que 120 secondes, l'application est fermée et le complément de suppression des métadonnées passe au fichier suivant, ou se ferme s'il a atteint le dernier fichier.

Vous pouvez faire précéder les paramètres de l'indicateur barre oblique (/) ou tiret (-). Les indicateurs ne respectent pas la casse.

Si vous spécifiez plusieurs indicateurs, seul le premier est reconnu.

Vous devez entrer le paramètre /source en premier, suivi du paramètre facultatif /destination. Tous les autres paramètres peuvent être spécifiés dans n'importe quel ordre.

Si vous tapez une barre oblique (/) à la fin du nom du répertoire source, l'outil échouera.

La syntaxe d'exécution du fichier OFFRHD.EXE est la suivante :
OFFRHD [/?] source [destination] [/O] [/R] [/F:type_fichier] [/L: fichier_journal] [/A]
Réduire ce tableauAgrandir ce tableau
ParamètreDescription
sourceObligatoire. Spécifie le lecteur, le répertoire et les fichiers desquels vous souhaitez supprimer les informations personnelles. Peut être n'importe quel chemin d'accès complet valide.
destinationFacultatif. Spécifie l'emplacement des fichiers analysés. Si vous ne spécifiez pas ce champ, tous les fichiers seront enregistrés dans le même répertoire, avec un suffixe représentant la date actuelle. Par exemple, - C010503 représente le 5 janvier 2003. Si le fichier de destination existe déjà, il sera remplacé.
/OSpécifie qu'aucune invite ne s'affichera pour vous demander de confirmer le remplacement d'un fichier existant.
/RSpécifie que le contenu du répertoire d'origine et ses sous-répertoires sera examiné.
/F:type_fichierSpécifie le format des fichiers de destination.
/F:HSpécifie le format HTML.
/F:MSpécifie le format MHTML.
/F:BSpécifie le format de document binaire. Si vous ne spécifiez pas ce paramètre, par défaut, le fichier sera enregistré dans le même format que le fichier source.
/L:fichier_journalSpécifie l'emplacement du fichier journal. Si vous ne spécifiez pas ce paramètre, le fichier journal s'affichera à la fin de l'exécution de l'outil.
/ASpécifie que l'outil créera un état des problèmes rencontrés dans le fichier, mais qu'il ne supprimera aucune donnée.
/:?Affiche la liste de tous les paramètres disponibles.

Fichier journal

Lorsque le complément de suppression des métadonnées a fini de vérifier le ou les fichiers, un fichier journal affiche les résultats du processus de vérification. Vous pouvez enregistrer ce fichier si vous souhaitez vous y reporter par la suite.

Utilisation de l'outil de suppression des métadonnées avec IRM

Dans Office 2003, vous ne pouvez exécuter l'outil de suppression des métadonnées sur des documents protégés par IRM que si vous êtes propriétaire du document ou si vous disposez de l'autorisation « Modifier » avec l'option « Accéder au contenu via un programme ».

Pour accorder des autorisations permettant d'exécuter l'outil de suppression des métadonnées sur des documents protégés par IRM, procédez comme suit :
  1. Dans le menu Fichier, cliquez sur Autorisation, Restreindre l'autorisation en tant que.
  2. Sélectionnez le compte d'utilisateur (généralement le vôtre) pour créer ou ouvrir le contenu, puis cliquez sur OK.
  3. Dans la boîte de dialogue Autorisation, cliquez sur Autres options.
  4. Cliquez sur le compte d'utilisateur auquel vous souhaitez accorder l'accès. (Ce compte d'utilisateur doit disposer de l'autorisation Modifier sur le document pour utiliser l'outil de suppression des métadonnées.)
  5. Cliquez sur Accéder au contenu via un programme, puis sur OK.

Propriétés

Numéro d'article: 834427 - Dernière mise à jour: mardi 22 mai 2007 - Version: 3.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Word 2003
  • Microsoft Excel 2002
  • Microsoft PowerPoint 2002 Standard
  • Microsoft Word 2002 Standard Edition
Mots-clés : 
kbcommandline kbconfig kbtooltip kbinfo KB834427
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com