Office 2003 および Office XP 用隠しデータ削除ツール

文書翻訳 文書翻訳
文書番号: 834427 - 対象製品
すべて展開する | すべて折りたたむ

目次

概要

隠しデータ削除ツール アドインは、Microsoft Office プログラムでドキュメントを表示したときに、通常は表示されない個人データや非表示のデータを削除するためのツールです。

Microsoft Office 2002 プログラムまたは Microsoft Office 2003 プログラムから、個々のファイルに対して隠しデータ削除ツール アドインを実行できます。また、コマンド ラインから、同時に複数のファイルに対して隠しデータ削除ツール アドインを実行することもできます。どちらの場合も、アドインを実行するには、処理対象のドキュメントの作成に使用したプログラムがインストールされている必要があります。

: 隠しデータ削除ツールを使用して保存されたファイルを開くと、Word および Excel で以下のメッセージが表示されます。
'file name' を変更し、保存する必要がなければ、読み取り専用で開いてください。読み取り専用で開きますか?
[はい] をクリックすると、ファイルを編集できなくなります。[いいえ] をクリックすると、ファイルを編集できるようになります。これにより、新しいメタデータを入力できます。

Remove Hidden Data アドインとその入手方法については、以下のマイクロソフト Web サイトを参照してください。
http://www.microsoft.com/downloads/details.aspx?displaylang=ja&FamilyID=144e54ed-d43e-42ca-bc7b-5446d34e5360
ReadMe ファイルに記載されていないその他の既知の問題およびトピックの関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
834636 Office 2003 および Office XP 用 Remove Hidden Data アドイン バージョン 1.0 についての既知の問題
842684 Office 2003 および Office XP 用隠しデータ削除ツール アドイン バージョン 1.1 についての既知の問題
コンピューターにインストールされている隠しデータ削除ツールのバージョンを調べるには、以下の手順を実行します。
  1. [スタート] ボタンをクリックし、[コントロール パネル] をクリックします。
  2. [プログラムの追加と削除] をクリックします。
  3. 現在インストールされているプログラムの一覧で、[隠しデータ削除ツール] をクリックし、[サポート情報を参照するには、ここをクリックしてください。] をクリックします。
  4. 次の表を使用し、インストールした隠しデータ削除ツールの最初の製品版を確認します。
    元に戻す全体を表示する
    最初の製品版バージョン
    隠しデータ削除ツール 1.111.0.6361.0
    隠しデータ削除ツール 1.06.00.2600.0000
注: 2007 Microsoft Office システムでは、Remove Hidden Data ツールの機能がアプリケーションに組み込まれています。この機能を使用するには、以下の手順を実行します。
  1. ファイルを開いた状態で、Microsoft Office ボタンをクリックし、[配布準備] をポイントします。
  2. [ドキュメント検査] をクリックします。[ドキュメント検査] ダイアログ ボックスが表示されます。すべての項目が選択されていることを確認します。これで、一覧のすべてのチェックが自動的に実行されます。一覧内の項目をスキップする場合、クリックして該当するチェック ボックスの選択を解除します。
2007 Office システムの個人情報を削除する方法の詳細については、Microsoft Office Word 2007 の [ヘルプ] をクリックし、[検索] ボックスに「ドキュメントの検査」と入力します。

詳細

以下は、隠しデータ削除ツール アドインの ReadMe ファイルの内容です。隠しデータ削除ツール アドインをインストールすると、この ReadMe ファイルは次のフォルダーに格納されます。
path\Program Files\Microsoft Office\Remove Hidden Data Tool\1033

Microsoft Office 2003 ReadMe ファイル:隠しデータ削除ツール アドイン

? 2003 Microsoft Corporation.All rights reserved.

この ReadMe ファイルでは、Microsoft Office 2003 隠しデータ削除ツール アドインに関する最新情報について説明します。「目次」には、このファイルに含まれる情報の一覧が記載されています。Office システムの個々の製品に固有の最新情報については、その製品の ReadMe ファイルを参照してください。

Remove Hidden Data は、Microsoft Word、Microsoft Excel、および Microsoft PowerPoint ファイルから非表示のデータおよび Collaboration Data を完全に削除するための Microsoft Office 2003 の各 Edition または Microsoft Office XP 用のアドインです。

このドキュメントの使用方法

ReadMe ファイルを画面上に表示するには、ブラウザー ウィンドウを最大化します。ReadMe ファイルを印刷するには、ツール バーの [印刷] ボタンをクリックします。

目次

概要

Office ドキュメントを電子的に配布する場合に、グループ作業でドキュメントを作成、編集する際に使用する情報、またはどのユーザーがドキュメントで作業を行ったかを確認できる非表示の情報など、公に共有したくない情報を含む可能性があります。

隠しデータ削除ツール アドインは、Microsoft Office アプリケーションでドキュメントを表示したときに、通常は表示されない個人情報または非表示の情報を削除するためのツールです。

隠しデータ削除ツール アドインは、Office XP または Office System 2003 アプリケーションから、個々のファイルに対して実行できます。また、コマンド ラインを使用して複数のファイルに対して実行することもできます。どちらの場合も、アドインを実行するには、処理対象のドキュメントを作成したアプリケーションがインストールされている必要があります。

注:

ファイルを公開する準備ができてから、隠しデータ削除ツール アドインを実行してください。アドインによって削除される情報には、変更履歴、コメント、校閲者へ送信など、Office のグループ作業のための機能によって使用される情報が含まれるため、いったん隠しデータ削除ツール アドインを実行すると、これらのグループ作業の機能は動作しません。

隠しデータ削除ツール アドインは、Office ファイルから特定の種類のデータを完全に、自動的に、そしてユーザーの確認なしで削除するようにデザインされています。既定では、新しいファイル名で保存するかどうかを確認するメッセージが表示されます。

元のデータが含まれているドキュメントのコピーを保持するためには、新しいドキュメントで元のファイルを上書きしないで、常に新しいファイル名を使用して保存してください。

隠しデータ削除ツール アドインで使用される言語を変更するには、アドインをアンインストールしてから、その言語用の隠しデータ削除ツール アドインを新しくダウンロードする必要があります。新しい言語のアドインがインストールされると、元の言語のアドインは置き換えられます。コマンド ライン ツールをサポートするために、どの言語の隠しデータ削除ツール アドインにも英語版のアドインが含まれています。

このアドインでは、以下の種類のファイルから隠しデータを削除することはできません。
  • 著作権管理のアクセス許可を使用するドキュメント
  • 保護されたドキュメント
  • デジタル署名されたドキュメント
  • 共有ブック
1 つまたは複数のこれらの条件に当てはまるファイルに対してこのツールを実行しようとする場合、操作は中断され、エラー メッセージが表示されます。元のファイルは変更されません。

System requirements

Supported Operating Systems: Microsoft Windows XP SP1 or later, Microsoft Windows 2000 SP4 or later, or Microsoft Windows Server 2003

このダウンロード ファイルは、以下の Office アプリケーションで動作します。
  • Microsoft Office Word 2003
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Word 2002 SP2 以降
  • Microsoft Excel 2002 SP2 以降
  • Microsoft PowerPoint 2002 SP2 以降
アドインを実行するには、処理対象のドキュメントを作成したアプリケーションがインストールされている必要があります。また、インストールされている Office のバージョンは、隠しデータ削除ツールの処理対象のドキュメントと同じバージョン、またはより新しいバージョンである必要があります。たとえば、Office 2003 を使用して Office 2000 で作成されたドキュメントに対してアドインを実行することはできますが、Office XP を使用して Office 2003 で作成されたドキュメントに対してツールを実行することはできません。

隠しデータ削除ツールは、Word 文書、Excel シート、PowerPoint プレゼンテーション、および Word、Excel、PowerPoint で作成された Web ページと単一ファイル Web ページに対して使用できます。他の形式のドキュメントには使用できません。

このアドインで削除できるデータの種類

次の種類のデータは自動的に削除されます。
  • コメント。
  • 以前の作成者と編集者。
  • ユーザー名。
  • プロパティの個人情報。
  • 変更履歴。ドキュメント内のすべての変更履歴を反映し、ドキュメントの内容は [チェック/コメント] ツール バーの [最終版] に対応します。
  • 削除された文字列。このデータは自動的に削除されます。
  • バージョン。
  • VB マクロ。説明とコメントはモジュールから削除されます。
  • 元のドキュメントに変更内容を反映する際にドキュメントを識別するために使用される ID 番号。
  • 回覧先。
  • 電子メール ヘッダー。
  • シナリオのコメント。
  • 識別子 (Office 97 ドキュメントのみ)。
: 隠しデータ削除ツールは、[保存時にファイルのプロパティから個人情報を削除する] の機能をオンにします。この機能の詳細に関しては、アプリケーションのヘルプで「個人情報の削除」を検索してください。

既知の問題

  • Excel: Microsoft Excel 2002 では、プリンターのパスは削除されません。Microsoft Office Excel 2003 では削除されます。
  • Excel:サポート元の外部ブックへのリンクが、Excel の単一ファイル Web ページから削除されないことがあります。
  • 隠しデータ削除ツール アドインが突然終了した場合、空のメモ帳のウィンドウが表示され、ログ ファイルが一時ディレクトリに残ることがあります。メモ帳のウィンドウを閉じるには、メモ帳で [ファイル] メニューの [メモ帳の終了] をクリックしてください。このログ ファイルを削除するには、ローカル設定フォルダーの一時ディレクトリの内容を削除してください。
  • ドキュメントの処理が完了する前に隠しデータ削除ツール アドインを閉じた場合、1 つまたは複数の一時ファイルが保存先のディレクトリに残ることがあります。これらのファイルを削除するには、保存先のディレクトリからファイルを削除してください。
  • このアドインで確認済みの単一ファイル Web ページに、file:///c:/<number>/ という形式で、ランダムに生成された名前の一時ファイルが含まれていることがあります。このファイル名に使用されている番号は単一ファイル Web ページのファイル名に基づくもので、ユーザーのコンピューターを識別できるものではありません。
  • 文書の比較と反映の精度を向上するために Word ファイルに保存される既存の非表示のランダムな番号は削除されません。
  • コマンド ラインから実行する場合、Word、Excel、または PowerPoint で作成された XML ドキュメントでは隠しデータ削除ツール アドインを使用できません。

基本的な使用法

Remove Hidden Data アドインをインストールした後、確認するドキュメントを開き、[ファイル] メニューの [Remove Hidden Data] をクリックします。

: [ファイル] メニューに [隠しデータの削除] が表示されない場合は、以下の手順を実行して確認してください。
  1. [ツール] メニューの [オプション] をクリックし、[セキュリティ] タブをクリックします。
  2. Word の場合は、[マクロのセキュリティ] の下の [マクロのセキュリティ] をクリックします。Excel または PowerPoint の場合は、[マクロ セキュリティ] の下の [マクロ セキュリティ] をクリックします。
  3. [信頼できる発行元] タブ (Office XP では [信頼のおける発行元] タブ) をクリックします。
  4. [組み込み済みのアドインとテンプレートをすべて信頼する] チェック ボックスをオンにします。[OK] を 2 回クリックします。
ファイル名を指定すると、ツールによって自動的に隠しデータが削除されます。詳細に関しては、「このアドインが削除できるデータの種類」を参照してください。

注:

元のデータが含まれるドキュメントのコピーを保持するためには、新しいドキュメントで元のファイルを上書きしないで、常に新しいファイル名で保存してください。

隠しデータ削除ツール アドインでは、ドキュメントをテンプレートとして保存する機能はサポートされていません。

コマンド ライン

コマンド ラインから隠しデータ削除ツール アドインを実行するには、次の操作を行ってください。
  1. コマンド ライン ツールを起動する前に、Excel、Word、Outlook、および PowerPoint のインスタンスをすべて終了します。
  2. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  3. cmd」と入力し、Enter キーを押します。
  4. OFFRHD.EXE ファイルが格納されているディレクトリに移動します。既定では、隠しデータ削除ツール アドインをインストールしたディレクトリと同じです。
  5. コマンド プロンプトで、実行するタスクの構文を入力します。
注:

処理対象のドキュメントのアプリケーションは表示されませんが、バックグラウンドで実行されています。アプリケーションでダイアログ ボックスが表示されると、ダイアログ ボックスが閉じられるまで隠しデータ削除ツール アドインは一時停止します。ダイアログ ボックスが開いている時間が 120 秒を超えると、アプリケーションは終了し、隠しデータ削除ツール アドインは次のファイルの処理を開始します。最後のファイルに到達していた場合、隠しデータ削除ツール アドインは終了します。

パラメーターの前に入力するフラグには、スラッシュ (/) またはダッシュ (-) を使用できます。フラグでは、大文字と小文字は区別されません。

複数のフラグを入力した場合、最初のフラグのみが認識されます。

/source パラメーターは最初に入力し、必要に応じてその後に /destination パラメーターを入力する必要があります。他のすべてのパラメーターは、どの順序でも入力できます。

ソース ディレクトリ名の末尾にスラッシュを入力すると、ツールは失敗します。

OFFRHD.EXE の構文は、次のとおりです。
OFFRHD [/?] source [destination] [/O] [/R] [/F:filetype] [/L: logfile] [/A]
元に戻す全体を表示する
パラメーター説明
source必須です。個人情報を削除するドライブ、ディレクトリ、およびファイルを指定します。有効な完全修飾パス名を使用します。
destination省略可能です。スキャンしたファイルの保存場所を指定します。このパラメーターを指定しない場合、現在の日付を表すサフィックスを追加して、すべてのファイルが同じディレクトリに保存されます。たとえば、-C010503 は 2003 年 1 月 5 日を表します。保存先のファイルが既に存在する場合は、上書きされます。
/O既存のファイルを上書きするかどうかを確認するメッセージを表示しません。
/Rソース ディレクトリとサブディレクトリの内容を検査します。
/F:filetype保存先のファイルの形式を指定します。
/F:HHTML を指定します。
/F:MMHTML を指定します。
/F:Bバイナリ ドキュメント形式を指定します。このパラメーターを指定しない場合、既定では、元のファイルと同じ形式で保存されます。
/L:logfileログ ファイルを保存する場所を指定します。このパラメーターを指定しない場合、ツールの処理が完了したときにログが表示されます。
/Aファイルで発見された問題のレポートを作成し、データは削除しません。
/:?使用可能なすべてのパラメーターの一覧を表示します。

ログ ファイル

隠しデータ削除ツール アドインによるファイルの確認が完了すると、確認の結果を示すログ ファイルが表示されます。後で参照する場合は、このファイルを保存してください。

プロパティ

文書番号: 834427 - 最終更新日: 2009年12月17日 - リビジョン: 6.1
この資料は以下の製品について記述したものです。
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Word 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002
キーワード:?
kbcommandline kbconfig kbtooltip kbinfo KB834427
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com