Средство удаления скрытых данных для Office 2003 и Office XP

Переводы статьи Переводы статьи
Код статьи: 834427 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Аннотация

Надстройка для удаления скрытых данных - это средство, предназначенное для удаления личных и скрытых данных, которые не отображаются непосредственно во время просмотра документа в программе Microsoft Office.

Надстройку для удаления скрытых данных можно запустить на отдельных файлах в програме Microsoft Office XP или программе Microsoft Office 2003. Также возможно запустить надстройку для удаления скрытых данных из командной строки на нескольких файлах одновременно. И в том и в другом случае для запуска средства необходимо, чтобы программа, в которой создавался документ, была установлена.

Для получения дополнительных сведений о средстве для удаления скрытых данных и о способе ее получения посетите следующий веб-узел Microsoft:
http://www.microsoft.com/downloads/details.aspx?displaylang=ru&FamilyID=144E54ED-D43E-42CA-BC7B-5446D34E5360
Для получения дополнительных сведений об известных проблемах и по вопросам, не рассмотренным в этом файле ReadMe, щелкните следующие номера статей базы знаний Майкрософт:
834636 Известные проблемы, связанные с надстройкой для удаления скрытых данных для Office 2003 и Office XP (Эта ссылка может указывать на содержимое полностью или частично на английском языке)
842684 Известные проблемы, связанные с надстройкой для удаления скрытых данных версии 1.1 для Office 2003 и Office XP (Эта ссылка может указывать на содержимое полностью или частично на английском языке)

Чтобы определить версию средства для удаления скрытых данных, установленную на компьютере, выполните следующие действия.
  1. Нажмите кнопку Пуск и выберите пункт Панель управления.
  2. Щелкните значок Установка и удаление программ.
  3. Из списка установленных программ выберите Средство удаления скрытых данных и щелкните ссылку Чтобы получить сведения о поддержке, щелкните здесь.
  4. Для определения исходной версии средства удаления скрытых данных, установленной на компьютере, см. следующую таблицу.

    Свернуть эту таблицуРазвернуть эту таблицу
    Исходная версияВерсия
    Remove Hidden Data 1.111.0.6361.0
    Средство удаления скрытых данных 1.06.00.2600.0000

Дополнительная информация

Ниже приведен файл ReadMe для надстройки для удаления скрытых данных После установки средства удаления скрытых данных он помещается в папку
путь\Program Files\Microsoft Office\Remove Hidden Data Tool\1033

Файл ReadMe Microsoft Office 2003: Надстройка для удаления скрытых данных

© 2003 Корпорация Майкрософт. Все права защищены.

Этот документ содержит последние сведения о надстройке Microsoft Office 2003 для удаления скрытых данных. В разделе «Содержание» перечислены все сведения, содержащиеся в этом файле; для получения последних сведений об отдельных продуктах системы Office см. файлы ReadMe для этих продуктов.

Средство удаления скрытых данных - это надстройка для Microsoft Office 2003 Editions или для Microsoft Office XP, которая дает возможность окончательно удалять скрытые данные и данные о совместной работе из файлов Microsoft Word, Microsoft Excel и Microsoft PowerPoint.

Об использовании данного документа

Для просмотра файла ReadMe разверните окно обозревателя. Чтобы распечатать файл ReadMe, нажмите кнопку Печать на на панели

Содержание

Обзор

При электронном распространении документов в них могут содержаться сведения, не предназначенные для общего просмотра, например данные, необходимые для работы над созданием и изменением документа, или скрытые данные, позволяющие отследить составителей документа.

Надстройка для удаления скрытых данных - это средство для удаления личных и скрытых данных, которые не отражаются непосредственно в документе при просмотре в Microsoft Office

Надстройку для удаления скрытых данных можно запустить на отдельных файлах в приложении Office XP или Office System 2003. Также возможно запустить средство удаления скрытых данных из командной строки на нескольких файлах одновременно. И в том и в другом случае для запуска средства необходимо, чтобы програма, в которой создавался документ, была установленна.

Примечания

Надстройку для удаления скрытых данных следует запускать на файлах, полностью готовых к публикации. Так как средство удаляет часть информации, которая используется Office для обеспечения функций совместной работы, таких как «Отслеживание изменений», «Комментарии» и «Отправить на проверку», то эти функции перестанут работать после использования средства удаления скрытых данных.

Надстройка для удаления скрытых данных разработана для автоматического безвозвратного удаления информации определенного типа из файлов Office без подтверждения. По умолчанию надстройка предложит сохранить файл под новым именем.

Чтобы сохранить копию документа с исходными данными, необходимо всегда сохранять новый файл под новым именем вместо того, чтобы заменять исходный документ.

Чтобы изменить язык, который средство удаления скрытых данных использует в процессе работы, необходимо удалить надстройку, а затем загрузить новую копию средства удаления скрытых данных для нужного языка. Когда надстройка с новым языком установлена, она заменяет версию с исходным языком Все копии надстройки для удаления скрытых данных на любом языке содежат англоязычную версию, чтобы обеспечить работу командной строки.

Это средство не удаляет скрытые данные из следующих типов файлов:
  • Документы, использующие разрешения управления правами
  • Защищенные документы
  • Документы, содержащие цифровую подпись
  • Общие книги
При попытке запуска средства на файле, попадающем под одну или более категорий, средство завершит работу, и появится сообщение об ошибке. Нет изменений в исходном файле

Системные требования

Поддерживаемые операционные системы: Microsoft Windows XP с пакетом обновления 1 (SP1) или выше, Microsoft Windows 2000 с пакетом обновления 4 (SP4) или выше, или Microsoft Windows Server 2003

Этот загружаемый файл работает со следующими приложениями Office:
  • Microsoft Office Word 2003
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Word 2002, SP2 или выше
  • Microsoft Word 2002, SP2 или выше
  • Microsoft PowerPoint 2002, SP2 или выше
Для запуска надстройки необходимо, чтобы программа, в которой создавался документ, была установлена. Также необходимо иметь версию Office не ранее той, в которой был создан документ, предназначенный для обработки средством удаления скрытых данных. Например, можно запустить средство на документе, созданном в Office 2000, с помощью Office 2003, но на документе, созданном в Office 2003, нельзя запустить средство с помощью Office XP.

Средство удаления скрытых данных работает с документами Word, электронными таблицами Excel и презентациами PowerPoint, а также с веб-страницами и однофайловыми веб-страницами. Средство не работает с другими форматами документов.

Типы данных, которые удаляет настройка

Следующие типы данных удаляются автоматически.
  • Описание.
  • Предыдущие авторы и редакторы.
  • Имя пользователя.
  • Краткие личные сведения.
  • Записи исправлений. Средство принимает все исправления, указанные в документе. В результате чего содержание документа будет соответствовать режиму просмотра Исправления в измененном документе на панели Правка
  • Удаленный текст. Эти данные удаляются автоматически.
  • Версии.
  • Макросы VB. Удаляются описания и комментарии из модулей.
  • Кодовый номер, необходимый для идентификации документа при слиянии изменений в исходном документе.
  • Маршруты документа.
  • Заголовки электронной почты.
  • Комментарии ситуации.
  • Уникальные идентификаторы (только для Office 97).
Примечание При использовании средства удаления скрытых данных также включается функция удаления личных сведений. Для получения дополнительных сведений об этой функции выполните поиск по словам «Удаление личных сведений» в приложении Справка.

Известные проблемы

  • Excel: Не удаляются пути к принтеру в Excel 2002; но они удаляются в Excel 2003.
  • Excel: Возможно, с однофайловой веб-страницы Excel не удаляется ссылка на поддерживающую внешнюю книгу.
  • Если надстройка для удаления скрытых данных неожиданно закрывается, может появиться пустое окно Блокнота, а в папке для временных файлов может остаться файл журнала. Чтобы закрыть окно Блокнота, нажмите в нем Файл, Выход. Чтобы удалить файл журнала, удалите содержимое папки для временных файлов, находящейся в папке Local Settings.
  • Если закрыть надстройку для удаления скрытых данных до завершения обработки документа, один или несколько временных файлов могут остаться в папке назначения. Эти файлы можно удалить из папки назначения.
  • Однофайловые веб-страницы, с которыми работает надстройка, могут содержать имена случайным образом созданных временных файлов в виде file:///c:/<номер>/. Номер при этом создается на основе имени файла веб-страницы и не может содержать сведений о вашем компьютере.
  • Скрытые случайные цифры, предназначенные для повышения точности слияния и сохраненные в файлах Word, не удаляются.
  • Если запустить надстройку для удаления скрытых данных из командной строки, она не работает с документами XML, созданными в Word, Excel, или PowerPoint.

Обычное использование

После установки средства удаления скрытых данных откройте документ, который нужно обработать, затем в меню Файл выберите Средство удаления скрытых данных.

Примечание Если пункт Средство удаления скрытых данных не отображается в меню Файл, выполните следующее:
  1. В меню Сервис выберите Параметры и перейдите на вкладку Безопасность.
  2. В разделе Защита от макросов нажмите кнопку Защита от макросов.
  3. Выберите вкладку Надежные источники .
  4. Установите флажок Доверять всем установленным надстройкам и шаблонам и дважды щелкните OK.
После указания имени файла средство автоматически удалит все указанные скрытые данные. Для получения дополнительных сведений см. раздел Типы данных, которые удаляет эта надстройка.

Примечания

Чтобы сохранить копию документа с исходными данными, необходимо всегда сохранять новый файл под новым именем вместо того, чтобы заменять исходный документ.

Надстройка для удаления скрытых данных не поддерживает сохранение документов как шаблонов.

Командная строка

Чтобы запустить средство удаления скрытых данных из командной строки, необходимо:
  1. Закрыть все окна Excel, Word, Outlook и PowerPoint, прежде чем запускать командную строку.
  2. В меню Пуск выбрать Выполнить.
  3. Ввести команду cmd и нажать клавишу ENTER.
  4. Перейти в папку, содержащую файл OFFRHD.EXE По умолчанию это папка, в которой находится надстройка для удаления скрытых данных.
  5. В командной строке набрать набрать команду для задачи, которую нужно выполнить.
Примечание

Хотя приложение для работы с документами невидимо, оно работает в фоновом режиме. Если приложение запустит диалоговое окно, надстройка для удаления скрытых данных приостановит работу до тех пор, пока диалоговое окно не бедет закрыто. Если диалоговое окно открыто более 120 секунд, приложение завершит работу, и надстройка для удаления скрытых данных перейдет к новому файлу или завершит работу, если она достигла последнего файла.

Чтобы указать параметры, поставьте перед ними косую черту (/) или тире (-). Для флагов регистр не учитывается.

Если введены несколько флагов, учитывается только первый из них.

Необходимо ввести сначала параметр /источник, а затем, если требуется, - параметр /назначение. Все остальные параметры могут вводиться в любом порядке

Если в конце имени папки источника стоит косая черта (/), средство выдает сбой.

Синтаксис команды OFFRHD.EXE таков:
OFFRHD [/?] источник [назначение] [/O] [/R] [/F:тип_файлов] [/L: файл_журнала] [/A]
Свернуть эту таблицуРазвернуть эту таблицу
ПараметрОписание
источникОбязательный. Устройство, папка и файлы, из которых необходимо удалить личную информацию. Может быть указан любой допустимый полный путь.
назначениеОбязательный. Местоположение обработанных файлов. Если не указывать это поле, все файлы будут сохранены в ту же папку с суффиксом, представляющим текущую дату. Например, -C010503 означает 5 января 2003 г. Если файл места назначения уже существует, он будет заменен.
/OЗапрос на подтверждение удаления существующего файла не будет отображен.
/RБудет просмотрено содержимое папки источника и вложенных в нее папок.
/F:тип_файловФормат файлов назначения.
/F:HHTML.
/F:MMHTML.
/F:BДвоичный формат документа. Если этот параметр не указан, файл по умолчанию будет сохрнен в исходном формате.
/L:файл_журналаМестоположение файла журнала. Если параметр не указан, журнал будет отображен после завершения работы средства.
/AСоздание отчета о проблемах, обнаруженных в файле, без удаления данных.
/:?Отображение списка всех доступных параметров.

Файл журнала

После окончания работы средства удаления скрытых данных в файл журнала заносится результат обработки файла(ов). Сохраните этот файл, если он понадобится вам в дальнейшем.

Использование средства удаления скрытых данных вместе с управлением правами на доступ к данным (IRM)

В Office 2003 нельзя запустить средство удаления скрытых данных на документах, защищенных с помощью управления правами на доступ к данным, если вы не являетесь владельцем документа или вам не предоставлено право вносить изменения с возможностью програмного доступа к содержимому.

Чтобы предоставить разрешение запускать средство удаления скрытых данных на документах, защищенных с помощью управления правами на доступ к данным, выполните следующее:
  1. В меню Файл выберите команду Разрешение, Ограничить разрешение.
  2. Выберите учетную запись пользователя (как правило, свою) чтобы создать или открыть содержимое, и нажмите кнопку OK.
  3. В диалоговом окне Разрешение нажмите Дополнительно.
  4. Выберите учетную запись пользователя, которому вы хотите предоставить доступ. (Чтобы пользователь мог работать с документом в средстве удаления скрытых данных, его учетная запись должна обладать разрешением на внесение изменений в документ).
  5. Выберите Програмный доступ к содержимому и нажмите кнопку OK

Свойства

Код статьи: 834427 - Последний отзыв: 12 октября 2006 г. - Revision: 2.1
Информация в данной статье относится к следующим продуктам.
  • Microsoft Office Excel 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Word 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
Ключевые слова: 
kbcommandline kbconfig kbtooltip kbinfo KB834427

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com