Errore 1603 quando si tenta di installare un pacchetto di Windows Installer: Si è verificato un errore irreversibile durante l'installazione

Questo articolo consente di correggere l'errore 1603 che si verifica quando si installa un pacchetto di Windows Installer.

Si applica a: Windows 10 - tutte le edizioni
Numero originale della Knowledge Base: 834484

Sintomi

Mentre si tenta di installare un pacchetto di Windows Installer, viene visualizzato il seguente messaggio di errore:

Errore 1603: si è verificato un errore irreversibile durante l'installazione.

Se si fa clic su OK nella finestra del messaggio, viene eseguito il rollback dell'installazione.

Causa

È possibile che venga visualizzato questo messaggio di errore se si verifica una delle condizioni seguenti:

  • Windows Installer sta tentando di installare un'app già installata nel PC.
  • La cartella in cui si sta tentando di installare il pacchetto di Windows Installer è crittografata.
  • L'unità che contiene la cartella in cui si sta tentando di installare il pacchetto di Windows Installer è accessibile come unità sostitutiva.
  • L'account SYSTEM non dispone del livello di autorizzazione Controllo completo per la cartella in cui si sta tentando di installare il pacchetto di Windows Installer. Si nota il messaggio di errore perché il servizio di Windows Installer usa l'account SYSTEM per installare il software.

Risoluzione

Per risolvere il problema, usare uno dei metodi indicati di seguito, a seconda della causa:

  • Controllare se l'app è già installata nel PC. In tal caso, provare a disinstallare e reinstallare l'app interessata.

    Se in precedenza si disponeva di un collegamento desktop per un'app, il collegamento potrebbe essere stato perso durante l'aggiornamento a Windows 10. In questi casi, è probabile che l'app sia ancora installata nel PC, causando questo errore quando si tenta di reinstallarla. È possibile ripristinare il collegamento cercando l'app e, se viene trovata, tenerla premuta (o fare clic con il pulsante destro del mouse) e selezionare Aggiungi a Start. In alternativa, è possibile risolvere il problema disinstallando e reinstallando l'app. Per cercare e disinstallare le app in Windows 10:

    1. Dal menu Start, selezionare Impostazioni.
    2. In Impostazioni selezionare Sistema>App e funzionalità.
    3. Se l'app è elencata, selezionarla e quindi selezionare Disinstalla.
    4. Seguire le istruzioni visualizzate sullo schermo.
  • Installare il pacchetto in una cartella non crittografata.

    Utilizzare questo metodo se viene visualizzato il messaggio di errore perché si tenta di installare il pacchetto di Windows Installer in una cartella crittografata.

  • Installare il pacchetto in un'unità a cui non si accede come unità sostitutiva.

    Utilizzare questo metodo se viene visualizzato il messaggio di errore perché l'unità che contiene la cartella in cui si tenta di installare il pacchetto di Windows Installer è accessibile come unità sostitutiva.

  • Concedere i livelli di autorizzazione Controllo completo all'account SYSTEM.

    Utilizzare questo metodo se viene visualizzato il messaggio di errore perché l'account SYSTEM non dispone dei livelli di autorizzazione Controllo completo per la cartella in cui si sta installando il pacchetto di Windows Installer.

    Per concedere i livelli di autorizzazione Controllo completo all'account SYSTEM, seguire questa procedura:

    1. Aprire Esplora file (o Windows Explorer), fare clic con il pulsante destro del mouse sull'unità in cui si vuole installare il pacchetto di Windows Installer e quindi scegliere Proprietà.

    2. Fare clic sulla scheda Sicurezza. Verificare che la casella Nomi gruppo o utente contenga l'account utente SYSTEM. Se l'account utente SYSTEM non viene visualizzato nella casella, seguire questa procedura per aggiungerlo:

      1. Fare clic su Modifica. Se richiesto, approvare il controllo dell'account utente.
      2. Fare clic su Aggiungi. Viene visualizzata la finestra di dialogo Seleziona utenti o gruppi.
      3. Nel campo Immettere i nomi degli oggetti da selezionare digitare SYSTEM e quindi fare clic su Controlla nomi.
      4. Fare clic su OK.
    3. Per modificare le autorizzazioni, fare clic su Modifica. Se richiesto, approvare il controllo dell'account utente.

    4. Selezionare l'account utente SYSTEM e verificare nella sezione Autorizzazioni che Controllo completo sia impostato su Consenti. Se non è così, selezionare la casella di controllo Consenti.

    5. Chiudere la finestra di dialogo Autorizzazioni e tornare alla finestra di dialogo Proprietà. Fare clic su Avanzate.

    6. Selezionare Modifica autorizzazioni. Se richiesto, approvare il controllo dell'account utente.

    7. Nella scheda Autorizzazioni selezionare la voce SYSTEM e fare clic su Modifica.

    8. Fare clic sull'elenco a discesa Applica a e selezionare Questa cartella, sottocartella e file. Fare clic su OK.

    9. Attendere che il sistema operativo applichi le autorizzazioni selezionate a tutte le sottocartelle.

    10. Eseguire il pacchetto di Windows Installer.