ID do artigo: 834536 - Última revisão: segunda-feira, 22 de março de 2004 - Revisão: 1.1

Provedor WMI de configuração não funcionará se você instalar o .NET Framework versão 1.0 depois de instalar o .NET Framework versão 1.1

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante Este artigo contém informações sobre como modificar o registro. Antes de modificar o registro, certifique-se de backup e certifique-se que você saiba como restaurar o registro se ocorrer um problema. Para obter informações sobre como fazer backup, restaurar e editar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registro do Microsoft Windows

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Se você instalar versão 1.0 do Microsoft .NET Framework depois de você instalou a versão 1.1 do .NET Framework, a ferramenta Testador de WMI, o WBEMTest.exe, não com êxito executa uma consulta, como o "Selecione * de appSettings" consulta. Além disso, você receber a seguinte mensagem de erro:
Falha de carregamento do provedor
Observação A ferramenta WBEMTest.exe é a ferramenta de teste de Web-Based Enterprise Management (WBEM) que implementa (WMI).

Causa

Esse problema ocorre porque duas versões do .NET Framework estão instaladas. A instalação de dois programas faz com que a instalação incorreta do .NET Framework 1.0 WMI Configuration Provider e faz com que a mensagem de erro que é descrito anteriormente.

Resolução

Para resolver esse problema, execute essas etapas:
  1. Inicie o Editor do Registro.

    Clique em Iniciar , clique em Executar , digite %WINDIR%\regedit.exe na caixa Abrir e, em seguida, clique em OK .
  2. Expanda o nó seguinte:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Catalog42\NetFrameworkv1
  3. Altere os Dados do valor de DLL para o seguinte:
    %WINDIR%\Microsoft.NET\Framework\v1.0.3705\netfxcfg.dll
  4. Altere os Dados do valor de MachineConfigDirectory para o seguinte:
    %WINDIR%\Microsoft.NET\Framework\v1.0.3705\CONFIG\
  5. Abra um prompt de comando.

    Clique em Iniciar , clique em Executar , digite cmd na caixa Abrir e, em seguida, clique em OK .
  6. Digite o seguinte comando no prompt de comando e pressione ENTER:
    regsvr32 %windir%\Microsoft.NET\Framework\v1.0.3705\netfxcfgprov.dll
  7. Digite o seguinte comando no prompt de comando e pressione ENTER:
    regsvr32 %windir%\Microsoft.NET\Framework\v1.0.3705\netfxcfg.dll
  8. Reinicie o computador.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft que estão listados na seção "Aplica-se a" deste artigo.

Mais Informações

Etapas para reproduzir o comportamento

  1. Instale o .NET Framework versão 1.1.
  2. Instale o .NET Framework versão 1.0.
  3. Iniciar o gerenciamento do Windows ferramenta Testador de instrumentação, WBEMTest.exe.

    Clique em Iniciar , clique em Executar , digite wbemtest na caixa Abrir e, em seguida, clique em OK . A caixa de diálogo Testador de WMI será exibida.
  4. Clique no botão conectar .
  5. Digite root\NetFrameworkv1 na caixa Namespace e em seguida, clique em conectar .
  6. Clique em consulta .
  7. Tipo Selecione * de appSettings no Digite a consulta caixa e, em seguida, clique em Aplicar .

    Você receber a seguinte mensagem de erro:
    Falha de carregamento do provedor
    .

A informação contida neste artigo aplica-se a:
  • Microsoft .NET Framework 1.0
  • Microsoft .NET Framework 1.1
Palavras-chave: 
kbmt kberrmsg kbprb KB834536 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 834536  (http://support.microsoft.com/kb/834536/en-us/ )