Artikel-ID: 834628 - Geändert am: Dienstag, 24. Juli 2007 - Version: 9.12

Daten beschädigt wird, wenn PAE auf einem Windows Server 2003-Computer aktiviert ist

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Problembeschreibung

Wenn Sie Microsoft SQL Server auf einem Microsoft Windows Server 2003-basierten Computer ausführen, werden möglicherweise Daten, die mit SQL Server-Datenbank gespeichert ist beschädigt.

Wenn Sie die Transaktionsprotokolldatei anzeigen, können einen oder mehrere Protokoll Einträge in der Datei mit einer Zeichenfolge von Nullen gefüllt werden. Die Zeichenfolge von Nullen ist genau einen Datensatz lang und nicht Cache ausgerichtet.

Ursache

Dieses Problem kann auftreten, wenn Sie die Spezifikation von Intel Physical Addressing Extension (PAE), verwenden um mehr als 4 Gigabyte (GB) des installierten Arbeitsspeichers in Ihrem Computer zu unterstützen. Fehlerfall Wenn eine (PTE) müssen seine physische Adresse geändert, und nur das niederwertige Wort hat wurde ausgefüllt, wenn ein anderer Prozessor beginnt mithilfe dieser Seite. Damit eine PTE verwendet wird, bevor seine vollständige physische Adresse zugewiesen wurde, fügt in den Abschnitt "Lösung" beschriebenen Hotfix eine Speicher Barriere Anweisung am Ende der Sequenz PTE Adresse Update.

Speicherbeschädigung ist nicht spezifisch für SQL Server, und es möglicherweise auftreten, wenn Sie andere speicherintensive Programme auf einem System PAE aktiviert ausführen, die mehr als 4 Arbeitsspeicher installiert GB.

Hinweis: Dieser Hotfix ist nur für X 86-Plattform.

Lösung

Informationen zu Service Packs

Installieren Sie das neueste Servicepack für Windows Server 2003, um dieses Problem zu beheben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824721  (http://support.microsoft.com/kb/824721/ ) Windows Server 2003 Servicepack 1 Liste der updates
889100  (http://support.microsoft.com/kb/889100/ ) So erhalten Sie das neueste Servicepack für Windows Server 2003

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Es gelten keine Voraussetzungen.

Neustartanforderung

Sie müssen den Computer nach der Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix wurde durch die RTMQFE-Version (5.2.3790.177)-Sicherheitsupdate MS04-032 ersetzt. Weitere Informationen zum Sicherheitsupdate MS04-032 finden Sie auf folgender der folgenden Microsoft-Website:
http://www.microsoft.com/technet/security/bulletin/ms04-032.mspx (http://www.microsoft.com/technet/security/bulletin/ms04-032.mspx)

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Verwenden Sie die Registerkarte Zeitzone im Element Datum und Uhrzeit in der Systemsteuerung, um die Differenz zwischen UTC und der Ortszeit zu ermitteln.
   Date         Time   Version            Size    File name
   ----------------------------------------------------------------
   09-Jan-2004  22:23  5.2.3790.118    2,064,384  Ntkrnlpa.exe
   09-Jan-2004  22:23  5.2.3790.118    2,108,416  Ntkrpamp.exe
   26-Dec-2003  19:52                        271  Branches.inf
   12-Jan-2004  18:11                     10,119  Kb834628.cat
   12-Jan-2004  18:02                        354  Updatebr.inf
   12-Jan-2004  18:02                      6,975  Update_rtmqfe.inf

Abhilfe

Um dieses Problem zu umgehen, verwenden Sie nicht die / PAE wechseln Sie in der Datei "Boot.ini".

Hinweis: Wenn Sie entfernen die / PAE Schalter aus der Datei Boot.ini Computers kann nicht den gesamten verfügbaren Arbeitsspeicher verwenden.

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind. Dieses Problem wurde erstmals in Windows Server 2003 Service Pack 1.

Weitere Informationen

Weitere Informationen zu Physical Addressing Extensions und Page Table Entry finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
268363  (http://support.microsoft.com/kb/268363/ ) Intel Physical Addressing Extensions (PAE) in Windows 2000
311901  (http://support.microsoft.com/kb/311901/ ) The Effects of 4GT tuning on System Page Table Entries
Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Erläuterung von Standardbegriffen bei Microsoft Softwareupdates
Die in diesem Artikel erwähnten Fremdanbieterprodukte werden von einem Lieferanten hergestellt, der von Microsoft unabhängig ist. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
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kbmt kbautohotfix kbhotfixserver kbbug kbfix kbqfe kbwinserv2003presp1fix KB834628 KbMtde
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 834628  (http://support.microsoft.com/kb/834628/en-us/ )
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