An interrupt storm that is generated by the ACPI driver causes a Windows Server 2003-based computer or a Windows XP-based computer to stop responding

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Article ID: 834631 - View products that this article applies to.
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SYMPTOMS

A Microsoft Windows Server 2003-based computer or a Microsoft Windows XP-based computer may stop responding (hang).

CAUSE

This problem may occur if an interrupt storm is generated by the Acpi.sys driver.

Note An interrupt storm is defined as a level-triggered interrupt signal that remains in an asserted state.

RESOLUTION

Windows Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

The hotfix that addresses this problem is included in Microsoft Knowledge Base article 823749. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
823749 A Windows Server 2003-based computer or a Windows XP-based computer may stop responding

Windows XP

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack
Note The fix for Windows XP was not released as an individual hotfix.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Microsoft Windows Server 2003 Service Pack 1.
This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


After you apply the service pack or the hotfix, you must modify the
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ACPI\Parameters
registry subkey.

To do this, follow these steps.
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ACPI\Parameters
    Note If the Parameters subkey does not exist, right-click ACPI, point to New, and then click Key. Type Parameters as the subkey name, and then press ENTER.
  3. Right-click the Attributes entry, and then click Modify.

    Note If the Attributes entry does not exist, right-click Parameters, point to New, and then click DWORD value. Type Attributes as the entry name, and then press ENTER.
  4. In the Edit DWORD Value dialog box, click Hexadecimal, type 100 in the Value data box, and then click OK.
  5. Quit Registry Editor.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 834631 - Last Review: November 5, 2008 - Revision: 4.0
APPLIES TO
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbwinxpsp2fix kbbug kbfix kbqfe kbwinserv2003presp1fix KB834631

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