Recibirá un mensaje de error "Stop código de error 0 x 00000051" durante la restauración del registro

Seleccione idioma Seleccione idioma
Id. de artículo: 834728 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Si utiliza programas que realizar copia de seguridad del registro y las operaciones de restauración, el equipo puede dejar de responder y puede recibir el mensaje de error siguiente:
Comprobación de errores 0 x 51 (c, c0000005, bddbab34, bddba78c)

Argumentos:
Arg1: 0000000c, (reservado)
Arg2: c0000005, (reservado)
Arg3: bddbab34, depende de dónde se bugchecked de Windows, puede ser un puntero al subárbol
Arg4: bddba78c, depende de dónde se bugchecked de Windows, puede ser código de retorno de HvCheckHive si está dañado el subárbol.
Uso de CPU puede aumentar también inesperadamente al 100% hasta que reinicie el equipo. Cuando el uso de CPU está al 100%, todos los programas que utilizan características de registro pueden dejar de responder.

Causa

Este problema puede producirse si utiliza un programa de control remoto o un programa de copia de seguridad del sistema.

El RegRestoreKey función lee un archivo de subárbol del registro especificado y lo copia en una clave especificada en el registro del sistema. El RegSaveKey función guarda una clave del registro específico y todos los relacionados subclaves a un archivo de sección. Ambas funciones realizan operaciones en el registro del sistema que deben realizarse de forma exclusiva. El problema que se describe en este artículo se produce porque el RegSaveKey y RegRestoreKey se denominan funciones al mismo tiempo en un programa multiproceso.

Solución

Información de hotfix de Windows 2000

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema que se describe en este artículo. Aplíquela sólo en sistemas que experimenten este problema específico.

Si la revisión está disponible para descargar, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si no aparece en esta sección, envíe una solicitud al servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o cualquier solución de problemas es necesario, es posible que deba crear una solicitud de servicio independiente. Se aplicarán los costos de soporte técnico usuales a las cuestiones y problemas que no reúnan los requisitos para esta revisión en cuestión. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Microsoft Windows 2000

Requisito de reinicio

Debe reiniciar el equipo después de aplicar esta revisión.

Información de reemplazo de hotfix

Esta revisión no sustituye a ninguna otra revisión.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o posterior) que se enumeran en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para ver la diferencia entre la hora UTC y la hora local, utilice el Zona horaria ficha de la herramienta Fecha y hora en el Panel de Control.
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   19-Dec-2003  18:57  5.0.2195.6886     30,224  Mountmgr.sys
   05-Feb-2004  20:37  5.0.2195.6897  1,699,776  Ntkrnlmp.exe     
   05-Feb-2004  20:37  5.0.2195.6897  1,699,200  Ntkrnlpa.exe     
   05-Feb-2004  20:37  5.0.2195.6897  1,720,000  Ntkrpamp.exe     
   05-Feb-2004  20:37  5.0.2195.6897  1,677,312  Ntoskrnl.exe

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:" de este artículo.

Más información

Para obtener información adicional acerca de la RegSaveKey y RegRestoreKey funciones, visite el siguiente sitio Web de Microsoft:
http://msdn.Microsoft.com
Para obtener información adicional acerca de cómo se denominan los paquetes de revisión, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
816915Nuevo esquema de nomenclatura para los paquetes de actualización de software de Microsoft Windows
824684 Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 834728 - Última revisión: lunes, 16 de enero de 2012 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Palabras clave: 
kbautohotfix kbhotfixserver kbqfe kbwin2000presp5fix kbbug kbfix kbmt KB834728 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 834728

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com