Un message d'erreur « Stop code d'erreur 0 x 00000051 » s'affiche pendant la restauration du Registre

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Numéro d'article: 834728 - Voir les produits auxquels s'applique cet article
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Sommaire

Symptômes

Lorsque vous utilisez des programmes qu'effectuer la sauvegarde du Registre et les opérations de restauration, votre ordinateur peut cesser de répondre et vous pouvez recevoir le message d'erreur suivant :
Vérification d'erreur 0 x 51 (c, c0000005, bddbab34, bddba78c)

Arguments :
Arg1 : HKEY_CLASSES_ROOT\\Interface\ 0000000c, (réservé)
Arg2 : c0000005, (réservé)
Arg3 : bddbab34, dépend où Windows bugchecked, peut-être un pointeur vers la ruche
Arg4 : bddba78c, dépend où Windows bugchecked, peut être le code de retour de par HvCheckHive si la ruche est endommagée.
Utilisation du processeur peut augmenter également de manière inattendue à 100 % jusqu'à ce que vous redémarriez l'ordinateur. Lorsque l'utilisation du processeur est à 100 %, tous les programmes qui utilisent les fonctions du Registre peuvent cesser de répondre.

Cause

Ce problème peut se produire si vous utilisez un programme de contrôle à distance ou un programme de sauvegarde système.

Le RegRestoreKey fonction lit un fichier ruche de Registre spécifié et la copie d'une clé spécifiée dans le Registre système. Le Endommagement fonction enregistre une clé de Registre spécifique et tous les correspondants des sous-clés dans un fichier ruche. Les deux fonctions effectuent des opérations sur la base de registres qui doivent être effectuées exclusivement. Le problème décrit dans cet article se produit parce que le Endommagement et RegRestoreKey fonctions sont appelées en même temps dans un programme multithreads.

Résolution

Informations sur le correctif Windows 2000

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu uniquement pour corriger le problème qui est décrite dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique.

Si le correctif est disponible au téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » en haut de cet article de la Base de connaissances. Si cette section n'apparaît pas, soumettre une demande au Service clientèle de Microsoft et de Support pour obtenir le correctif.

Remarque Si d'autres problèmes se produisent ou si des procédures de dépannage est nécessaire, vous devrez créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes qui ne relèvent pas de ce correctif spécifique. Pour une liste complète des numéros de téléphone Service clientèle de Microsoft et prise en charge ou pour créer une demande de service distincte, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.Microsoft.com/contactus/?ws=support
Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, il est dans la mesure où un correctif n'est pas disponible pour cette langue.

Conditions préalables

Microsoft Windows 2000

La nécessité de redémarrer

Vous devez redémarrer votre ordinateur après avoir appliqué ce correctif.

Informations de remplacement du correctif

Ce correctif ne remplace pas d'autres correctifs.

Informations sur les fichiers

La version anglaise de ce correctif possède les attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriés dans le temps universel coordonné (UTC). Lorsque vous affichez les informations du fichier, il est converti en heure locale. Pour connaître la différence entre l'UTC et l'heure locale, utilisez la Fuseau horaire onglet dans l'outil Date et heure du Panneau de configuration.
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   19-Dec-2003  18:57  5.0.2195.6886     30,224  Mountmgr.sys
   05-Feb-2004  20:37  5.0.2195.6897  1,699,776  Ntkrnlmp.exe     
   05-Feb-2004  20:37  5.0.2195.6897  1,699,200  Ntkrnlpa.exe     
   05-Feb-2004  20:37  5.0.2195.6897  1,720,000  Ntkrpamp.exe     
   05-Feb-2004  20:37  5.0.2195.6897  1,677,312  Ntoskrnl.exe

Statut

Microsoft a confirmé qu'il s'agit d'un problème dans les produits Microsoft répertoriés dans la section « S'applique à » de cet article.

Plus d'informations

Pour plus d'informations sur la Endommagement et RegRestoreKey fonctions, reportez-vous au site Web de Microsoft à l'adresse suivante :
adresse http://msdn.Microsoft.com
Pour plus d'informations sur la façon de nommer les packages de correctifs, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
816915Nouveau schéma d'affectation de noms pour les packages de mise à jour logicielle Microsoft Windows
824684 Description de la terminologie standard utilisée pour décrire les mises à jour du logiciel Microsoft

Propriétés

Numéro d'article: 834728 - Dernière mise à jour: lundi 16 janvier 2012 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professionnel
  • Microsoft Windows 2000 Server
Mots-clés : 
kbautohotfix kbhotfixserver kbqfe kbwin2000presp5fix kbbug kbfix kbmt KB834728 KbMtfr
Traduction automatique
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La version anglaise de cet article est la suivante: 834728
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