Viene visualizzato un messaggio di errore "Stop 0x00000051 del codice di errore" durante il ripristino del Registro di sistema

Traduzione articoli Traduzione articoli
Identificativo articolo: 834728 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si utilizzano programmi che eseguire il backup del Registro di sistema e le operazioni di ripristino, il computer potrebbe smettere di rispondere che Ŕ possibile che venga visualizzato il seguente messaggio di errore:
Controllo errori 0x51 (c, c0000005, bddbab34, bddba78c)

Argomenti:
Arg1: 0000000c, (riservato).
Arg2: c0000005, (riservato).
Arg3: bddbab34, dipende dalla posizione in cui bugchecked di Windows, potrebbe essere un puntatore all'hive
Arg4: bddba78c, dipende dalla posizione in cui bugchecked di Windows, potrebbe essere il codice di ritorno di HvCheckHive se l'hive Ŕ danneggiato.
Utilizzo della CPU anche in modo imprevisto pu˛ aumentare fino al 100%, fino a quando non si riavvia il computer. Una volta l'utilizzo della CPU al 100%, tutti i programmi che utilizzano le funzionalitÓ del Registro di sistema potrebbero non rispondere.

Cause

Questo problema pu˛ verificarsi se si utilizza un programma di controllo remoto o un programma di backup del sistema.

Il RegRestoreKey funzione legge un file di hive del Registro di sistema specificata e viene copiato in una chiave specificata nel Registro di sistema. Il RegSaveKey funzione consente di salvare una chiave del Registro di sistema e tutte le sottochiavi in un file hive. Entrambe le funzioni eseguono operazioni nel Registro di sistema che devono essere eseguiti in modo esclusivo. Il problema descritto in questo articolo si verifica perchÚ il RegSaveKey e RegRestoreKey funzioni vengono chiamate nello stesso momento in un programma multithread.

Risoluzione

Informazioni sull'hotfix per Windows 2000

Un hotfix supportato Ŕ disponibile da Microsoft. Tuttavia, questo hotfix Ŕ destinato esclusivamente alla risoluzione il problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico.

Se l'aggiornamento rapido Ŕ disponibile per il download, Ŕ presente una sezione "Hotfix disponibile per il download" nella parte superiore di questo articolo della Knowledge Base riportato di seguito. Se non viene visualizzato in questa sezione, Ŕ possibile inviare una richiesta al servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se Ŕ richiesta la risoluzione dei problemi, Ŕ necessario creare una richiesta di assistenza separata. I costi di supporto usuali verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido non Ŕ disponibile per tale lingua.

Prerequisiti

Microsoft Windows 2000

Richiesta di riavvio

Dopo aver applicato questo hotfix, Ŕ necessario riavviare il computer.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce eventuali altri aggiornamenti rapidi.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o successivi) elencati nella tabella riportata di seguito. Le date e ore dei file elencate nel tempo universale coordinato (UTC). Quando si visualizzano le informazioni del file, viene convertita in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare il Fuso orario scheda dello strumento Data e ora nel Pannello di controllo.
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   19-Dec-2003  18:57  5.0.2195.6886     30,224  Mountmgr.sys
   05-Feb-2004  20:37  5.0.2195.6897  1,699,776  Ntkrnlmp.exe     
   05-Feb-2004  20:37  5.0.2195.6897  1,699,200  Ntkrnlpa.exe     
   05-Feb-2004  20:37  5.0.2195.6897  1,720,000  Ntkrpamp.exe     
   05-Feb-2004  20:37  5.0.2195.6897  1,677,312  Ntoskrnl.exe

Status

Microsoft ha confermato che si tratta di un problema con i prodotti elencati nella sezione "Si applica a" di questo articolo.

Informazioni

Per ulteriori informazioni sui RegSaveKey e RegRestoreKey funzioni, visitare il seguente sito Web Microsoft:
http://www.microsoft.com/italy/msdn
Per ulteriori informazioni sulla denominazione dei pacchetti di hotfix, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
816915Nuovo schema di denominazione per i pacchetti di aggiornamento del software Microsoft Windows
824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

ProprietÓ

Identificativo articolo: 834728 - Ultima modifica: lunedý 16 gennaio 2012 - Revisione: 1.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Chiavi:á
kbautohotfix kbhotfixserver kbqfe kbwin2000presp5fix kbbug kbfix kbmt KB834728 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 834728
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com