Zápis sestav řízených parametry pro aplikaci Microsoft CRM 1.2 pomocí nástroje Crystal Reports 9

Překlady článku Překlady článku
ID článku: 834790 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

K dispozici jsou ke stažení tři ukázkové sestavy, které popisují, jak pomocí nástroje Crystal Reports 9 verze Professional, Developer nebo Advanced zapsat sestavy řízené parametry pro aplikaci Microsoft Business Solutions CRM verze 1.2. Parametry vylepšují provedení sestav tím, že omezují množství dat zahrnutých v sestavě. Sestavy řízené parametry tedy pomáhají vytvořit sestavy, které obsahují pouze potřebná data.

Další informace

Stažení ukázkových sestav řízených parametry

Chcete-li stáhnout ukázkové sestavy, navštivte následující web Stažení softwaru společnosti Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyID=1d08d05e-a8e1-46ef-a808-ac388be24a3e&DisplayLang=en
Další informace o tom, jak stahovat soubory podpory společnosti Microsoft, naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
119591 Jak získat soubory odborné pomoci společnosti Microsoft ze serverů služeb online
Tento soubor byl zkontrolován na výskyt virů. Společnost Microsoft použila ke kontrole tohoto souboru nejnovější antivirový software, který byl v době jeho publikování k dispozici. Po publikování je soubor uložen na zabezpečených serverech znemožňujících neoprávněné změny souboru.

Informace o instalaci

Postupujte podle pokynů na stránce pro stažení.

Informace o odinstalaci

Chcete-li ukázkové soubory odebrat, odstraňte je.

Požadavek na restartování

Po instalaci ukázkových sestav není třeba počítač restartovat.

Informace o souborech

Anglické verze těchto souborů s ukázkovými sestavami mají následující atributy. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Při zobrazení informací o souboru jsou data a čas převedeny na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo na ovládacím panelu Datum a čas.
Datum      Čas   Velikost    Název souboru ------------------------------------------------------------------------------------------- 20. 1. 2004  09:54  65 024  Account Activity And Notes (specify status, owner, date).rpt 20. 1. 2004  09:57  64 000  Case List (specify owner, status, date).rpt  2. 1. 2004  10:19  103 936 Opportunity List By Account (specify owner, date, accounts).rpt

Přidání ukázkových sestav do aplikace Microsoft CRM

Chcete-li sestavu zobrazit v aplikaci Microsoft CRM, musíte ji uložit do stávajících složek se sestavami aplikace Microsoft CRM.

Nástroj Crystal Reports 9

Chcete-li k uložení sestavy v aplikaci Microsoft CRM použít nástroj Crystal Reports 9, postupujte následovně:
  1. Nainstalujte tři ukázkové sestavy z webu Stažení softwaru společnosti Microsoft, jak je popsáno výše v části Řešení.
  2. Otevřete každý soubor v nástroji Crystal Reports 9:
    1. V nabídce File (Soubor) klepněte na příkaz Save as (Uložit jako).
    2. Klepněte na možnost Enterprise (Podnik).
    3. Zadejte informace o svém účtu a klepněte na tlačítko OK.
    4. Rozbalte položku MSCRM1.2.
    5. Rozbalte uzel Admin Reports (Správcovské sestavy), Sales Reports (Sestavy prodeje) nebo Service Reports (Sestavy služeb).
    6. Klepněte na podsložku, do které chcete sestavu umístit.
    7. Zadejte název souboru a poté klepněte na tlačítko OK.

Nástroj Microsoft CRM 1.2 Report Manager

Další informace o tom, jak stáhnout nástroj Microsoft CRM 1.2 Report Manager, naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
834791 Přidání, odstranění a přejmenování sestav aplikace Microsoft CRM pomocí nástroje Microsoft CRM 1.2 Report Manager (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
Chcete-li sestavu uložit do stávajících složek se sestavami aplikace Microsoft CRM, postupujte následovně:
  1. Nainstalujte tři ukázkové sestavy.
  2. Spusťte nástroj Microsoft CRM 1.2 Report Manager.
  3. Pro každý soubor proveďte následující kroky:
    1. Vyhledejte složku, do které chcete soubor uložit.
    2. Klepněte na tlačítko Add Report (Přidat sestavu).
    3. Zadejte název souboru a staženou sestavu a poté klepněte na tlačítko Add Report (Přidat sestavu).

Jak pomocí nástroje Crystal Reports 9 přidat do sestavy aplikace Microsoft CRM parametry

Úvod

Chcete-li pomocí nástroje Crystal Reports 9 přidat do sestavy aplikace Microsoft CRM parametr, je třeba provést následující kroky. Následující části tohoto článku dále rozvíjejí každý z těchto kroků.
  1. Definujte parametr. Provedete to tak, že zadáte název parametru, text, který bude od uživatele požadován, prvky rozevíracího seznamu a výchozí hodnotu.
  2. Umístěte všechna pole parametrů do sestavy. Pole mohou být viditelná nebo skrytá.
  3. Přidejte do vzorce pro výběr záznamů kód, který porovná údaje zadané uživatelem do parametru s údaji z aplikace Microsoft CRM.
  4. Uložte sestavu a přidaný parametr vyzkoušejte.
Pomocí nástroje Crystal Reports lze přidat mnoho typů parametrů. Tento článek uvádí pouze čtyři příklady. Každý příklad ukazuje jiný aspekt použití parametrů s daty aplikace Microsoft CRM. Tento článek obsahuje následující příklady:
  • Parametr Owner (Vlastník), který uživatelům umožňuje vybrat pouze jejich vlastní záznamy nebo všechny záznamy. Tento příklad vysvětluje, jak pomocí speciálního parametru UserID (ID uživatele) určit identifikátor GUID aplikace Microsoft CRM uživatele, který sestavu spustil.
  • Parametr Status (Stav), který uživateli umožňuje vybrat ze všech hodnot stavu dostupných pro entitu v aplikaci Microsoft CRM. Tento příklad ukazuje, jak lze z pole v aplikaci Microsoft CRM přečíst seznam dostupných hodnot pro použití ve volbách parametru.
  • Parametr Date Created (Datum vytvoření), který uživateli umožňuje vybrat z předdefinovaných rozsahů dat: všechna, během posledních 60 dní nebo tento rok. Tento příklad ukazuje, jak lze v nástroji Crystal Reports 9 použít standardní datové metody.
  • Parametr Date Range (Rozsah dat), který uživateli umožňuje zadat počáteční a koncové datum rozsahu. Tento příklad ukazuje, jak použít parametr rozsahu a jak v závislosti na poli parametru vytvořit další pole se vzorci. V tomto případě je rozsahem parametr Date Range (Rozsah dat) a jsou vytvořeny dvě nové proměnné StartDate (Počáteční datum) a EndDate (Koncové datum) pro použití v záhlaví stránky sestavy.

Předtím, než začnete

Jak pracuje nástroj Crystal Reports s aplikací Microsoft CRM 1.2
Před vytvořením parametrizované sestavy se ujistěte, že rozumíte tomu, jak nástroj Crystal Reports s aplikací Microsoft CRM 1.2 pracuje:
  • Uživatelům aplikace Microsoft CRM jsou dostupné pouze sestavy v uzlu Enterprise/MSCRM1.2.
  • V uzlu MSCRM1.2 nelze vytvořit nové složky.
  • Pomocí nástroje Crystal Reports nelze sestavu přímo přejmenovat. Chcete-li sestavu odstranit, musíte použít nástroj Microsoft CRM 1.2 Report Manager.

    Další informace o nástroji Report Manager získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
    834791 Přidání, odstranění a přejmenování sestav pomocí nástroje Microsoft CRM 1.2 Report Manager (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
  • Pomocí nástroje Crystal Reports nelze sestavu přímo přejmenovat. Uložte sestavu pomocí nástroje Microsoft CRM 1.2 Report Manager nebo Crystal Reports s novým názvem. Tyto metody přejmenování sestav změní název v aplikaci Microsoft CRM, ale nezmění nadpis zobrazený v části Page Header (Záhlaví stránky) sestavy. Chcete-li změnit nadpis, klepněte v nabídce File (Soubor) nástroje Crystal Reports 9 na příkaz Summary Info (Souhrnné informace) a poté změňte nadpis v poli Report Title (Název sestavy).
  • Nápovědu k vytváření parametrů naleznete v online nápovědě nástroje Crystal Reports 9.
Vytvoření sestavy řízené parametry
Nejjednodušším způsobem, jak vytvořit sestavu řízenou parametry, je uložit stávající sestavu aplikace Microsoft CRM verze 1.2 s novým názvem a potom tuto kopii upravit:
  1. V nabídce Start přejděte na příkaz Programy a klepněte na položku Crystal Reports 9.
  2. Na stránce Welcome to Crystal Reports (Vítá vás aplikace Crystal Reports) klepněte na tlačítko Cancel (Zrušit).
  3. V nabídce File (Soubor) klepněte na příkaz Open (Otevřít).
  4. Klepněte na příkaz Enterprise (Podnik) a poté na tlačítko OK.
  5. Zadejte svoje ověřovací informace pro službu Crystal APS a poté klepněte na tlačítko OK.
  6. Rozbalte položku MSCRM1.2, klepněte na sestavu, kterou chcete upravit, a poté klepněte na příkaz Open (Otevřít).
  7. V nabídce File (Soubor) klepněte na příkaz Save As (Uložit jako), vyhledejte umístění, kam chcete soubor v uzlu MSCRM1.2 uložit, zadejte název a poté klepněte na tlačítko OK.
Upravujete-li sestavy aplikace Microsoft CRM pomocí nástroje Crystal Reports 9 poprvé, máte-li problémy s připojením nebo nemůžete-li sestavy uložit, další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
834789 Nejčastější dotazy týkající se sestav aplikace Microsoft Business Solutions CRM 1.2

Přidání parametru Owner (Vlastník)

Pomocí parametru Owner (Vlastník) si uživatel může vybrat mezi vlastními záznamy a všemi záznamy. Uživatel tedy nemusí vybírat z rozevíracího seznamu, který obsahuje všechny uživatele.

Aby bylo možné rozlišit záznamy, které vlastní uživatel spouštějící sestavu, musí být sestava schopná rozpoznat identifikátor GUID systému Microsoft CRM uživatele spouštějícího sestavu. Vytvoří-li zapisovatel sestavy parametr UserID (ID uživatele), aplikace Microsoft CRM jako jeho hodnotu automaticky přiřadí identifikátor GUID aplikace Microsoft CRM uživatele, který sestavu spouští. Na rozdíl od ostatních parametrů není uživatel vyzván k zadání hodnoty.

Vytvořte parametr Owner (Vlastník) s hodnotami Mine (Moje) nebo All (Vše). Pokud uživatel spustí sestavu a klepne na možnost Mine (Moje), jsou vybrány jeho vlastní záznamy za předpokladu, že se shoduje parametr UserID (ID uživatele) s polem entita.owner. Klepne-li uživatel na možnost All (Vše), jsou zahrnuty všechny záznamy.

Následující příklad využívá sestavu založenou na entitě Account (Obchodní vztah).
Krok 1: Definování parametru UserID (ID uživatele), do kterého se uloží identifikátor GUID aplikace Microsoft CRM aktuálního uživatele
Chcete-li definovat parametr UserID (ID uživatele), do kterého se uloží identifikátor GUID aktuálního uživatele, postupujte následovně:
  1. V podokně Field Explorer (Průzkumník polí) v nástroji Crystal Reports 9 klepněte pravým tlačítkem myši na položku Parameter Fields (Pole parametrů) a poté klepněte na příkaz New (Nový).
  2. Do pole Name (Název) zadejte UserID (ID uživatele) a poté klepněte na tlačítko OK.
Krok 2: Definování parametru Owner (Vlastník)
Chcete-li definovat parametr Owner (Vlastník), který uživatele vyzve k výběru možnosti Mine (Moje) nebo All (Vše), postupujte následovně:
  1. V podokně Field Explorer (Průzkumník polí) klepněte pravým tlačítkem myši na položku Parameter Fields (Pole parametrů) a poté klepněte na příkaz New (Nový).
  2. Do pole Name (Název) zadejte Owner (Vlastník).
  3. Do pole Prompting (Dotazování) zadejte dotaz, který se uživateli zobrazí. Zadejte například:
    Zadejte, které záznamy chcete zahrnout.
  4. Klepněte na tlačítko Set Default Values (Nastavit výchozí hodnoty).
  5. Zadejte hodnoty, které chcete zobrazit v rozevíracím seznamu. V tomto příkladu jsou použity hodnoty Mine (Moje) a All (Vše). Pomocí tlačítka > lze jednotlivé hodnoty přesunout do seznamu Default Values (Výchozí hodnoty).
  6. U každé hodnoty klepněte na tlačítko Define Description (Definovat popis) a poté zadejte text, který chcete zobrazit v rozevíracím seznamu pro parametr Owner (Vlastník).
  7. V rozevíracím seznamu Display (Zobrazit) klepněte na položku Description (Popis) a poté klepněte na tlačítko OK.
  8. V dialogovém okně Create Parameter Field (Vytvořit pole parametru) zrušte zaškrtnutí políčka Allow editing of default values when there is more than one value (V případě více než jedné hodnoty povolit úpravu výchozích hodnot).
  9. Uložte nový parametr klepnutím na tlačítko OK.
Chcete-li, aby parametr Owner (Vlastník) fungoval, je třeba jej zahrnout do sestavy. Provedete to tak, že parametr přetáhnete z podokna Field Explorer (Průzkumník polí) na libovolné místo v sestavě. Všechny nové parametry je vhodné přidat do části Page Header (Záhlaví stránky) sestavy. Jsou-li parametry uvedeny v části Page Header (Záhlaví stránky), může uživatel rychle zjistit, jaká data sestava obsahuje. Pokud nechcete, aby byla hodnota parametru Owner (Vlastník) v sestavě uvedena, přetáhněte jej do skryté oblasti na sestavě.
Krok 3: Použití parametru Owner (Vlastník) v záhlaví stránky
  1. Protože parametr Owner (Vlastník) je první parametr, který do záhlaví stránky přidáváte, musíte vytvořit textové pole, které bude obsahovat stávající pole Report Title (Název sestavy). Postupujte následujícím způsobem:
    1. Klepněte v sestavě pravým tlačítkem myši na pole Report Title (Název sestavy) a poté klepněte na příkaz Delete (Odstranit).
    2. V nabídce Insert (Vložit) klepněte na příkaz Text Object (Textový objekt) a nový text umístěte na místo, kde bylo pole Report Title (Název sestavy).
    3. V podokně Field Explorer (Průzkumník polí) rozbalte položku Special Fields (Speciální pole).
    4. Přetáhněte speciální pole Report Title (Název sestavy) do nového textového objektu.
  2. Přetáhněte parametr Owner (Vlastník) z části Parameter Fields (Pole parametrů) podokna Field Explorer (Průzkumník polí) do nového textového objektu.
  3. Oddělte název od parametru Owner (Vlastník) přidáním vhodného oddělovacího textu nebo mezer.
  4. Chcete-li, aby se písmo shodovalo s ostatními sestavami aplikace Microsoft CRM, klepněte na nový objekt pravým tlačítkem myši a poté klepněte na příkaz Format Text (Formát textu). Na kartě Font (Písmo) klepněte na možnosti Verdana, Bold (Tučně) a Yellow (Žluté) a poté klepněte na tlačítko OK.
Krok 4: Přidání parametru Owner (Vlastník) do vzorce pro výběr záznamů
Vzorec pro výběr záznamů

Vzorec pro výběr záznamů definuje, které záznamy jsou v sestavě zahrnuty. Vzorec je tvořen následující strukturou:
(if {?Parametr1} = "Parametr1_Možnost1" and {tabulka.pole} = "hodnota1" then true else if {?Parametr1} = "Parametr1_Možnost2" and {tabulka.pole} = "hodnota2" then true)
Další informace o vzorcích pro výběr sestavy včetně šablon pro různé typy parametrů naleznete v online nápovědě nástroje Crystal Reports 9 v části Record selection formulas (Vzorce pro výběr záznamů).

V následujícím postupu je vytvořen vzorec pro výběr záznamů ověřující hodnotu parametru Owner (Vlastník), na kterou uživatel klepne. Pokud uživatel klepne na možnost Mine (Moje), jsou v sestavě zahrnuty pouze obchodní vztahy, které uživatel vlastní.

Pokud upravovaná sestava není založena na entitě Account (Obchodní vztah), nahraďte text account.userid textem entita.ownerid.

Přidání parametru Owner (Vlastník) do vzorce pro výběr záznamů

Chcete-li do vzorce pro výběr záznamů přidat parametr Vlastník, postupujte následovně:
  1. V nabídce Report (Sestava) klepněte na příkaz Selection Formulas (Vzorce pro výběr) a poté klepněte na možnost Record (Záznam).
  2. Maximalizujte okno.
  3. Není-li v pravém dolním podokně nic uvedeno, zadejte v prvním řádku následující vzorec bez operátoru and. Obsahuje-li již toto podokno kód, přidejte všechny tři řádky včetně operátoru and na konec seznamu.
    and
    (if {?Owner} = "Mine" then {account.ownerid} = {?UserID} 
          else true)
    Při spuštění sestavy se zobrazí dotaz na parametr Owner (Vlastník) se zadaným textem dotazu. Klepne-li uživatel na tlačítko OK, zobrazí se data sestavy.
  4. Klepněte na tlačítko Save (Uložit) a potom klepněte na tlačítko Close (Zavřít).

Přidání parametru Status (Stav)

Tato část popisuje, jak přidat parametr stavu založený na hodnotě pole entita.statecode v aplikaci Microsoft CRM. Možnosti, které uživatelům dáte, jsou založeny na hodnotách tohoto pole v aplikaci Microsoft CRM. V tomto příkladu je použita entita Activity (Aktivita).
Krok 1: Definování parametru Status (Stav)
Chcete-li definovat parametr Status (Stav), postupujte následovně:
  1. V podokně Field Explorer (Průzkumník polí) klepněte pravým tlačítkem myši na položku Parameter Fields (Pole parametrů) a poté klepněte na příkaz New (Nový).
  2. Do pole Name (Název) zadejte text Status (Stav).
  3. Do pole Prompting text (Text dotazu) zadejte dotaz, který chcete zobrazit. Zadejte například:
    Zahrnout aktivity v následujícím stavu
  4. Klepněte na tlačítko Set Default Values (Nastavit výchozí hodnoty).
  5. V poli Browse Table (Procházet tabulku) klepněte na název tabulky, která obsahuje pole stavu. V tomto příkladu je použita entita Activity (Aktivita). Klepněte proto na možnost activity (aktivita).
  6. V poli Browse Field (Procházet pole) klepněte na možnost statecodename.
  7. Na stránce Connection Info (Informace o připojení) zrušte zaškrtnutí políčka Connect to Local Computer (Připojit k místnímu počítači).
  8. Načtěte seznam aktuálních hodnot v aplikaci Microsoft CRM. Provedete to tak, že v poli Server nahradíte název svého počítače názvem svého serveru Microsoft CRM. Pokud toto pole obsahuje například text http://tentopocitac/MSCRMServices, změňte jej na text http://Vas_serverCRM/MSCRMServices a poté klepněte na tlačítko Finish (Dokončit)

    Poznámka: Nástroj Crystal Reports 9 čte všechny hodnoty pole entita.statecode používané aktuálními daty v aplikaci Microsoft CRM. Tyto hodnoty nemusí představovat všechny hodnoty, které se v tomto poli zobrazí v aplikaci Microsoft CRM. Úplný seznam výchozích hodnot pro rozevírací seznamy naleznete v Příloze A příručky Microsoft Business Solutions CRM Implementation Guide. Pokud jste změnili rozevírací seznam, zobrazte pole v aplikaci Microsoft CRM, abyste se ujistili, že jste v parametru zahrnuli všechny hodnoty.
  9. Klepněte na každou hodnotu, kterou chcete v rozevíracím seznamu zahrnout, a poté ji klepnutím na tlačítko >přesuňte do seznamu Default Values (Výchozí hodnoty).
  10. U každé hodnoty klepněte na tlačítko Define Description (Definovat popis) a poté zadejte text, který chcete zobrazit v rozevíracím seznamu pro parametr Owner (Vlastník).
  11. Seřaďte hodnoty tak, aby možnost, kterou chcete použít jako výchozí, byla v seznamu na prvním místě.
  12. V rozevíracím seznamu Display (Zobrazit) klepněte na položku Description (Popis) a poté klepněte na tlačítko OK.
  13. V dialogovém okně Create Parameter Field (Vytvořit pole parametru) zrušte zaškrtnutí políčka Allow editing of default values when there is more than one value (V případě více než jedné hodnoty povolit úpravu výchozích hodnot).
  14. Uložte nový parametr klepnutím na tlačítko OK.
Chcete-li, aby nový parametr Status (Stav) fungoval, je třeba jej zahrnout do sestavy. Provedete to tak, že parametr přetáhnete z podokna Field Explorer (Průzkumník polí) na libovolné místo v sestavě. V následujícím postupu (Krok 2) se předpokládá, že jste již v záhlaví sestavy vytvořili textové pole k umístění pole Report Title (Název sestavy) a parametru Owner (Vlastník).
Krok 2: Použití parametru Status (Stav) v záhlaví stránky
Chcete-li parametr Status (Stav) použít v záhlaví stránky, postupujte následovně:
  1. Přetáhněte parametr Status (Stav) z části Parameter Fields (Pole parametrů) podokna Field Explorer (Průzkumník polí) do textového objektu v části Page Header (Záhlaví stránky).
  2. Oddělte parametr Status (Stav) od parametru Owner (Vlastník) přidáním oddělovacího textu nebo mezer.
V následujícím postupu (Krok 3) je vytvořen vzorec pro výběr záznamů ověřující uživatelem vybranou hodnotu parametru Status (Stav). Klepne-li uživatel na možnost All (Vše), jsou zahrnuty všechny aktivity. Jinak jsou zahrnuty pouze záznamy, u kterých se hodnota pole v aplikaci Microsoft CRM shoduje s parametrem vybraným uživatelem.

Pokud upravovaná sestava není založena na entitě Activity (Aktivita), nahraďte text activity.statecodename textem entita.statecodename.
Krok 3: Přidání parametru Status (Stav) do vzorce pro výběr záznamů
Chcete-li do vzorce pro výběr záznamů přidat parametr Status (Stav), postupujte následovně:
  1. V nabídce Report (Sestava) klepněte na příkaz Selection Formulas (Vzorce pro výběr) a poté klepněte na možnost Record (Záznam).
  2. Maximalizujte okno.
  3. Není-li v pravém dolním podokně nic uvedeno, zadejte v prvním řádku následující vzorec bez operátoru and. Obsahuje-li již toto podokno kód, přidejte všechny tři řádky včetně operátoru and na konec seznamu.
    and
         (if {?Status} = "All" then true 
         else {activity.statecodename}={?Status})
  4. Klepněte na tlačítko Save (Uložit) a potom klepněte na tlačítko Close (Zavřít).
Při spuštění sestavy se zobrazí dotaz na parametr Status (Stav) se zadaným textem dotazu. Poté, co uživatel klepne na tlačítko OK, se zobrazí data sestavy.

Přidání parametrů Date (Datum)

Tato část popisuje, jak pomocí parametru přimět uživatele k zadání rozsahu dat. Rozsah dat musí být založen na hodnotách jednoho nebo více polí v aplikaci Microsoft CRM. Každá entita obsahuje pole entita.createdon (entita.vytvořeno) a entita.modifiedon (entita.změněno). Některé entity mají další datová políčka. Například aktivity mají data založená na naplánovaném a skutečném čase.

Můžete vytvořit parametr, který uživatele vyzve, aby v rozevíracím seznamu vybral položku s předdefinovanými rozsahy dat, jako je posledních 60 dní nebo tento rok, nebo aby zadal konkrétní počáteční a koncové datum.

Následující dva příklady používají entitu Incident (Case) (Oznámení (Případ)).
Přidání parametru Date Created (Vytvořeno)
Parametr Date Created (Vytvořeno) zobrazí výzvu se seznamem konkrétních předdefinovaných rozsahů dat. Chcete-li přidat parametr Date Created (Vytvořeno) postupujte následovně:
  1. Chcete-li definovat parametr Date Created (Vytvořeno) postupujte následovně:
    1. V podokně Field Explorer (Průzkumník polí) klepněte pravým tlačítkem myši na položku Parameter Fields (Pole parametrů) a poté klepněte na příkaz New (Nový).
    2. Do pole Name (Název) zadejte Date Created (Vytvořeno).
    3. Do pole Prompting (Dotaz) zadejte dotaz, který chcete zobrazit. Zadejte například:
      Vyberte záznamy vytvořené:
    4. Klepněte na tlačítko Set Default Values (Nastavit výchozí hodnoty).
    5. Zadejte hodnoty, které chcete zobrazit v rozevíracím seznamu. V tomto příkladu jsou použity hodnoty Within Past 60 Days (během posledních 60 dní), Year To Date (tento rok) a All (vše). Pomocí tlačítka > lze jednotlivé hodnoty přesunout do seznamu Default Values (Výchozí hodnoty).
    6. U každé hodnoty klepněte na tlačítko Define Description (Definovat popis) a poté zadejte text, který chcete zobrazit v rozevíracím seznamu parametru Date Created (Vytvořeno).
    7. V rozevíracím seznamu Display (Zobrazit) klepněte na položku Description (Popis) a poté klepněte na tlačítko OK.
    8. V dialogovém okně Create Parameter Field (Vytvořit pole parametru) zrušte zaškrtnutí políčka Allow editing of default values when there is more than one value (V případě více než jedné hodnoty povolit úpravu výchozích hodnot).
    9. Uložte nový parametr klepnutím na tlačítko OK.
  2. Chcete-li parametr Date Created (Vytvořeno) použít v záhlaví stránky, postupujte následovně:
    1. Přetáhněte parametr Date Created (Vytvořeno) z části Parameter Fields (Pole parametrů) podokna Field Explorer (Průzkumník polí) do textového objektu v části Page Header (Záhlaví stránky).
    2. Oddělte parametr Date Created (Vytvořeno) od parametru Status (Stav) přidáním oddělovacího textu nebo mezer.
  3. Není-li vytvářená sestava založena na entitě Incident (Oznámení), nahraďte text incident.createdon textem entita.createdon.

    V kroku 4 je vytvořen vzorec pro výběr záznamů, který kontroluje hodnotu parametru Date Created (Vytvořeno) vybranou uživatelem. Klepne-li uživatel na možnost All (Vše), jsou zahrnuty všechny záznamy. V opačném případě se zobrazí pouze záznamy, které splňují kritéria definovaná ve vzorci pro výběr záznamů. Kód se vzorcem pro výběr používá tři předdefinované datové metody nástroje Crystal Reports: Aged0To30Days (0 až 30 dní staré), Aged31To60Days (31 až 60 dní staré) a YearToDate (tento rok).
  4. Přidejte parametr Date Created (Vytvořeno) do vzorce pro výběr záznamů. Postupujte následujícím způsobem:
    1. V nabídce Report (Sestava) klepněte na příkaz Selection Formulas (Vzorce pro výběr) a poté klepněte na možnost Record (Záznam).
    2. Maximalizujte okno.
    3. Není-li v pravém dolním podokně nic uvedeno, zadejte v prvním řádku následující vzorec bez operátoru and. Obsahuje-li již toto podokno kód, přidejte všechny tři řádky na konec seznamu.
      and
      (if {?Date Created}="Within Past 60 Days" and   {incident.createdon} in Aged0To30Days or {incident.createdon} in Aged31To60Days then true
      else if {?Date Created}="Year To Date" and {incident.createdon}in YearToDate then true
      )
    4. Klepněte na tlačítko Save (Uložit) a potom klepněte na tlačítko Close (Zavřít).
    Při spuštění sestavy se zobrazí dotaz na parametr Date Created (Vytvořeno) se zadaným textem dotazu. Klepne-li uživatel na tlačítko OK, zobrazí se data sestavy.
Přidání parametru Date Range (Rozsah dat)
Parametr Date Range (Rozsah dat) uživatele vyzve k zadání konkrétního počátečního a koncového data.

Poznámka: Při tisku sestav, které používají parametr rozsahu, jsou uživatelé vyzváni k zadání rozsahu při zobrazení sestavy a po klepnutí na tlačítko Print (Tisk).

Chcete-li přidat parametr Date Range (Rozsah dat), postupujte následovně:
  1. Definujte parametr Data Range (Rozsah dat). Postupujte následujícím způsobem:
    1. V podokně Field Explorer (Průzkumník polí) klepněte pravým tlačítkem myši na položku Parameter Fields (Pole parametrů) a poté klepněte na příkaz New (Nový).
    2. Do pole Name (Název) zadejte Data Range (Rozsah dat).
    3. Do pole Prompting (Dotaz) zadejte dotaz, který chcete zobrazit. Zadejte například:
      Zahrnout případy vytvořené v období
    4. Klepněte na možnost Range Value(s) (Hodnoty rozsahu) a poté na tlačítko OK.
    Chcete-li, aby parametr Data Range (Rozsah dat) fungoval, je třeba jej zahrnout do sestavy. Parametr můžete z podokna Field Explorer (Průzkumník polí) přetáhnout do libovolného umístění v sestavě.
  2. Chcete-li v záhlaví sestavy zobrazit počáteční a koncové datum rozsahu, musíte vytvořit dvě nová pole vzorce: StartDate (Počáteční datum) a EndDate (Koncové datum). Postupujte následujícím způsobem:
    1. V podokně Field Explorer (Průzkumník polí) klepněte pravým tlačítkem myši na položku Formula Fields (Pole vzorců) a poté klepněte na příkaz New (Nový).
    2. V poli Name (Název) zadejte StartDate (Počáteční datum) a poté klepněte na tlačítko Use Editor (Použít editor).
    3. Do pole Formula (Vzorec) zadejte:
      Minimum ({?Date Range})
    4. Klepněte na tlačítko Save (Uložit) a potom na tlačítko Close (Zavřít).
    5. V podokně Field Explorer (Průzkumník polí) klepněte pravým tlačítkem myši na položku Formula Fields (Pole vzorců) a poté klepněte na příkaz New (Nový).
    6. V poli Name (Název) zadejte EndDate (Koncové datum) a poté klepněte na tlačítko Use Editor (Použít editor).
    7. Do pole Formula (Vzorec) zadejte:
      Maximum ({?Date Range})
      .
    8. Klepněte na tlačítko Save (Uložit) a potom klepněte na tlačítko Close (Zavřít).
  3. Použijte parametry StartDate (Počáteční datum) a EndDate (Koncové datum) v záhlaví sestavy. Postupujte následujícím způsobem:
    1. Přetáhněte parametry StartDate (Počáteční datum) a EndDate (Koncové datum) z části Formula Fields (Pole vzorců) podokna Field Explorer (Průzkumník polí) do textového objektu v části Page Header (Záhlaví stránky).
    2. Přidejte oddělovací text nebo mezery, aby byla pole oddělena a bylo možné je identifikovat.
    V kroku 4 je vytvořen vzorec pro výběr záznamů, který kontroluje hodnotu parametru Date Range (Rozsah dat) vybranou uživatelem. Klepne-li uživatel na možnost All (Vše), jsou zahrnuty všechny aktivity. Jinak jsou zahrnuty pouze záznamy, u kterých se hodnota pole v aplikaci Microsoft CRM shoduje s uživatelem vybraným parametrem.

    Není-li vytvářená sestava založena na entitě Incident (Oznámení), nahraďte text incident.createdon textem entita.createdon.
  4. Přidejte parametr Date Range (Rozsah dat) do vzorce pro výběr záznamů. Postupujte následujícím způsobem:
    1. V nabídce Report (Sestava) klepněte na příkaz Selection Formulas (Vzorce pro výběr) a poté klepněte na možnost Record (Záznam).
    2. Maximalizujte okno.
    3. Není-li v pravém dolním podokně nic uvedeno, zadejte v prvním řádku následující vzorec bez operátoru and. Obsahuje-li již toto podokno kód, přidejte všechny tři řádky včetně operátoru and na konec seznamu.
      and
      (if {incident.createdon} in {?Date Range} then true
      else false)
      Ve druhém řádku použijte datové pole, které chcete s rozsahem dat porovnávat. V závislosti na entitě může být někdy vhodné použít místo pole createdon pole modifiedon. Použít lze pouze data, která existují v některé z entit zahrnutých v sestavě.
    4. Klepněte na tlačítko Save (Uložit) a potom klepněte na tlačítko Close (Zavřít).
    Při spuštění sestavy se zobrazí dotaz na parametr Date Range (Rozsah dat) se zadaným textem dotazu. Po vybrání počátečního a koncového data rozsahu a klepnutí na tlačítko OK se zobrazí data sestavy.
Filtry sestav se sestavami řízenými parametry
Používáte-li se sestavami řízenými parametry filtry sestav, je třeba parametry vybrat dvakrát. Nejdříve uživatel sestavu řízenou parametry spustí a zadá parametry. Poté klepne na ikonu na pravém okraji panelu nástrojů Report Filtering (Filtrování sestavy) a spustí filtrování sestavy. Zadá filtry, klepne na položku Filter (Filtr), po výzvě zadá parametry znovu a poté klepne na tlačítko OK.

Odkazy

Chcete-li stáhnout přehled nejčastějších dotazů týkajících se sestav aplikace Microsoft CRM, navštivte následující web společnosti Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyID=81886de8-a10a-473f-8125-49291e0f03d9
Další informace o tom, jak pomocí nástroje Microsoft CRM 1.2 Report Manager upravovat sestavy, naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
834791 Použití nástroje Microsoft CRM 1.2 Report Manager k úpravám sestav (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
Další informace o tisku sestav řízených parametry v aplikaci Microsoft CRM 1.2 naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
834913 Tisk sestav řízených parametry v aplikaci Microsoft CRM 1.2 (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Vlastnosti

ID článku: 834790 - Poslední aktualizace: 22. listopadu 2006 - Revize: 5.4
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft CRM 1.2
Klíčová slova: 
kbmbsreports kbmbsmigrate kbfile kbhowto KB834790
Právní omezení pro obsah znalostní báze týkající se produktů, jejichž podpora byla ukončena
Tento článek byl napsán o produktech, pro které společnost Microsoft již neposkytuje nadále podporu. Článek je tedy nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com