Utilizzo di Crystal Reports 9 per scrivere report basati su parametri per Microsoft CRM 1.2

Traduzione articoli Traduzione articoli
Identificativo articolo: 834790 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

Sono disponibili per il download tre report di esempio che descrivono come utilizzare le versioni Professional, Developer e Advanced di Crystal Reports 9 per scrivere report basati su parametri per Microsoft Business Solutions CRM versione 1.2. Per migliorare le prestazioni dei report, i parametri consentono di limitare la quantitÓ di dati inclusi nel report. Di conseguenza i report basati su parametri consentono di ottenere report che includono solo i dati necessari.

Informazioni

Download dei report di esempio basati su parametri

Per scaricare i report di esempio, visitare il sito Area download Microsoft (informazioni in lingua inglese):
http://www.microsoft.com/downloads/details.aspx?FamilyID=1d08d05e-a8e1-46ef-a808-ac388be24a3e&DisplayLang=en
Per ulteriori informazioni sul download di file di supporto Microsoft, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
119591 Come ottenere file di supporto Microsoft dai servizi online
Il file Ŕ stato controllato e non contiene virus. Microsoft ha utilizzato il software antivirus pi¨ recente disponibile al momento della data di pubblicazione del file. Il file viene salvato su server con un livello di protezione avanzata che impedisce modifiche non autorizzate.

Informazioni sull'installazione

Seguire le istruzioni riportate nella pagina di download.

Informazioni sulla rimozione

Per rimuovere i file di esempio, eliminarli.

Richiesta di riavvio

Dopo l'installazione dei report di esempio non Ŕ necessario riavviare il computer.

Informazioni sui file

La versione in lingua inglese dei report di esempio presenta gli attributi elencati nella tabella seguente. Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sui file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data        Ora    Dimensione  Nome file 
   ---------------------------------------------------------------------------------------------- 
   20/01/2004  09.54      65.024  Account Activity And Notes (specify status, owner, date).rpt
   20/01/2004  09.57      64.000  Case List (specify owner, status, date).rpt
   20/01/2004  10.19     103.936  Opportunity List By Account (specify owner, date, accounts).rpt

Aggiungere i report di esempio a Microsoft CRM

Per visualizzare un report in Microsoft CRM, Ŕ necessario salvarlo nelle cartelle dei report esistenti di Microsoft CRM.

Crystal Reports 9

Per utilizzare Crystal Reports 9 per salvare il report in Microsoft CRM, attenersi alla seguente procedura:
  1. Installare i tre report di esempio scaricati dall'Area download Microsoft come indicato nella sezione Informazioni.
  2. Aprire ciascun file in Crystal Reports 9:
    1. Scegliere Salva con nome dal menu File.
    2. Fare clic su Enterprise.
    3. Digitare le informazioni sull'account e scegliere OK.
    4. Espandere MSCRM1.2.
    5. Espandere il nodo Admin Reports, Sales Reports, or Service reports.
    6. Fare clic sulla sottocartella in cui si desidera collocare il report.
    7. Specificare il nome del file e scegliere OK.

Microsoft CRM 1.2 Report Manager

Per ulteriori informazioni sul download di Microsoft CRM 1.2 Report Manager, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
834791 Aggiunta, eliminazione e ridenominazione dei report di Microsoft CRM tramite Microsoft CRM 1.2 Report Manager
Per salvare il report nelle cartelle dei report esistenti di Microsoft CRM, attenersi alla seguente procedura:
  1. Installare i tre report di esempio.
  2. Avviare Microsoft CRM 1.2 Report Manager.
  3. Per ciascun file attenersi alla seguente procedura:
    1. Individuare la cartella in cui si desidera salvare il file.
    2. Scegliere Add Report.
    3. Specificare il nome del file e il report scaricato e fare clic su Add Report.

ModalitÓ di utilizzo di Crystal Reports 9 per aggiungere parametri a un report Microsoft CRM

Introduzione

Per utilizzare Crystal Reports 9 per aggiungere un parametro a un report Microsoft CRM, Ŕ necessario attenersi alla seguente procedura. Nelle sezioni seguenti di questo articolo vengono fornite indicazioni precise per ciascun passaggio.
  1. Definire il parametro. Per effettuare questa operazione, specificare il nome del parametro, il testo che verrÓ visualizzato dall'utente, gli elementi delle caselle di riepilogo a discesa e il valore predefinito.
  2. Collocare tutti i campi dei parametri nel report. I campi possono essere visibili o nascosti.
  3. Aggiungere codice alla formula di selezione dei record che consente di confrontare i dati immessi dall'utente nel parametro con i dati di Microsoft CRM.
  4. Salvare il report e verificare il parametro aggiunto.
╚ possibile utilizzare Crystal Reports per aggiungere molti tipi di parametri. Questo articolo fornisce solo quattro esempi, ciascuno dei quali esamina un aspetto diverso dell'utilizzo dei parametri con i dati di Microsoft CRM. Nel presente articolo sono inclusi i seguenti esempi:
  • Un parametro Proprietario che consente all'utente di selezionare solo i record in suo possesso o tutti i record. Questo esempio spiega come utilizzare il parametro speciale IDUtente per determinare il GUID di Microsoft CRM dell'utente che esegue il report.
  • Un parametro Stato che consente all'utente di selezionare tra tutti i valori relativi allo stato disponibili per l'entitÓ in Microsoft CRM. Questo esempio spiega come leggere l'elenco di valori disponibili in un campo in Microsoft CRM da utilizzare nelle scelte dei parametri.
  • Un parametro Data creazione che consente all'utente di scegliere tra intervalli di date predefiniti, quali tutti, negli ultimi 60 giorni o nell'ultimo anno. Questo esempio spiega come utilizzare i metodi standard relativi alle date in Crystal Reports 9.
  • Un parametro Intervallo di date che consente all'utente di specificare le date di inizio e di fine per l'intervallo. Questo esempio spiega come utilizzare un parametro relativo all'intervallo e come creare ulteriori campi formula basati su un campo parametro. In questo caso il parametro Intervallo di date Ŕ un intervallo e vengono create due nuove variabili, DataInizio e DataFine, da utilizzare nell'intestazione della pagina del report.

Operazioni preliminari

Funzionamento di Crystal Reports con Microsoft CRM 1.2
Prima di creare report con parametri, assicurarsi di comprendere il funzionamento di Crystal Reports con Microsoft CRM 1.2:
  • Solo i report del nodo Enterprise/MSCRM1.2 sono disponibili per gli utenti di Microsoft CRM.
  • Non Ŕ possibile creare nuove cartelle nel nodo MSCRM1.2.
  • Non Ŕ possibile utilizzare Crystal Reports per rinominare direttamente un report. Per eliminare un report, Ŕ necessario utilizzare Microsoft CRM 1.2 Report Manager.

    Per ulteriori informazioni su Report Manager, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
    834791 Aggiunta, eliminazione e ridenominazione dei report di Microsoft CRM tramite Microsoft CRM 1.2 Report Manager
  • Non Ŕ possibile utilizzare Crystal Reports per rinominare direttamente un report. Utilizzare Microsoft CRM 1.2 Report Manager o Crystal Reports per salvare un report con un nuovo nome. Questi metodi di ridenominazione dei report consentono di cambiare il nome in Microsoft CRM, ma non il titolo visualizzato nella sezione Intestazione pagina del report. Per modificare il titolo, scegliere Informazioni di riepilogo dal menu File di Crystal Reports 9 e modificare il titolo nella casella Titolo report.
  • Per informazioni sulla creazione dei parametri, consultare la Guida in linea di Crystal Reports 9.
Creare un report basato sui parametri
Il modo pi¨ semplice di creare un report basato su parametri Ŕ quello di salvare un report esistente di Microsoft CRM versione 1.2 con un nuovo nome e di modificare la copia:
  1. Dal menu Start scegliere Programmi, quindi fare clic su Crystal Reports 9.
  2. Nella schermata Benvenuti in Crystal Reports scegliere Annulla.
  3. Scegliere Apri dal menu File.
  4. Fare clic su Enterprise, quindi scegliere OK.
  5. Digitare le informazioni di autenticazione per l'APS di Crystal e scegliere OK.
  6. Espandere MSCRM1.2, fare clic sul report che si desidera modificare, quindi scegliere Apri.
  7. Scegliere Salva con nome dal menu File, individuare il percorso in cui si desidera salvare il file in corrispondenza del nodo MSCRM1.2, specificare il nome e scegliere OK.
Se Ŕ la prima volta che si utilizza Crystal Reports 9 per modificare i report di Microsoft CRM, si verificano problemi di connessione o non Ŕ possibile salvare i report, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
834789 Domande frequenti sui report di Microsoft Business Solutions CRM 1.2

Aggiungere un parametro Proprietario

Con un parametro Proprietario l'utente pu˛ selezionare i record di cui Ŕ proprietario o tutti i record. Di conseguenza l'utente non deve effettuare una selezione da una casella di riepilogo a discesa che contiene tutti gli utenti.

Per distinguere i record di cui Ŕ proprietario l'utente che esegue il report, tale report deve essere in grado di identificare il GUID di Microsoft CRM dell'utente. Se l'autore del report crea un parametro IDUtente, in Microsoft CRM a tale parametro viene automaticamente assegnato come valore il GUID di Microsoft CRM della persona che esegue il report. A differenza degli altri parametri l'utente non deve digitare alcun valore.

Creare un parametro Proprietario che contenga i valori "Miei" o "Tutti". Quando l'utente esegue il report e fa clic su Miei, se il parametro IDUtente corrisponde alla casella entitÓ.owner, risulteranno selezionati i record in possesso dell'utente. Se l'utente fa clic su Tutti, verranno inclusi tutti i record.

L'esempio riportato di seguito utilizza un report basato sull'entitÓ Account.
Passaggio 1: definire il parametro IDUtente per memorizzare il GUID di Microsoft CRM dell'utente corrente
Per definire il parametro IDUtente per memorizzare il GUID di Microsoft CRM dell'utente corrente, attenersi alla seguente procedura:
  1. Nel riquadro Explorer Campo in Crystal Reports 9 fare clic con il pulsante destro del mouse su Campi di parametro e scegliere Nuovo.
  2. Nella casella Nome digitare IDUtente, quindi scegliere OK.
Passaggio 2: definire il parametro Proprietario
Per definire un parametro Proprietario che richieda all'utente di fare clic su Miei o su Tutti, attenersi alla seguente procedura:
  1. Nel riquadro Explorer Campo fare clic con il pulsante destro del mouse su Campi di parametro e scegliere Nuovo.
  2. Nella casella Nome digitare Proprietario.
  3. Nella casella Testo prompt digitare il prompt che verrÓ visualizzato dall'utente. Digitare ad esempio:
    Specificare i record da includere
  4. Fare clic su Imposta Valori Predefiniti.
  5. Digitare i valori desiderati nella casella di riepilogo a discesa. Questo esempio utilizza i valori "Miei" e "Tutti". Utilizzare il pulsante > per spostare ogni valore nella casella Valori predefiniti.
  6. Per ciascun valore fare clic su Definisci Descrizione e digitare il testo che si desidera visualizzare nella casella di riepilogo a discesa per il parametro Proprietario.
  7. Nella casella di riepilogo a discesa Visualizza fare clic su Descrizione, quindi scegliere OK.
  8. Nella finestra di dialogo Crea campo parametro deselezionare la casella di controllo Consenti modifica dei valori predefiniti se sono presenti pi¨ valori.
  9. Scegliere OK per salvare il nuovo parametro.
PerchÚ il parametro Proprietario funzioni, Ŕ necessario includerlo nel report. Per effettuare questa operazione, trascinare il parametro dal riquadro Explorer Campo a un punto qualsiasi del report. ╚ consigliabile aggiungere i nuovi parametri alla sezione Intestazione pagina del report. Se i parametri sono tutti elencati nella sezione Intestazione pagina, un utente pu˛ rapidamente determinare quali dati sono inclusi nel report. Se non si desidera che il valore del parametro Proprietario venga visualizzato nel report, trascinarlo in un'area nascosta del report.
Passaggio 3: utilizzare il parametro Proprietario nell'intestazione della pagina
  1. Dato che Proprietario Ŕ il primo parametro aggiunto all'intestazione della pagina, Ŕ necessario creare una casella di testo che contenga la casella Titolo report esistente. A questo scopo, attenersi alla seguente procedura:
    1. Fare clic con il pulsante destro del mouse sulla casella Titolo report e scegliere Elimina.
    2. Scegliere Oggetto di testo dal menu Inserisci e collocare il nuovo oggetto di testo dove si trovava il campo Titolo report.
    3. Nel riquadro Explorer Campo espandere Campi speciali.
    4. Trascinare la casella speciale Titolo report nel nuovo oggetto di testo.
  2. Trascinare il parametro Proprietario dalla sezione Campi di parametri del riquadro Explorer Campo al nuovo oggetto di testo.
  3. Aggiungere il testo di separazione o gli spazi per separare il titolo dal parametro Proprietario.
  4. Per fare in modo che il carattere corrisponda a quello degli altri report di Microsoft CRM, fare clic con il pulsante destro del mouse sul nuovo oggetto di testo, scegliere Formatta testo e, nella scheda Carattere fare clic su Verdana, su Grassetto, su Giallo e infine scegliere OK.
Passaggio 4: Aggiungere il parametro Proprietario alla formula di selezione dei record
Formula di selezione dei record

La formula di selezione dei record definisce quali record sono inclusi nel report. La formula segue la struttura indicata:
  (if {?Parametro1} = "Parametro1_Opzione1" and {table.field} = "valore1" then true
    else if {?Parametro1} = "Parametro1_Opzione2" and {table.field} = "valore2" then true)
Per ulteriori informazioni sulle formule di selezione dei record, compresi i modelli per tipi di parametri diversi, vedere l'argomento relativo nella Guida in linea di Crystal Reports 9.

Nella procedura riportata di seguito viene creata una formula di selezione dei record che consente di verificare il valore del parametro Proprietario selezionato dall'utente. Se l'utente fa clic su Miei, vengono inclusi nel report solo gli account in possesso dell'utente corrente.

Se il report che viene modificato non si basa sull'entitÓ Account, sostituire account.ownerid con entitÓ.ownerid.

Aggiungere il parametro Proprietario alla formula di selezione dei record

Per aggiungere il parametro Proprietario alla formula di selezione dei record, attenersi alla seguente procedura:
  1. Scegliere Formule di selezione dal menu Report e fare clic su Record.
  2. Ingrandire la finestra.
  3. Se nel riquadro inferiore destro non Ŕ presente nulla, digitare la formula riportata di seguito senza "and" nella prima riga. Se il codice Ŕ giÓ presente, aggiungere le tre righe includendo "and" alla fine del listato di codice.
    and
    (if {?Owner} = "Mine" then {account.ownerid} = {?UserID} 
          else true)
    Quando il report viene eseguito, il prompt Proprietario viene visualizzato con il testo specificato. Quando l'utente sceglie OK, vengono visualizzati i dati del report.
  4. Fare clic su Salva, quindi su Chiudi.

Aggiungere un parametro Stato

In questa sezione viene descritto come aggiungere un parametro Stato in base al valore della casella entitÓ.statecode in Microsoft CRM. Le opzioni fornite agli utenti si basano sui valori di questa casella in Microsoft CRM. Questo esempio utilizza l'entitÓ Impegno.
Passaggio 1: Definire il parametro Stato
Per definire il parametro Stato, attenersi alla seguente procedura:
  1. Nel riquadro Explorer Campo fare clic con il pulsante destro del mouse su Campi di parametro e scegliere Nuovo.
  2. Nella casella Nome digitare Stato.
  3. Nella casella Testo prompt digitare il prompt che verrÓ visualizzato. Digitare ad esempio:
    Includere gli impegni con lo stato di
  4. Fare clic su Imposta Valori Predefiniti.
  5. Nella casella Sfoglia tabella fare clic sul nome della tabella che contiene la casella dello stato. Questo esempio utilizza l'entitÓ Impegno. Di conseguenza fare clic su impegno.
  6. Nella casella Sfoglia campo scegliere statecodename.
  7. Nella schermata Informazioni di connessione deselezionare la casella di controllo Connetti al computer locale.
  8. Caricare un elenco di tutti i valori correnti in Microsoft CRM. Per effettuare questa operazione, nella casella Server sostituire il nome del computer in uso con il nome del server Microsoft CRM. Se ad esempio in questa casella Ŕ riportato http://computer/MSCRMServices, sostituire il nome con http://ServerCRM/MSCRMServices, quindi fare clic su Fine.

    Nota In Crystal Reports 9 vengono letti tutti i valori della casella entitÓ.statecode utilizzati nei dati correnti di Microsoft CRM. Questi valori potrebbero non rappresentare tutti i valori che possono essere visualizzati in questa casella di Microsoft CRM. Per un elenco completo di valori predefiniti per le caselle di riepilogo a discesa, vedere l'Appendice A della Guida all'implementazione di Microsoft Business Solutions CRM. Se Ŕ stata modificata una casella di riepilogo a discesa, visualizzare la casella in Microsoft CRM per assicurarsi di includere tutti i valori nel parametro.
  9. Fare clic su ciascun valore che si desidera inserire nella casella di riepilogo a discesa, quindi fare clic sul pulsante > per spostare ogni valore nella casella Valori predefiniti.
  10. Per ciascun valore fare clic su Definisci Descrizione e digitare il testo che si desidera visualizzare nella casella di riepilogo a discesa per il parametro Proprietario.
  11. Ordinare i valori per fare in modo che l'opzione che deve essere il valore predefinito sia in prima posizione nella casella.
  12. Nella casella di riepilogo a discesa Visualizza fare clic su Descrizione, quindi scegliere OK.
  13. Nella finestra di dialogo Crea campo parametro deselezionare la casella di controllo Consenti modifica dei valori predefiniti se sono presenti pi¨ valori.
  14. Scegliere OK per salvare il nuovo parametro.
PerchÚ il parametro Stato funzioni, Ŕ necessario includerlo nel report. Per effettuare questa operazione, trascinare il parametro dal riquadro Explorer Campo a un punto qualsiasi del report. La procedura riportata di seguito (Passaggio 2) presuppone che sia giÓ stata creata una casella di testo nell'intestazione del report che contenga la casella Titolo report e il parametro Proprietario.
Passaggio 2: utilizzare il parametro Stato nell'intestazione della pagina
Per utilizzare il parametro Stato nell'intestazione della pagina, attenersi alla seguente procedura:
  1. Trascinare il parametro Stato dalla sezione Campi di parametri del riquadro Explorer Campo all'oggetto di testo della sezione Intestazione pagina.
  2. Aggiungere il testo di separazione o gli spazi per separare il parametro Stato dal parametro Proprietario.
Nella procedura riportata di seguito (Passaggio 3) viene creata una formula di selezione dei record che consente di verificare il valore del parametro Stato selezionato dall'utente. Se l'utente fa clic su Tutti, verranno inclusi tutti gli impegni. In caso contrario verranno inclusi solo i record in cui il valore del campo di Microsoft CRM corrisponde al parametro selezionato dall'utente.

Se il report che viene modificato non si basa sull'entitÓ Impegno, sostituire activity.statecodename con entitÓ.statecodename.
Passaggio 3: Aggiungere il parametro Stato alla formula di selezione dei record
Per aggiungere il parametro Stato alla formula di selezione dei record, attenersi alla seguente procedura:
  1. Scegliere Formule di selezione dal menu Report e fare clic su Record.
  2. Ingrandire la finestra.
  3. Se nel riquadro inferiore destro non Ŕ presente nulla, digitare la formula riportata di seguito senza "and" nella prima riga. Se il codice Ŕ giÓ presente, aggiungere le tre righe alla fine del listato di codice.
    and
         (if {?Status} = "All" then true 
         else {activity.statecodename}={?Status})
  4. Fare clic su Salva, quindi su Chiudi.
Quando l'utente esegue il report, il prompt Stato viene visualizzato con il testo specificato. Quando l'utente sceglie OK, vengono visualizzati i dati del report.

Aggiungere i parametri data

Questa sezione descrive come utilizzare un parametro per fare in modo che l'utente specifichi un intervallo di date. Tale intervallo deve essere basato sui valori di una o pi¨ caselle relative alle date di Microsoft CRM. Ciascuna entitÓ dispone di una casella entitÓ.createdon e di una casella entitÓ.modifiedon. Alcune entitÓ dispongono di altre caselle relative alle date. Ad esempio Impegno dispone di date basate sull'ora pianificata e su quella corrente.

╚ possibile creare un parametro che richieda all'utente di fare clic sugli elementi di una casella di riepilogo a discesa che contiene intervalli di date predefiniti come negli ultimi 60 giorni e nell'ultimo anno o di specificare date di inizio e di fine.

I due esempi riportati di seguito utilizzano l'entitÓ Caso.
Aggiungere un parametro Data creazione
Il parametro Data creazione richiede all'utente di scegliere tra un elenco di intervalli di date predefiniti specifici. Per aggiungere un parametro Data creazione, attenersi alla seguente procedura:
  1. Per definire il parametro Data creazione, attenersi alla seguente procedura:
    1. Nel riquadro Explorer Campo fare clic con il pulsante destro del mouse su Campi di parametro e scegliere Nuovo.
    2. Nella casella Nome digitare Data creazione.
    3. Nella casella Testo prompt digitare il prompt che verrÓ visualizzato. Digitare ad esempio:
      Specificare i record creati:
    4. Fare clic su Imposta Valori Predefiniti.
    5. Digitare i valori desiderati nella casella di riepilogo a discesa. Questo esempio utilizza i valori "Negli ultimi 60 giorni", "Nell'ultimo anno" e "Tutti". Utilizzare il pulsante > per spostare ogni valore nella casella Valori predefiniti.
    6. Per ciascun valore fare clic su Definisci Descrizione e digitare il testo che si desidera visualizzare nella casella di riepilogo a discesa per il parametro Data creazione.
    7. Nella casella di riepilogo a discesa Visualizza fare clic su Descrizione, quindi scegliere OK.
    8. Nella finestra di dialogo Crea campo parametro deselezionare la casella di controllo Consenti modifica dei valori predefiniti se sono presenti pi¨ valori.
    9. Scegliere OK per salvare il nuovo parametro.
  2. Per utilizzare il parametro Data creazione nell'intestazione della pagina, attenersi alla seguente procedura:
    1. Trascinare il parametro Data creazione dalla sezione Campi di parametri del riquadro Explorer Campo all'oggetto di testo della sezione Intestazione pagina.
    2. Aggiungere il testo di separazione o gli spazi per separare il parametro Data creazione dal parametro Stato.
  3. Se il report in fase di creazione non si basa sull'entitÓ Caso, sostituire caso.createdon con entitÓ.createdon.

    Nel passaggio 4 viene creata una formula di selezione dei record che consente di verificare il valore del parametro Data creazione selezionato dall'utente. Se l'utente fa clic su Tutti, verranno inclusi tutti i record. In caso contrario verranno visualizzati solo i record che corrispondono ai criteri definiti nella formula di selezione dei record. Il codice della formula di selezione utilizza tra metodi predefiniti relativi alle date di Crystal Reports, Aged0To30Days, Aged31To60Days e YearToDate.
  4. Aggiungere il parametro Data creazione alla formula di selezione dei record. A questo scopo, attenersi alla seguente procedura:
    1. Scegliere Formule di selezione dal menu Report e fare clic su Record.
    2. Ingrandire la finestra.
    3. Se nel riquadro inferiore destro non Ŕ presente nulla, digitare la formula riportata di seguito senza "and" nella prima riga. Se il codice Ŕ giÓ presente, aggiungere tutte le righe alla fine del listato di codice.
      and
      (if {?Date Created}="Within Past 60 Days" and   {incident.createdon} in Aged0To30Days or {incident.createdon} in Aged31To60Days then true
      else if {?Date Created}="Year To Date" and {incident.createdon}in YearToDate then true
      )
    4. Fare clic su Salva, quindi su Chiudi.
    Quando l'utente esegue il report, il prompt Data creazione viene visualizzato con il testo specificato. Quando l'utente sceglie OK, vengono visualizzati i dati del report.
Aggiungere un parametro Intervallo di date
Il parametro Intervallo di date richiede che l'utente scelga date di inizio e di fine specifiche.

Nota Quando gli utenti stampano i report che utilizzano un parametro relativo all'intervallo, viene loro richiesto l'intervallo al momento della visualizzazione del report e dopo avere fatto clic su Stampa.

Per aggiungere un parametro Intervallo di date, attenersi alla seguente procedura:
  1. Definire il parametro Intervallo di date. A questo scopo, attenersi alla seguente procedura:
    1. Nel riquadro Explorer Campo fare clic con il pulsante destro del mouse su Campi di parametro e scegliere Nuovo.
    2. Nella casella Nome digitare Intervallo di date.
    3. Nella casella Testo prompt digitare il prompt che verrÓ visualizzato. Digitare ad esempio:
      Includere i casi creati tra
    4. Fare clic su Valore/i intervallo, quindi scegliere OK.
    PerchÚ il parametro Intervallo di date funzioni, Ŕ necessario includerlo nel report. ╚ possibile trascinare il parametro dal riquadro Explorer Campo a un punto qualsiasi del report.
  2. Se si desidera visualizzare le date di inizio e di fine nell'intestazione del report, Ŕ necessario creare due nuovi campi formula, DataInizio e DataFine. A questo scopo, attenersi alla seguente procedura:
    1. Nel riquadro Explorer Campo fare clic con il pulsante destro del mouse su Campi formula e scegliere Nuovo.
    2. Nella casella Nome digitare DataInizio e fare clic su Utilizza Editor.
    3. Nella casella Formula digitare:
      Minimum ({?Date Range})
    4. Fare clic su Salva, quindi su Chiudi.
    5. Nel riquadro Explorer Campo fare clic con il pulsante destro del mouse su Campi formula e scegliere Nuovo.
    6. Nella casella Nome digitare DataFine e fare clic su Utilizza Editor.
    7. Nella casella Formula digitare:
      Maximum ({?Date Range})
    8. Fare clic su Salva, quindi su Chiudi.
  3. Utilizzare DataInizio e DataFine nell'intestazione del report. A questo scopo, attenersi alla seguente procedura:
    1. Trascinare i parametri DataInizio e DataFine dalla sezione Campi formula del riquadro Explorer Campo all'oggetto di testo della sezione Intestazione pagina.
    2. Aggiungere il testo di separazione o gli spazi per separare e identificare i campi.
    Nel passaggio 4 viene creata una formula di selezione dei record che consente di verificare il valore del parametro Intervallo di date selezionato dall'utente. Se l'utente fa clic su Tutti, verranno inclusi tutti gli impegni. In caso contrario verranno inclusi solo i record in cui il valore della casella di Microsoft CRM corrisponde al parametro selezionato dall'utente.

    Se il report in fase di creazione non si basa sull'entitÓ Caso, sostituire caso.createdon con entitÓ.createdon.
  4. Aggiungere il parametro Intervallo di date alla formula di selezione dei record. A questo scopo, attenersi alla seguente procedura:
    1. Scegliere Formule di selezione dal menu Report e fare clic su Record.
    2. Ingrandire la finestra.
    3. Se nel riquadro inferiore destro non Ŕ presente nulla, digitare la formula riportata di seguito senza "and" nella prima riga. Se il codice Ŕ giÓ presente, aggiungere le tre righe alla fine del listato di codice.
      and
      (if {incident.createdon} in {?Date Range} then true
      else false)
      Nella seconda riga utilizzare il campo data che si desidera confrontare con l'intervallo di date. In base all'entitÓ potrebbe essere consigliabile utilizzare la casella modifiedon invece della casella createdon. Si possono utilizzare solo le date esistenti in una delle entitÓ incluse nel report.
    4. Fare clic su Salva, quindi su Chiudi.
    Quando gli utenti eseguono il report, il prompt Intervallo di date viene visualizzato con il testo specificato. Quando l'utente seleziona le date di inizio e di fine per l'intervallo e sceglie OK, vengono visualizzati i dati del report.
Filtri dei report con report basati su parametri
Se si utilizzano i filtri dei report con report basati su parametri, Ŕ necessario selezionare i parametri due volte. Innanzitutto gli utenti eseguono il report basato su parametri e specificano i parametri. Successivamente fanno clic sull'icona all'estremitÓ destra della barra degli strumenti Filtro report per aprire i filtri dei report, immettono i filtri, fanno clic su Filtro, digitano di nuovo i parametri quando viene loro richiesto e scelgono OK.

Riferimenti

Per scaricare un elenco di domande frequenti sui report di Microsoft CRM, visitare il seguente sito Web Microsoft (informazioni in lingua inglese):
http://www.microsoft.com/downloads/details.aspx?FamilyID=81886de8-a10a-473f-8125-49291e0f03d9
Per ulteriori informazioni sull'utilizzo di Microsoft CRM 1.2 Report Manager per modificare i report, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
834791 Aggiunta, eliminazione e ridenominazione dei report di Microsoft CRM tramite Microsoft CRM 1.2 Report Manager
Per ulteriori informazioni sulla stampa di report basati su parametri in Microsoft CRM 1.2, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
834913 Quando si stampa un report basato su parametri in Microsoft Business Solutions CRM versione 1.2, Ŕ necessario immettere i parametri due volte

ProprietÓ

Identificativo articolo: 834790 - Ultima modifica: lunedý 23 aprile 2007 - Revisione: 6.1
Le informazioni in questo articolo si applicano a
  • Microsoft CRM 1.2
Chiavi:á
kbmbsreports kbmbsmigrate kbfile kbhowto KB834790
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com