Jak używać programu Crystal Reports 9 do zapisywania raportów z parametrami dla programu Microsoft CRM w wersji 1.2

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 834790 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Streszczenie

Trzy przykładowe raporty, opisujące sposób użycia wersji Professional, Developer lub Advanced programu Crystal Reports 9 do zapisywania raportów z parametrami dla programu Microsoft Business Solutions CRM w wersji 1.2, są dostępne do pobrania. Aby ulepszyć raporty, parametry ograniczają ilość danych uwzględnianych w raporcie. Raporty z parametrami ułatwiają zatem prezentację tylko potrzebnych danych.

Więcej informacji

Pobieranie przykładowych raportów z parametrami

Aby pobrać przykładowe raporty, odwiedź następującą witrynę w sieci Web — Centrum pobierania firmy Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyID=1d08d05e-a8e1-46ef-a808-ac388be24a3e&DisplayLang=pl
Aby uzyskać dodatkowe informacje dotyczące sposobu pobierania plików Pomocy technicznej firmy Microsoft, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
119591 Jak uzyskać pliki Pomocy technicznej Microsoft w usługach online
Firma Microsoft przeskanowała ten plik w poszukiwaniu wirusów. Firma Microsoft użyła najnowszego oprogramowania do wykrywania wirusów dostępnego w dniu opublikowania pliku. Plik jest przechowywany na serwerach o podwyższonym stopniu bezpieczeństwa, co uniemożliwia nieautoryzowane zmiany w pliku.

Informacje o instalacji

Postępuj zgodnie z instrukcjami wyświetlanymi na stronie pobierania.

Informacje o usuwaniu

Aby pozbyć się przykładowych plików, należy je usunąć.

Wymagania dotyczące ponownego uruchomienia

Ponowne uruchamianie komputera po zainstalowaniu przykładowych raportów nie jest konieczne.

Informacje o pliku

Wersja angielskojęzyczna tych plików przykładowych raportów ma atrybuty plików wyświetlone w poniższej tabeli. Daty i godziny ostatniej modyfikacji plików podano zgodnie z czasem UTC (Coordinated Universal Time). Są one zamieniane na czas lokalny po wyświetleniu informacji o pliku. Aby zobaczyć różnicę między czasem UTC a czasem lokalnym, należy skorzystać z karty Strefa czasowa w aplecie Data i godzina w Panelu sterowania.
   Data     Godzina Rozmiar Nazwa pliku 
------------------------------------------------------------------------------------------- 
20-sty-2004  09:54  65 024  Account Activity And Notes (specify status, owner, date).rpt 
20-sty-2004  09:57  64 000  Case List (specify owner, status, date).rpt 
02-sty-2004  10:19  103 936 Opportunity List By Account (specify owner, date, accounts).rpt

Dodawanie przykładowych raportów do programu Microsoft CRM

Aby przeglądać raport w programie Microsoft CRM, należy zapisać raport w istniejących folderach raportów programu Microsoft CRM.

Program Crystal Reports 9

Aby użyć programu Crystal Reports 9 do zapisania raportu w programie Microsoft CRM, wykonaj następujące kroki:
  1. Zainstaluj trzy przykładowe raporty z witryny pobierania firmy Microsoft w sposób opisany w sekcji „Więcej informacji” powyżej.
  2. Otwórz każdy plik w programie Crystal Reports 9:
    1. W menu Plik kliknij polecenie Zapisz jako.
    2. Kliknij przycisk Przedsiębiorstwo.
    3. Wpisz informacje dotyczące konta, a następnie kliknij przycisk OK.
    4. Rozwiń węzeł MSCRM1.2.
    5. Rozwiń węzeł Raporty administracyjne, handlowe lub serwisowe.
    6. Kliknij podfolder, w którym chcesz umieścić raport.
    7. Określ nazwę pliku, a następnie kliknij przycisk OK.

Program Microsoft CRM 1.2 Report Manager

Aby uzyskać dodatkowe informacje dotyczące sposobu pobierania programu Microsoft CRM 1.2 Report Manager, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
834791 Adding, deleting, and renaming Microsoft CRM Reports by using Microsoft CRM 1.2 Report Manager
Aby zapisać raport w istniejących folderach raportów programu Microsoft CRM, wykonaj następujące kroki:
  1. Zainstaluj trzy przykładowe raporty.
  2. Otwórz program Microsoft CRM 1.2 Report Manager.
  3. Dla każdego pliku wykonaj następujące kroki:
    1. Zlokalizuj folder, w którym chcesz zapisać plik.
    2. Kliknij przycisk Dodaj raport.
    3. Określ nazwę pliku i pobrany raport, a następnie kliknij przycisk Dodaj raport.

Jak używać programu Crystal Reports 9 do dodawania parametrów do raportu programu Microsoft CRM

Wprowadzenie

Aby użyć programu Crystal Reports 9 do dodania parametru do raportu programu Microsoft CRM, wykonaj następujące kroki: W następnych sekcjach tego artykułu szczegółowo omówiono te kroki.
  1. Zdefiniuj parametr. Aby to zrobić, określ nazwę parametru, tekst, o który będzie monitowany użytkownik, elementy listy rozwijanej i wartość domyślną.
  2. Umieść wszystkie pola parametrów w raporcie. Pola mogą być widoczne lub ukryte.
  3. Dodaj do formuły wyboru rekordu kod porównujący dane wpisane przez użytkownika w parametrze z danymi z programu Microsoft CRM.
  4. Zapisz raport i przetestuj dodany parametr.
Korzystając z programu Crystal Reports, można dodać wiele parametrów różnego typu. W tym artykule przedstawiono tylko cztery przykłady. Każdy przykład ilustruje inny aspekt użycia parametrów z danymi programu Microsoft CRM. W tym artykule uwzględniono następujące przykłady:
  • Korzystając z parametru Owner (Właściciel), użytkownik może wybrać tylko należące do niego rekordy lub wszystkie rekordy. Ten przykład wyjaśnia sposób użycia specjalnego parametru UserID (Identyfikator użytkownika) do ustalania identyfikatora GUID programu Microsoft CRM dla użytkownika uruchamiającego raport.
  • Parametr Status umożliwia wybór jednej z wartości stanu dostępnych dla jednostki w programie Microsoft CRM. Ten przykład demonstruje sposób odczytywania z pola w programie Microsoft CRM listy dostępnych wartości w celu użycia ich jako wartości parametru.
  • Korzystając z parametru Date Created (Data utworzenia), użytkownik może wybrać jeden ze wstępnie zdefiniowanych zakresów dat: wszystkie w ciągu minionych 60 dni lub od początku roku do bieżącej daty. Ten przykład pokazuje sposób użycia standardowych metod określania dat w programie Crystal Reports 9.
  • Parametr Date Range (Zakres dat) umożliwia użytkownikowi określenie początkowej i końcowej daty zakresu. Ten przykład pokazuje sposób użycia parametru zakresu i tworzenia dodatkowych pól formuł na podstawie pola parametru. W tym przypadku parametr Date Range jest zakresem, a dwie nowe zmienne StartDate (Data rozpoczęcia) i EndDate (Data zakończenia) są tworzone w celu użycia w nagłówku strony raportu.

Zanim rozpoczniesz

Jak program Crystal Reports współpracuje z programem Microsoft CRM 1.2
Przed utworzeniem raportów parametrycznych należy zrozumieć sposób współpracy programu Crystal Reports z programem Microsoft CRM 1.2:
  • Tylko raporty w węźle Enterprise/MSCRM1.2 są dostępne dla użytkowników korzystających z programu Microsoft CRM.
  • Nie można tworzyć nowych folderów w węźle MSCRM1.2.
  • Nie można zmienić nazwy raportu bezpośrednio w programie Crystal Reports. Aby usunąć raport, należy użyć programu Microsoft CRM 1.2 Report Manager.

    Aby uzyskać dodatkowe informacje dotyczące programu Report Manager, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
    834791 Adding, Deleting, and Renaming Reports using Microsoft CRM 1.2 Report Manager
  • Nie można zmienić nazwy raportu bezpośrednio w programie Crystal Reports. Aby zapisać raport z nową nazwą, należy użyć programu Microsoft CRM 1.2 Report Manager lub Crystal Reports. Te metody zmiany nazw raportów powodują zmianę nazwy w programie Microsoft CRM, jednak tytuł widoczny w sekcji nagłówka strony raportu nie jest zmieniany. Aby zmienić tytuł, w menu Plik programu Crystal Reports 9 kliknij polecenie Podsumowanie, a następnie edytuj tytuł w polu Tytuł raportu.
  • Aby uzyskać pomoc w zakresie tworzenia parametrów, skorzystaj z Pomocy online programu Crystal Reports 9.
Tworzenie raportu z parametrami
Najprostszą metodą tworzenia raportu z parametrami jest zapisanie istniejącego raportu programu Microsoft CRM w wersji 1.2 z nową nazwą, a następnie modyfikowanie tej kopii:
  1. W menu Start wskaż polecenie Programy, a następnie kliknij polecenie Crystal Reports 9.
  2. Na stronie Crystal Reports — Zapraszamy kliknij przycisk Anuluj.
  3. W menu Plik kliknij polecenie Otwórz.
  4. Kliknij przycisk Przedsiębiorstwo, a następnie kliknij przycisk OK.
  5. Wpisz swoje informacje dotyczące uwierzytelnienia dla usługi Crystal APS, a następnie kliknij przycisk OK.
  6. Rozwiń węzeł MSCRM1.2, kliknij raport, który chcesz zmodyfikować, a następnie kliknij polecenie Otwórz.
  7. W menu Plik kliknij polecenie Zapisz jako, odszukaj lokalizację, w której chcesz zapisać plik w węźle MSCRM1.2, określ nazwę, a następnie kliknij przycisk OK.
Jeżeli po raz pierwszy używasz programu Crystal Reports 9 do modyfikacji raportów programu Microsoft CRM, występują problemy z połączeniem lub nie można zapisać raportów, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
834789 Często zadawane pytania dotyczące programu Microsoft Business Solutions CRM 1.2 Reports

Dodawanie parametru Owner

Korzystając z parametru Owner (Właściciel), użytkownik może wybrać tylko należące do niego rekordy lub wszystkie rekordy. Użytkownik nie musi zatem wybierać elementu z listy rozwijanej wszystkich użytkowników.

Aby rozróżnić rekordy należące do osoby uruchamiającej raport, musi być możliwe zidentyfikowanie identyfikatora GUID osoby uruchamiającej dany raport w programie Microsoft CRM. Jeżeli autor raportu utworzy parametr UserID (Identyfikator użytkownika), program Microsoft CRM automatycznie przypisuje jako jego wartość identyfikator GUID programu Microsoft CRM dla osoby uruchamiającej dany raport. W przeciwieństwie do innych parametrów użytkownik nie jest monitowany o wpisanie wartości.

Należy utworzyć parametr Owner przechowujący wartości „Mine” (Mój) lub „All” (Wszystkich). Jeżeli użytkownik uruchomi raport i kliknie wartość Mine, a parametr UserId jest zgodny z polem jednostka.owner, wybierane są rekordy należące do danego użytkownika. Jeżeli użytkownik kliknie element All, uwzględniane są wszystkie rekordy.

W następującym przykładzie wykorzystano raport oparty na jednostce Account (Konto).
Krok 1: Definiowanie parametru UserID w celu przechowywania identyfikatora GUID programu Microsoft CRM dla bieżącego użytkownika
Aby zdefiniować parametr UserID w celu przechowywania identyfikatora GUID programu Microsoft CRM dla bieżącego użytkownika, wykonaj następujące kroki:
  1. W okienku Eksplorator pól w programie Crystal Reports 9 kliknij prawym przyciskiem myszy pozycję Pola parametrów, a następnie kliknij polecenie Nowy.
  2. W polu Nazwa wpisz UserID, a następnie kliknij przycisk OK.
Krok 2: Definiowanie parametru Owner
Aby zdefiniować parametr Owner służący do monitowania użytkownika o kliknięcie wartości Mine lub All, wykonaj następujące kroki:
  1. W okienku Eksplorator pól kliknij prawym przyciskiem myszy pozycję Pola parametrów, a następnie kliknij polecenie Nowy.
  2. W polu Nazwa wpisz Owner.
  3. W polu tekstowym Monit wpisz monit skierowany do użytkownika. Wpisz na przykład:
    Określ rekordy, które należy uwzględnić
  4. Kliknij przycisk Ustawianie wartości domyślnych.
  5. Wpisz wartości, które chcesz umieścić na liście rozwijanej. W tym przykładzie wykorzystano „Mine” i „All”. Korzystając z przycisku >, przenieś poszczególne wartości na listę Wartości domyślne.
  6. Dla każdej wartości kliknij przycisk Definiuj opis, a następnie wpisz żądany tekst, który będzie wyświetlany na liście rozwijanej dla parametru Owner.
  7. Na liście rozwijanej Wyświetl kliknij pozycję Opis, a następnie kliknij przycisk OK.
  8. W oknie dialogowym Tworzenie pola parametru wyczyść pole wyboru Zezwalaj na edycję wartości domyślnych w przypadku kilku wartości.
  9. Kliknij przycisk OK, aby zapisać nowy parametr.
Aby umożliwić prawidłowe funkcjonowanie parametru Owner, należy uwzględnić ten parametr w raporcie. Aby to zrobić, przeciągnij parametr z okienka Eksplorator pól do dowolnej lokalizacji w raporcie. Dobrym rozwiązaniem jest dodanie dowolnych nowych parametrów do sekcji nagłówka (Page Header) raportu. Jeżeli wszystkie parametry są wymienione w sekcji Page Header, użytkownik może szybko ustalić, jakie dane uwzględniono w raporcie. Jeżeli wartość parametru Owner nie powinna być wyświetlana w raporcie, przeciągnij ją do ukrytego obszaru raportu.
Krok 3: Użycie parametru Owner w nagłówku strony
  1. Parametr Owner jest pierwszym parametrem dodawanym do nagłówka strony, dlatego należy utworzyć pole tekstowe służące do przechowywania istniejącego pola Tytuł raportu. Aby to zrobić, wykonaj następujące kroki:
    1. Kliknij prawym przyciskiem myszy pole Tytuł raportu w raporcie, a następnie kliknij polecenie Usuń.
    2. W menu Wstaw kliknij polecenie Obiekt tekstowy i umieść nowy obiekt tekstowy w miejscu, w którym znajdowało się pole Tytuł raportu.
    3. W okienku Eksplorator pól rozwiń węzeł Pola specjalne.
    4. Przeciągnij pole specjalne Tytuł raportu do nowego obiektu tekstowego.
  2. Przeciągnij parametr Owner z sekcji Pola parametrów okienka Eksplorator pól do nowego obiektu tekstowego.
  3. Dodaj dowolny tekst lub spacje, aby rozdzielić tytuł i parametr Owner.
  4. Aby zapewnić zgodność czcionki z innymi raportami programu Microsoft CRM, kliknij prawym przyciskiem myszy nowy obiekt tekstowy, kliknij polecenie Format tekstu, na karcie Czcionka kliknij pozycję Verdana, kliknij opcję Tekst pogrubiony, kliknij kolor Żółty, a następnie kliknij przycisk OK.
Krok 4: Dodanie parametru Owner do formuły wyboru rekordów
Formuła wyboru rekordów

Formuła wyboru rekordów określa, które rekordy są uwzględniane w raporcie. Formuła jest zgodna z następującą strukturą:
(if {?Parametr1} = "Parametr1_Opcja1" and {tabela.pole} = "wartość1" then true else if {?Parametr1} = "Parametr1_Opcja2" and {tabela.pole} = "wartość2" then true)
Aby uzyskać więcej informacji dotyczących formuł wyboru rekordów, z szablonami dla różnych typów parametrów włącznie, zobacz temat „Record selection formulas” w Pomocy online programu Crystal Reports 9.

W następujące procedurze tworzona jest formuła wyboru rekordów, która weryfikuje wartość parametru Owner klikniętą przez użytkownika. Jeżeli użytkownik kliknie wartość Mine, tylko konta należące do bieżącego użytkownika są uwzględniane w raporcie.

Jeżeli modyfikowany raport nie jest oparty na jednostce Account (Konto), należy zastąpić składnik account.ownerid składnikiem entity.ownerid.

Dodanie parametru Owner do formuły wyboru rekordów

Aby dodać parametr Owner do formuły wyboru rekordów, wykonaj następujące kroki:
  1. W menu Raport kliknij polecenie Formuły wyboru, a następnie kliknij polecenie Rekord.
  2. Zmaksymalizuj okno.
  3. Jeżeli żadne informacje nie są wyświetlane w okienku na dole po prawej stronie, wpisz następującą formułę bez „and” w pierwszym wierszu. Jeżeli kod jest już wyświetlany, dodaj wszystkie trzy wiersze, z „and” włącznie, na końcu listy kodu włącznie.
    and
    (if {?Owner} = "Mine" then {account.ownerid} = {?UserID} 
          else true)
    Po uruchomieniu raportu monit Owner jest wyświetlany z tekstem określonym przez autora. Dane raportu są wyświetlane po kliknięciu przez użytkownika przycisku OK.
  4. Kliknij przycisk Zapisz, a następnie kliknij przycisk Zamknij.

Dodawanie parametru Status

W tej sekcji opisano sposób dodawania parametru stanu na podstawie wartości pola entity.statecode w programie Microsoft CRM. Opcje udostępniane użytkownikom są zależne od wartości tego pola w programie Microsoft CRM. W tym przykładzie wykorzystano jednostkę Działanie.
Krok 1: Definiowanie parametru Status
Aby zdefiniować parametr Status, wykonaj następujące kroki:
  1. W okienku Eksplorator pól kliknij prawym przyciskiem myszy pozycję Pola parametrów, a następnie kliknij polecenie Nowy.
  2. W polu Nazwa wpisz Status.
  3. W polu tekstowym Monit wpisz żądany monit, który będzie wyświetlany. Wpisz na przykład:
    Uwzględnij działania z następującym statusem
  4. Kliknij przycisk Ustawianie wartości domyślnych.
  5. W polu Przeglądaj tabele kliknij nazwę tabeli zawierającej pole stanu. W tym przykładzie wykorzystano jednostkę Działanie. Należy zatem kliknąć element activity.
  6. W polu Przeglądanie pól kliknij element statecodename.
  7. Na stronie Informacje o połączeniu wyczyść pole wyboru Połącz z komputerem lokalnym.
  8. Załaduj listę wszystkich bieżących wartości w programie Microsoft CRM. Aby to zrobić, w polu Serwer zastąp nazwę swojego komputera nazwą serwera programu Microsoft CRM. Jeżeli na przykład w tym polu jest widoczny tekst http://mój_komputer/MSCRMServices, zamień go na tekst http://Twój_CRMServer/MSCRMServices, a następnie kliknij przycisk Zakończ.

    Uwaga: Program Crystal Reports 9 wczytuje wszystkie wartości pola entity.statecode używane w bieżących danych w programie Microsoft CRM. Te wartości mogą nie reprezentować wszystkich wartości, które mogą być wyświetlane w tym polu w programie Microsoft CRM. Aby wyświetlić pełną listę wartości domyślnych dla pól rozwijanych, zobacz „Dodatek A” podręcznika Microsoft Business Solutions CRM Implementation Guide. Jeżeli pole rozwijane zostało zmodyfikowane, należy przeglądać dane pole w programie Microsoft CRM, aby upewnić się, że uwzględnione zostały wszystkie wartości dla parametru określonego przez użytkownika.
  9. Kliknij każdą żądaną wartość, którą chcesz uwzględnić na liście rozwijanej, a następnie kliknij przycisk >, aby przenieść każdą wartość na listę Wartości domyślne.
  10. Dla każdej wartości kliknij przycisk Definiuj opis, a następnie wpisz żądany tekst, który będzie wyświetlany na liście rozwijanej dla parametru Owner.
  11. Uporządkuj wartości, tak aby opcja, którą chcesz skonfigurować jako wartość domyślną, była wyświetlana na początku listy.
  12. W polu rozwijanym Wyświetl kliknij pozycję Opis, a następnie kliknij przycisk OK.
  13. W oknie dialogowym Tworzenie pola parametru wyczyść pole wyboru Zezwalaj na edycję wartości domyślnych w przypadku kilku wartości.
  14. Kliknij przycisk OK, aby zapisać nowy parametr.
Aby umożliwić prawidłowe funkcjonowanie nowego parametru Status, należy uwzględnić ten parametr w raporcie. Aby to zrobić, przeciągnij parametr z okienka Eksplorator pól do dowolnej lokalizacji w raporcie. W następującej procedurze (Krok 2) założono, że użytkownik utworzył już w nagłówku raportu pole tekstowe służące do przechowywania pola Tytuł raportu i parametru Owner.
Krok 2: Użycie parametru Status w nagłówku strony
Aby użyć parametru Status w nagłówku strony, wykonaj następujące kroki:
  1. Przeciągnij parametr Status z sekcji Pola parametrów okienka Eksplorator pól do obiektu tekstowego w sekcji nagłówka strony (Page Header).
  2. Dodaj dowolny tekst lub spacje, aby rozdzielić parametry Status i Owner.
W następujące procedurze (Krok 3) tworzona jest formuła wyboru rekordów, która weryfikuje wartość parametru Status wybraną przez użytkownika. Jeżeli użytkownik kliknie wartość All, uwzględniane są wszystkie działania. W przeciwnym wypadku uwzględniane są tylko rekordy, w których wartość pola programu Microsoft CRM jest zgodna z parametrem klikniętym przez użytkownika.

Jeżeli modyfikowany raport nie jest oparty na jednostce Działanie, należy zastąpić składnik activity.statecodename składnikiem entity.statecodename.
Krok 3: Dodanie parametru Status do formuły wyboru rekordów
Aby dodać parametr Status do formuły wyboru rekordów, wykonaj następujące kroki:
  1. W menu Raport kliknij polecenie Formuły wyboru, a następnie kliknij polecenie Rekord.
  2. Zmaksymalizuj okno.
  3. Jeżeli żadne informacje nie są wyświetlane w okienku na dole po prawej stronie, wpisz następującą formułę bez „and” w pierwszym wierszu. Jeżeli kod jest już wyświetlany, dodaj wszystkie trzy wiersze na końcu listy kodu.
    and
         (if {?Status} = "All" then true 
         else {activity.statecodename}={?Status})
  4. Kliknij przycisk Zapisz, a następnie kliknij przycisk Zamknij.
Po uruchomieniu raportu przez użytkownika monit Status jest wyświetlany z tekstem określonym przez autora. Dane raportu są wyświetlane po kliknięciu przez użytkownika przycisku OK.

Dodanie parametrów Data

W tej sekcji opisano sposób użycia parametru do monitowania użytkownika o określenie zakresu dat. Zakres dat musi być oparty na wartościach jednego lub kilku pól daty w programie Microsoft CRM. Z każdą jednostką jest związane pole entity.createdon i pole entity.modifiedon. Niektóre jednostki są związane z innymi polami daty. Na przykład jednostka Działanie jest związana z datami zależnymi od zaplanowanego terminu i bieżącej daty.

Można utworzyć parametr służący do monitowania użytkownika o kliknięcie elementów na liście rozwijanej, na której są uwzględnione wstępnie zdefiniowane zakresy dat, takie jak „w ciągu 60 ubiegłych dni” lub „od początku roku do bieżącej daty”, albo określenia daty początkowej i końcowej.

W następujących dwóch przykładach wykorzystano jednostkę Przypadek.
Dodawanie parametru Date Crated
Parametr Data utworzenia umożliwia monitowanie użytkownika i wyświetlenie listy określonych wstępnie zdefiniowanych zakresów dat. Aby dodać parametr Date Created, wykonaj następujące kroki:
  1. Aby zdefiniować parametr Date Created, wykonaj następujące kroki:
    1. W okienku Eksplorator pól kliknij prawym przyciskiem myszy pozycję Pola parametrów, a następnie kliknij polecenie Nowy.
    2. W polu Nazwa wpisz Date Created.
    3. W polu tekstowym Monit wpisz żądany monit, który będzie wyświetlany. Wpisz na przykład:
      Określ utworzone rekordy:
    4. Kliknij przycisk Ustawianie wartości domyślnych.
    5. Wpisz wartości, które chcesz umieścić na liście rozwijanej. W tym przykładzie wykorzystano „Within Past 60 Days” (W ciągu ostatnich 60 dni), „Year To Date” (Od początku roku do bieżącej daty) i „All” (Wszystkie). Korzystając z przycisku >, przenieś poszczególne wartości na listę Wartości domyślne.
    6. Dla każdej wartości kliknij przycisk Definiuj opis, a następnie wpisz żądany tekst, który będzie wyświetlany na liście rozwijanej dla parametru Date Created.
    7. Na liście rozwijanej Wyświetl kliknij pozycję Opis, a następnie kliknij przycisk OK.
    8. W oknie dialogowym Tworzenie pola parametru wyczyść pole wyboru Zezwalaj na edycję wartości domyślnych w przypadku kilku wartości.
    9. Kliknij przycisk OK, aby zapisać nowy parametr.
  2. Aby użyć parametru Date Created w nagłówku strony, wykonaj następujące kroki:
    1. Przeciągnij parametr Date Created z sekcji Pola parametrów okienka Eksplorator pól do obiektu tekstowego w sekcji Nagłówek strony.
    2. Dodaj dowolny tekst lub spacje, aby rozdzielić parametry Date Created i Status.
  3. Jeżeli tworzony raport nie jest oparty na jednostce Przypadek, należy zastąpić składnik incident.createdon składnikiem entity.createdon.

    W kroku 4 tworzona jest formuła wyboru rekordów, która weryfikuje wartość parametru Date Created wybraną przez użytkownika. Jeżeli użytkownik kliknie wartość All, uwzględniane są wszystkie rekordy. W przeciwnym wypadku wyświetlane są tylko rekordy zgodne z kryteriami zdefiniowanymi w formule wyboru rekordów. W kodzie formuły wyboru rekordów wykorzystano trzy wstępnie zdefiniowane metody określania zakresu dat z programu Crystal Reports: Aged0To30Days, Aged31To60Days i YearToDate.
  4. Dodaj parametr Date Created do formuły wyboru rekordów. Aby to zrobić, wykonaj następujące kroki:
    1. W menu Raport kliknij polecenie Formuły wyboru, a następnie kliknij polecenie Reokord.
    2. Zmaksymalizuj okno.
    3. Jeżeli żadne informacje nie są wyświetlane w okienku na dole po prawej stronie, wpisz następującą formułę bez „and” w pierwszym wierszu. Jeżeli kod jest już wyświetlany, dodaj wszystkie wiersze na końcu listy kodu.
      and
      (if {?Date Created}="Within Past 60 Days" and   {incident.createdon} in Aged0To30Days or {incident.createdon} in Aged31To60Days then true
      else if {?Date Created}="Year To Date" and {incident.createdon}in YearToDate then true
      )
    4. Kliknij przycisk Zapisz, a następnie kliknij przycisk Zamknij.
    Po uruchomieniu raportu przez użytkownika monit Date Created jest wyświetlany z tekstem określonym przez autora. Dane raportu są wyświetlane po kliknięciu przez użytkownika przycisku OK.
Dodawanie parametru Date Range
Parametr Date Range (Zakres dat) umożliwia monitowanie użytkownika o określenie daty początkowej i końcowej.

Uwaga: W przypadku drukowania raportu z parametrem zakresu użytkownik jest monitowany o podanie zakresu przed wyświetleniem podglądu raportu i po kliknięciu przycisku Drukuj.

Aby dodać parametr Date Range, wykonaj następujące kroki:
  1. Zdefiniuj parametr Date Range. Aby to zrobić, wykonaj następujące kroki:
    1. W okienku Eksplorator pól kliknij prawym przyciskiem myszy pozycję Pola parametrów, a następnie kliknij polecenie Nowy.
    2. W polu Nazwa wpisz Date Range.
    3. W polu tekstowym Monit wpisz żądany monit, który będzie wyświetlany. Wpisz na przykład:
      Uwzględnij rekordy utworzone w następującym okresie
    4. Kliknij przycisk Wartości zakresów, a następnie kliknij przycisk OK.
    Aby umożliwić prawidłowe funkcjonowanie parametru Date Range, należy uwzględnić ten parametr w raporcie. Można przeciągnąć parametr z okienka Eksplorator pól do dowolnej lokalizacji w raporcie.
  2. Jeżeli chcesz wyświetlić datę początkową i końcową zakresu w nagłówku raportu, musisz utworzyć dwa nowe pola formuły: StartDate i EndDate. Aby to zrobić, wykonaj następujące kroki:
    1. W okienku Eksplorator pól kliknij prawym przyciskiem myszy pozycję Pola formuły, a następnie kliknij polecenie Nowy.
    2. W polu Nazwa wpisz StartDate, a następnie kliknij przycisk Użyj edytora.
    3. W polu Formuła wpisz:
      Minimum ({?Date Range})
    4. Kliknij przycisk Zapisz, a następnie przycisk Zamknij.
    5. W okienku Eksplorator pól kliknij prawym przyciskiem myszy pozycję Pola formuły, a następnie kliknij polecenie Nowy.
    6. W polu Nazwa wpisz EndDate, a następnie kliknij przycisk Użyj edytora.
    7. W polu Formuła wpisz:
      Maximum ({?Date Range})
      .
    8. Kliknij przycisk Zapisz, a następnie kliknij przycisk Zamknij.
  3. Użyj parametrów StartDate i EndDate w nagłówku strony. Aby to zrobić, wykonaj następujące kroki:
    1. Przeciągnij parametry StartDate i EndDate z sekcji Pola formuły okienka Eksplorator pól do obiektu tekstowego w sekcji nagłówka strony (Page Header).
    2. Dodaj dowolny tekst lub spacje, aby ułatwić rozdzielenie oraz identyfikację pól.
    W kroku 4 tworzona jest formuła wyboru rekordów, która weryfikuje wartość parametru Date Range klikniętą przez użytkownika. Jeżeli użytkownik kliknie wartość All, uwzględniane są wszystkie działania. W przeciwnym wypadku uwzględniane są tylko rekordy, w których wartość pola programu Microsoft CRM jest zgodna z parametrem klikniętym przez użytkownika.

    Jeżeli tworzony raport nie jest oparty na jednostce Przypadek, należy zastąpić składnik incident.createdon składnikiem entity.createdon.
  4. Dodaj parametr Date Range do formuły wyboru rekordów. Aby to zrobić, wykonaj następujące kroki:
    1. W menu Raport kliknij polecenie Formuły wyboru, a następnie kliknij polecenie Rekord.
    2. Zmaksymalizuj okno.
    3. Jeżeli żadne informacje nie są wyświetlane w okienku na dole po prawej stronie, wpisz następującą formułę bez „and” w pierwszym wierszu. Jeżeli kod jest już wyświetlany, dodaj wszystkie trzy wiersze na końcu listy kodu.
      and
      (if {incident.createdon} in {?Date Range} then true
      else false)
      W drugim wierszu użyj pola daty, które chcesz porównać z zakresem dat. Zależnie od jednostki dobrym rozwiązaniem może być użycie pola modifiedon zamiast pola createdon. Można użyć tylko dat istniejących w jednostkach uwzględnionych w raporcie.
    4. Kliknij przycisk Zapisz, a następnie kliknij przycisk Zamknij.
    Po uruchomieniu raportu przez użytkownika monit Date Range jest wyświetlany z tekstem określonym przez autora. Dane raportu są wyświetlane po wybraniu przez użytkownika daty początkowej i końcowej dla zakresu oraz kliknięciu przycisku OK.
Filtry dla raportów z parametrami
Jeżeli filtry są używane w odniesieniu do raportów z parametrami, należy dwukrotnie wybrać parametry. Najpierw użytkownicy uruchamiają raport z parametrami i określają parametry. Następnie klikają ikonę obok prawej krawędzi paska narzędzi Filtrowanie raportów, wprowadzają filtry, klikają przycisk Filtruj, ponownie wpisują parametry po wyświetleniu monitu, a następnie klikają przycisk OK.

Materiały referencyjne

Aby pobrać listę często zadawanych pytań dotyczących raportów programu Microsoft CRM, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://www.microsoft.com/downloads/details.aspx?FamilyID=81886de8-a10a-473f-8125-49291e0f03d9
Aby uzyskać dodatkowe informacje dotyczące sposobu używania programu Microsoft CRM 1.2 Report Manager do modyfikacji raportów, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
834791 How to use Microsoft CRM 1.2 Reports Manager to modify reports
Aby uzyskać dodatkowe informacje dotyczące sposobu drukowania raportów z parametrami w programie Microsoft CRM 1.2, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
834913 How to print parameter-driven reports in Microsoft CRM 1.2

Właściwości

Numer ID artykułu: 834790 - Ostatnia weryfikacja: 30 marca 2007 - Weryfikacja: 6.1
Informacje zawarte w tym artykule dotyczą:
  • Microsoft CRM 1.2
Słowa kluczowe: 
kbmbsreports kbmbsmigrate kbfile kbhowto KB834790

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com