FIX: You may receive a blank page when you try to compare two pages in a WBC in Edit mode

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Article ID: 834920 - View products that this article applies to.
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SYMPTOMS

If you try to view two postings to compare the revision history in a Web Browser Client (WBC) in Edit mode, you may receive a blank Web page.

CAUSE

This problem occurs because the compare revision process called the PageRevisionCommon.js file, but the file no longer exists. If the user has a custom 404 error message in the Web.config file, it causes the PageRevisionCommon.js file to be returned as an HTML page. Because of this, you may receive a blank Web page in Microsoft Internet Explorer.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time     Size  File name
   ----------------------------------------------------------
   30-Jan-2004  02:06   7,789  Pagerevisioncompareinfo.aspx
   30-Jan-2004  02:06  15,210  Pagerevisioncompareresult.aspx
   30-Jan-2004  02:06  16,048  Pagerevisionhistory.aspx   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

Properties

Article ID: 834920 - Last Review: November 15, 2007 - Revision: 1.5
APPLIES TO
  • Microsoft Content Management Server 2002
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbhotfixserver kbqfe kbbug kbfix kbcontentmgtserv2002sp2fix kbcontentmgtserv2002presp2fix KB834920

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