«Stop код ошибки 0x0000007F» сообщение об ошибке (UNEXPECTED_KERNEL_MODE_TRAP) и на компьютере под управлением Windows 2000 перезагружается

Переводы статьи Переводы статьи
Код статьи: 835281 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

При запуске Symantec AntiVirus корпоративной Edition 8.0 и NSI Software. Double-Take на Компьютер под управлением Microsoft Windows 2000 Server, вы можете возникать следующие проблемы:
  • Появляется сообщение об ошибке, похожее на следующий:
    STOP 0X0000007F (0X00000008, 0X00000000, 0X00000000, 0X00000000)
    (UNEXPECTED_KERNEL_MODE_TRAP)
  • Компьютер неожиданно перезагружается.
Другие версии Symantec AntiVirus может также создавать эти симптомы.

Причина

При выполнении потока Windows 2000 выделяет 12 КБ пространство стека ядра для Этот поток. При — стекового пространства больше доступное пространство стека, Stop 0x0000007f возникает ошибка, и компьютер перезагружается.

Решение

Поскольку другие условия может привести к ошибке Stop 0x0000007f Убедитесь, что проблема порождаемой условие переполнения стека ядра. Для этого получить. файл дампа памяти ядра на компьютере.

В порядок работы этого исправления необходимо также применить обновление к NSI Software Double-Take. Вызывает обновление IoCreateFileSpecifyDeviceObjectHintфункция. Эта функция предоставляет драйвер фильтра может останавливать рекурсивные обращения NTFS файловая система на тот же стек. Для получения этого обновления Свяжитесь с NSI, затем попросите исправление HF28130.

В в корпорации Майкрософт по-прежнему существует предел используемого пространства стека Windows XP и Microsoft В Windows Server 2003. Тем не менее IoCreateFileSpecifyDeviceObjectHint функция в ядро оба Эти операционные системы. Если вы Используйте драйверы фильтра для реализации данной функции в этих операционных систем, которые можно сэкономить пространство стека.

Сведения об исправлении

Исправление от корпорации Майкрософт. Однако данное исправление предназначено для устранения проблемы, описанной в этой статье. Применение исправления только в тех системах, где наблюдается вышеописанная проблема.

Если исправление доступно для загрузки, имеется раздел «Исправление доступно для загрузки» в верхней части статьи базы знаний. Если этот раздел не отображается, отправьте запрос служба поддержки клиентов и поддержки, чтобы получить данное исправление.

Примечание Если другие проблемы или необходимо устранить неполадки, возможно создать отдельный запрос на обслуживание. Расходы на обычные службы поддержки будут применяться дополнительные вопросы и проблемы, не связанные с данным исправлением, оплачиваются. Для получения полного списка телефонов поддержки и обслуживания клиентов корпорации Майкрософт или создать отдельный запрос посетите следующий веб-узел корпорации Майкрософт:
условиям обслуживания
Примечание В форме «Исправление доступно для загрузки» отображаются языки, для которых доступно исправление. Если язык не отображается, это потому, что исправление для данного языка отсутствует.

Необходимые условия

Не требуется соблюдение.

Необходимость перезагрузки

Необходимо перезагрузить компьютер после установки этого исправления.

Сведения о замене исправлений

Это исправление не заменяет других исправлений.

Сведения о файле

Английская версия данного исправления содержит атрибуты файлов (или более поздними), приведенные в следующей таблице. Дата и время для файлов указаны в формате общего скоординированного времени (UTC). При просмотре сведений о файле, преобразуются в местное время. Чтобы узнать разницу между временем UTC и местным временем, следует использовать Часовой пояс на вкладке средство Дата и время панели управления.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   10-Feb-2004  19:47  5.0.2195.6897      30,160  Mountmgr.sys
   30-Apr-2004  02:35  5.0.2195.6927   1,701,312  Ntkrnlmp.exe     
   30-Apr-2004  02:35  5.0.2195.6927   1,700,992  Ntkrnlpa.exe     
   30-Apr-2004  02:35  5.0.2195.6927   1,722,624  Ntkrpamp.exe     
   30-Apr-2004  02:35  5.0.2195.6927   1,678,144  Ntoskrnl.exe 
   30-Apr-2004  02:35  5.4.15.0            6,656  Spmsg.dll


Дополнительные сведения об этом проблемы, обратитесь к следующей статье базы знаний Майкрософт:
822789Появление «Stop 0x0000007F» сообщение об ошибке или компьютер неожиданно перезагружается
При реализации решения, Описанное в статье Microsoft Knowledge Base 822789, в Антивирусные Navap.sys Symantec компонент будет проверять наличие указанного объема пространства в стеке ядра, бесплатный до компонент продолжается. Если объем пространства в стеке ядра бесплатно меньше, чем указано значением KStackMinFree значение реестра Описанное в статье базы знаний 822789, Компонент Navap.sys будет его работы.

Если уже реализован решение об этом рассказывается в статье базы знаний 822789, и вы по-прежнему опыт работы стек ядра проблемы переполнения Применение Это исправление с обновлением NSI. Если При реализации решения и не сталкивался с какими ядра проблемы переполнения стека Затем можно применить это исправление и уменьшить объем пространства в стеке ядра, указанный в параметре KStackMinFree реестр значение. В этом случае компонент Navap.sys требуется низкий объем пространства в стеке ядра и может возможность выполнения более часто.

Статус

Корпорация Майкрософт подтверждает, что это проблема в продуктах корпорации Майкрософт, перечисленных в разделе «Относится к».

Ссылки

Для получения дополнительных сведений щелкните следующий номер статьи базы знаний Майкрософт:
816915 Новая схема присвоения имен файлов для пакетов обновлений программного обеспечения Microsoft Windows
824684 Стандартные термины, используемые при описании обновлений программных продуктов Майкрософт
838804 Появление сообщения об ошибке stop «0x0000007F» на компьютере под управлением Windows 2000
Продукты независимых производителей, на которые статье, производятся компаниями, независимыми от Корпорация Майкрософт. Корпорация Майкрософт не дает никаких гарантий, подразумеваемых или в противном случае относительно производительности или надежности этих продуктов.

Свойства

Код статьи: 835281 - Последний отзыв: 16 января 2012 г. - Revision: 1.0
Информация в данной статье относится к следующим продуктам.
  • операционная система Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Ключевые слова: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbwin2000presp5fix kbmt KB835281 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:835281

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com