DHCP 客户端计算机有时无法获得 IP 地址从运行非 Microsoft 版本的 DHCP 服务的服务器

文章翻译 文章翻译
文章编号: 835304 - 查看本文应用于的产品
展开全部 | 关闭全部

症状

DHCP 客户端计算机有时无法获得 IP 地址从运行非 Microsoft 版本的动态主机配置协议 (DHCP) 服务的服务器。如果等待几分钟的时间,并且再重新启动客户端计算机,该客户端计算机您可能能够获取 IP 地址。

原因

如果满足下列所有条件都都为真,就会出现此问题:
  • 客户端计算机的 IP 地址的租用已经过期。
  • 使用的在客户端计算机的 IP 地址不再可用。
  • 客户端计算机正在使用非 Microsoft DHCP 服务器。
  • 非 Microsoft DHCP 服务器被配置为忽略"重复"DHCP 发现消息 (DHCPDISCOVER)。
出现此问题的原因是客户端计算机发送三个的 DHCP 发现消息与 请求的地址 字段设置为客户端计算机的以前的 IP 地址。 DHCP 客户端计算机始终会发送三个的 DHCP 发现消息,如果两个下列条件都为真:
  • 客户端计算机的 IP 地址的租用已经过期。
  • 使用的在客户端计算机的 IP 地址不再可用。
客户端计算机发送三个的 DHCP 发现消息以验证客户端计算机的旧 IP 地址不再可用。客户端计算机接受第三个的 DHCP 提供消息 (DHCPOFFER) 中提供的 IP 地址。

但是,如果 DHCP 服务器配置为忽略"重复"的 DHCP 发现消息,DHCP 服务器应答,仅对第一个 DHCP 发现 DHCP 提供消息的消息。DHCP 服务器将忽略后续的 DHCP 发现消息。因此,客户端计算机永远不会收到第三个的 DHCP 提供消息。

解决方案

若要解决此问题,将 DHCP 服务器配置为不忽略"重复"DHCP 发现消息。 例如对于如果使用的 Lucent VitalQIP DHCP 服务器设备配置该 CheckTransactionID = 0 Dhcpd.pcy 文件中的参数,以便在 DHCP 服务器回答所有 DHCP 发现消息。 有关如何配置此设置的信息,请与您的 DHCP 服务器设备的制造商联系。有关如何联系您的 DHCP 服务器设备制造商联系的信息,请访问下面的 Microsoft 网站:
http://support.microsoft.com/gp/vendors
Microsoft 提供了第三方联系人信息可以帮助您找到技术支持。此联系信息如有更改,恕不另行通知。Microsoft 不能保证此第三方联系人信息的准确性。

属性

文章编号: 835304 - 最后修改: 2008年6月16日 - 修订: 2.1
这篇文章中的信息适用于:
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Web Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
关键字:?
kbmt kbprb KB835304 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 835304
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com