Se produce una pérdida de memoria después de instalar Windows 2000 Server Service Pack 4

Seleccione idioma Seleccione idioma
Id. de artículo: 835517 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Después de instalar Microsoft Windows 2000 Service Pack 4 (SP4), que puede producirse una condición de pérdida de memoria en un servidor que también tiene instalado Microsoft Operations Manager (MOM). Cuando intenta iniciar sesión en el equipo servidor, puede experimentar uno o más errores de memoria. Además, el servidor puede dejar de responder (bloquearse) y 2020 del identificador de evento puede aparecer en el registro de eventos del sistema.

Causa

Este problema puede producirse si los programas generar tráfico de red de procedimiento remoto (RPC) de la llamada. Este problema puede afectar a MOM ya que MOM genera tráfico RPC cuando se comunica con los agentes administrados.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Debe tener instalado para aplicar esta revisión de Windows 2000 SP4. Si MOM 2000 SP1 está instalado en el servidor, detenga el servicio MOM (Onepoint) antes de aplicar este hotfix.

Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
260910Cómo obtener el Service Pack más reciente para Windows 2000

Requisito de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información acerca de la sustitución de la revisión

Este hotfix reemplaza artículo 825237.

Información de archivo

La versión en inglés de este tiene los atributos de archivo (o posterior) que figuran en la tabla siguiente. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Version         Size       File name
   -----------------------------------------------------------
   02-Feb-2004  19:59  5.0.2195.6824      42,256  Basesrv.dll
   21-Sep-2003  00:45  5.0.2195.6824     236,304  Cmd.exe
   02-Feb-2004  19:59  5.0.2195.6882     222,992  Gdi32.dll
   02-Feb-2004  19:59  5.0.2195.6894     711,952  Kernel32.dll
   02-Feb-2004  19:59  5.0.2195.6824      54,032  Mpr.dll
   02-Feb-2004  19:59  5.0.2195.6895     334,608  Msgina.dll
   02-Feb-2004  19:59  5.0.2195.6892      90,264  Rdpwd.sys
   09-Jan-2004  01:41  5.0.2195.6888   5,854,720  Sp3res.dll
   02-Feb-2004  19:59  5.0.2195.6891     380,688  User32.dll
   02-Feb-2004  19:59  5.0.2195.6891     391,952  Userenv.dll
   21-Jan-2004  19:48  5.0.2195.6892   1,630,256  Win32k.sys
   11-Nov-2003  00:29  5.0.2195.6873     182,032  Winlogon.exe
   02-Feb-2004  19:59  5.0.2195.6884     243,984  Winsrv.dll

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a".

Más información

Aunque este problema de pérdida de memoria es conocido que se produzca con MOM, otros programas que generan tráfico RPC pueden desencadenar también este problema. Puede experimentar este problema después de instalar Windows 2000 SP4, incluso si MOM no está instalada o implicated en caso contrario.

El cambio en el archivo Userenv.dll es corregir un problema de pérdida de símbolo (token) en el proceso Services.exe de SP4 de Windows 2000. La pérdida se produce cuando un subproceso que ejecuta algunas de las funciones de userenv no suplanta al usuario por algún motivo.

Para obtener información adicional, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
816915Nuevo esquema de nomenclatura de archivos para los paquetes de actualización de software de Microsoft Windows
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 835517 - Última revisión: jueves, 26 de octubre de 2006 - Versión: 3.5
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Service Pack 3 de Microsoft Windows 2000
  • Microsoft Windows 2000 Server SP4
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB835517 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 835517

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com