Sie können nicht den Inhalt eines Ordners von einer Remotefreigabe kopieren, wenn der Ordner viele Dateien und Unterordner enthält

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Artikel-ID: 835601 - Produkte anzeigen, auf die sich dieser Artikel bezieht
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Problembeschreibung


In Microsoft Windows NT 4.0 Wenn Sie Windows Explorer, verwenden um einen Ordner kopieren, der viele Unterordner und Dateien von einer Remotefreigabe an einen anderen Speicherort enthält möglicherweise einige der Unterordner und Dateien nicht kopiert werden.

Ursache

Dieses Problem tritt auf, wenn Sie eine Win32-Programm, wie Windows Explorer, verwenden um einen Ordner mit vielen Unterordnern und Dateien über ein langsames Netzwerk zu kopieren.

Wenn ein Win32-Programm der "FindFirstFile"-Funktion verwendet, um eine Liste der Dateien auf einer Remotefreigabe Windows-Redirector (Rdr.sys) Probleme abzurufen einen Befehl Suchen Transact (SMB) auf der Remotefreigabe. Eine Liste von Dateien und Ordnern von der Remotefreigabe zurückgegeben wird und Windows-Redirector speichert die Liste im Puffer Suche suchen Control Block (SCB).

Der Benutzerpuffer Modus FindNextFile wird nur der erste Teil der Liste Dateien und Ordner kopiert. (Der Benutzerpuffer Modus FindNextFile FindFirstFile Handle zugeordnet ist.) Wenn das Win32-Programm in diesem Teil der Liste der Windows-Redirector Abfragen Rdr! CopyIntoSearchBuffer Funktion den nächsten Teil der Liste an den Benutzer-Modus-Puffer kopiert. Die Funktion überprüft, dass der SCB Suche Puffer nicht veraltet ist. (Wenn der Ordner auf der Remotefreigabe sehr groß ist, wird der Ordner sehr lange laden dauern.) Wenn der SCB Suche Puffer vor langer Zeit geladen wurde, die Funktion kennzeichnet SCB Suche Puffer und dann die Funktion fehlschlägt und in einem STATUS_PENDING Zustand aktualisiert. Die Rdr! CopyIntoSearchBuffer Funktion Profilschlüssels anschließend einen Aufruf an den Server um die verbleibende Dateiliste abzurufen. Der ResumeName-Zeiger zeigt jedoch an den nächsten Dateinamen, der von der Win32-Anwendung (im Puffer Suche SCB) erwartet und nicht den tatsächlichen Datei Nachnamen, der von der Win32-Programm angezeigt wurde.

Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist inzwischen von Microsoft erhältlich; dieser Hotfix wurde jedoch ausschließlich zur Behebung des in diesem Artikel beschriebenen Problems entwickelt. Wenden Sie es nur auf Systemen, bei die dieses spezielle Problem auftritt.

Wenden Sie sich zum Beheben dieses Problems an Microsoft Product Support Services, um den Hotfix zu erhalten. Eine vollständige Liste mit Telefonnummern der Microsoft-Produktsupport und Informationen Supportkosten der folgenden Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: PLEASE DO NOT TRANSLATE and DELETE THIS PASSAGE. IT DOES NOT APPLY TO GERMANY.

Voraussetzungen

Aufgrund von Dateiabhängigkeiten erfordert dieser Hotfix Microsoft Windows NT 4.0 Service Pack 6a.

Starten von Anforderungen

Sie müssen den Computer nach der Installation dieses Hotfixes neu starten.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time () angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools ? Datum und Uhrzeit in der Systemsteuerung.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-Jan-2004  13:22  4.0.1381.7261     266,256  Rdr.sys

Status

Microsoft hat bestätigt, dass dies ein Problem in den Microsoft-Produkten ist, die im Abschnitt "Gilt für" dieses Artikels aufgeführt sind.

Eigenschaften

Artikel-ID: 835601 - Geändert am: Freitag, 7. Februar 2014 - Version: 1.4
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Keywords: 
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Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 835601
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