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You cannot copy the contents of a folder from a remote share if the folder contains many files and subfolders

Article ID:835601
Last Review:October 26, 2006
Revision:1.4
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SYMPTOMS


In Microsoft Windows NT 4.0, when you use Windows Explorer to copy a folder that contains many subfolders and files from a remote share to another location, some of the subfolders and files may not be copied.

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CAUSE

This problem occurs when you use a Win32 program, such as Windows Explorer, to copy a folder with many subfolders and files over a slow network.

When a Win32 program uses the FindFirstFile function to retrieve a list of files on a remote share, Windows Redirector (Rdr.sys) issues a Search Transact Server Message Block (SMB) command on the remote share. A list of files and folders is returned from the remote share, and Windows Redirector stores the list in the Search Control Block (SCB) search buffer.

Only the first part of the files and folders list is copied to the FindNextFile user mode buffer. (The FindNextFile user mode buffer is associated with the FindFirstFile handle.) When the Win32 program queries this part of the list, the Windows Redirector Rdr!CopyIntoSearchBuffer function copies the next part of the list to the user mode buffer. The function checks that the SCB search buffer is not too old. (If the folder on the remote share is very large, the folder will take a long time to load.) If the SCB search buffer was loaded a long time ago, the function flags the SCB search buffer, and then the function fails and updates to a STATUS_PENDING state. The Rdr!CopyIntoSearchBuffer function then reissues a call to the server to retrieve the remaining file list. However, the ResumeName pointer points to the next file name that is expected by the Win32 program (in the SCB search buffer) and not to the actual last file name that was viewed by the Win32 program.

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RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

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Prerequisites

Because of file dependencies, this hotfix requires Microsoft Windows NT 4.0 Service Pack 6a.

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Restart requirements

You must restart your computer after you apply this hotfix.

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Hotfix replacement information

This hotfix does not replace any other hotfixes.

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File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-Jan-2004  13:22  4.0.1381.7261     266,256  Rdr.sys

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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APPLIES TO
Microsoft Windows NT Server 4.0 Standard Edition
Microsoft Windows NT Workstation 4.0 Developer Edition

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Keywords: 
kbhotfixserver kbqfe kbqfe kbfix kbbug KB835601

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