Você não pode copiar o conteúdo de uma pasta a partir de um compartilhamento remoto se a pasta contiver muitos arquivos e subpastas

Traduções deste artigo Traduções deste artigo
ID do artigo: 835601 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas


No Microsoft Windows NT 4.0, ao usar o Windows Explorer para copiar uma pasta que contém muitas subpastas e arquivos de um compartilhamento remoto para outro local, alguns dos arquivos e subpastas podem não ser copiados.

Causa

Esse problema ocorre quando você usar um programa Win32, como o Windows Explorer, para copiar uma pasta com muitas subpastas e arquivos em uma rede lenta.

Quando um programa Win32 usa a função FindFirstFile para recuperar uma lista de arquivos em um compartilhamento remoto, problemas do redirecionador do Windows (rdr.sys) um comando de pesquisa Transact (SMB) no compartilhamento remoto. Uma lista de arquivos e pastas é retornada do compartilhamento remoto e redirecionador do Windows armazena a lista no buffer de pesquisa de bloco de controle de pesquisa (SCB).

Somente a primeira parte da lista de arquivos e pastas é copiada para o buffer do modo de usuário FindNextFile. (O buffer do modo de usuário FindNextFile está associado com o identificador FindFirstFile.) Quando o programa Win32 consulta nesta parte da lista, o redirecionador do Windows Rdr! CopyIntoSearchBuffer função copia a próxima parte da lista para o buffer do modo de usuário. A função verifica que o buffer de pesquisa SCB não é muito antigo. (Se a pasta no compartilhamento remoto for muito grande, a pasta levará muito tempo para carregar.) Se o buffer de pesquisa SCB foi carregado muito tempo atrás, a função sinaliza o buffer de pesquisa SCB e, em seguida, a função falha e é atualizado para um estado STATUS_PENDING. O Rdr! CopyIntoSearchBuffer função reedita, em seguida, uma chamada para o servidor para recuperar a lista de arquivos restantes. No entanto, o ponteiro ResumeName aponta para o próximo nome de arquivo esperado pelo programa de Win32 (em buffer de pesquisa SCB) e não para o último nome do arquivo real que foi exibido pelo programa Win32.

Resolução

Informações sobre o hotfix

Um hotfix suportado agora está disponível da Microsoft, mas destina-se somente a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Para resolver esse problema, contate o Atendimento Microsoft para obter o hotfix. Para obter uma lista completa de telefones do Atendimento Microsoft e informações sobre os custos de suporte da, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação Em alguns casos, as taxas cobradas pelas ligações para chamadas de suporte podem ser canceladas se um profissional de suporte da Microsoft determinar que uma atualização específica resolverá o problema. Os custos normais de suporte serão aplicados a questões e problemas que não se qualificam à atualização específica em questão de suporte adicionais.

Pré-requisitos

Devido às dependências do arquivo, esse hotfix exige o Microsoft Windows NT 4.0 Service Pack 6a.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-Jan-2004  13:22  4.0.1381.7261     266,256  Rdr.sys

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft que estão listados na seção "Aplica-se a" deste artigo.

Propriedades

ID do artigo: 835601 - Última revisão: sábado, 26 de outubro de 2013 - Revisão: 1.4
A informação contida neste artigo aplica-se a:
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Palavras-chave: 
kbnosurvey kbarchive kbmt kbhotfixserver kbqfe kbqfe kbfix kbbug KB835601 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 835601

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com