Не удается скопировать содержимое папки с удаленного общего ресурса, если папка содержит множество файлов и вложенных папок

Переводы статьи Переводы статьи
Код статьи: 835601 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема


В Microsoft Windows NT 4.0 скопируйте папку, содержащую много вложенных папок и файлов с удаленного общего ресурса в другое место с помощью проводника Windows некоторые вложенные папки и файлы могут не копируются.

Причина

Данная проблема возникает при использовании программы Win32, таких как проводник Windows, скопировать папку много вложенных папок и файлов в медленной сети.

Когда программа Win32 функция FindFirstFile для получения списка файлов на удаленном общем ресурсе проблемы перенаправитель Windows (Rdr.sys) команда поиска Transact блок SMB (Server Message) на удаленном общем ресурсе. Возвращает список файлов и папок из удаленной общей папке и перенаправитель Windows хранит список в буфер поиска блок управления поиска (SCB).

Только первая часть списка файлов и папок копируется в буфер FindNextFile пользовательского режима. (Режим буфера FindNextFile пользователя сопоставлен обработчик FindFirstFile.) Когда программа Win32 запрашивает эту часть списка, перенаправитель WindowsRdr! CopyIntoSearchBufferфункция копирует следующей части списка буфер режима пользователя. Функция проверяет буфер SCB поиска не слишком старый. (Если очень большой папки на удаленном общем ресурсе папки займет много времени для загрузки.) Если буфер SCB поиска была загружена давно, функция флаги поиска буфера SCB, а затем функция завершается неудачей и обновляет состояние ответ STATUS_PENDING. ВRdr! CopyIntoSearchBufferЗатем функция reissues вызов сервера для получения списка оставшихся файлов. Тем не менее указатель ResumeName указывает имя файла Далее, ожидается, что программа Win32 (в буфере поиска SCB), а не фактические имя последнего файла, который был просмотрен программа Win32.

Решение

Сведения об исправлении

Корпорация Майкрософт выпустила исправление, но в данной статье описывается проблема может быть решена. Предлагаемое исправление должно применяться исключительно в системах, где наблюдается вышеописанная проблема.

Чтобы устранить эту проблему, обратитесь в службу технической поддержки корпорации Майкрософт для получения исправления. Полный список телефонов службы поддержки продуктов Майкрософт и сведения о стоимости поддержки посетите веб-узел корпорации Майкрософт:
http://support.Microsoft.com/contactus/?ws=Support
ПримечаниеВ особых случаях оплата, предусмотренная для звонков в службу поддержки может быть отменена, если специалистом службы технической поддержки Майкрософт будет определено, что решением проблемы является специально выпущенное. Затраты на обычные службы поддержки будут применяться дополнительные вопросы и проблемы, которые не соответствуют требованиям особым обновлением.

Необходимые условия

Из-за зависимостей между файлами для установки исправления требуется наличие Microsoft Windows NT 4.0 с пакетом обновления 6a (SP6a).

Необходимость перезагрузки

После установки этого исправления необходимо перезагрузить компьютер.

Сведения о замене исправлений

Это исправление не заменяет других исправлений.

Сведения о файлах

Английская версия данного исправления содержит версии файлов (или более поздней версии), приведенные в следующей таблице. Дата и время для файлов указаны в формате общего скоординированного времени (UTC). При просмотре сведений о файле, он преобразуется в локальное время. Чтобы узнать разницу между временем по Гринвичу и местным временем, следует использоватьЧасовой поясвкладку Дата и время на панели управления.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-Jan-2004  13:22  4.0.1381.7261     266,256  Rdr.sys

Статус

Корпорация Майкрософт подтверждает, что это проблема в продуктах Microsoft, перечисленных в разделе «Относится к» данной статьи.

Свойства

Код статьи: 835601 - Последний отзыв: 4 февраля 2011 г. - Revision: 3.0
Информация в данной статье относится к следующим продуктам.
Ключевые слова: 
kbhotfixserver kbqfe kbfix kbbug kbmt KB835601 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:835601

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com