Windows XP 또는 Windows 2000에서 소리가 느리게 재생되거나 음악이 연속적으로 재생되지 않을 수 있다

기술 자료 번역 기술 자료 번역
기술 자료: 835730 - 이 문서가 적용되는 제품 보기.
중요 이 문서에서는 레지스트리 수정 방법을 설명합니다. 레지스트리를 수정하기 전에 해당 레지스트리를 백업하고 문제가 발생할 경우 이를 복원하는 방법을 알고 있어야 합니다. 레지스트리 백업, 복원 및 편집 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
256986 Microsoft Windows 레지스트리 설명
모두 확대 | 모두 축소

이 페이지에서

현상

Intel® HyperThreading Technology 또는 Enhanced SpeedStep® Technology를 사용하는 Microsoft Windows XP 또는 Microsoft Windows 2000 기반 컴퓨터에서 다음 현상 중 하나 이상이 발생할 수 있습니다.
  • 오디오를 재생할 때 오디오가 연속적으로 재생되지 않을 수 있습니다.
  • MIDI 기반의 음악을 재생할 때 음악이 느린 템포로 재생될 수 있습니다.
  • 컴퓨터가 C3 절전 상태로 올바르게 전환되지 않을 수 있습니다. 이는 배터리 전원 수명에 영향을 미칩니다.

원인

이 문제는 하이퍼 스레드가 설정되어 있고 컴퓨터 전원 상태가 변경되는 경우 시스템에서 반환되는 시간 값을 잘못 해석하여 발생합니다. 다음 작업 중 하나를 수행하는 경우 이 문제가 발생할 수 있습니다.
  • DirectX 진단 도구(Dxdiag.exe)의 음악 탭에서 DirectMusic 테스트를 누릅니다.
  • 컴퓨터 게임을 재생합니다.
  • Microsoft Windows XP Media Center Edition에서 TV 소리를 듣습니다.
DirectX 진단 도구에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
190900 DirectX: DirectX 진단 도구 설명

해결 방법

Microsoft Windows XP

서비스 팩 정보

이 문제를 해결하려면 Windows XP용 최신 서비스 팩을 구하십시오. 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
322389 최신 Windows XP 서비스 팩을 구하는 방법

핫픽스 정보

현재 지원되는 핫픽스를 Microsoft에서 구할 수 있지만 이 문서에서 설명하는 문제를 해결하기 위한 것일 뿐이므로 이러한 특정 문제가 발생하는 시스템에만 이 핫픽스를 적용하십시오. 이 핫픽스는 나중에 추가 테스트를 받아야 할 수도 있습니다. 따라서 이 문제의 영향이 심각하지 않으면 이 핫픽스가 포함된 다음 서비스 팩이 나올 때까지 기다리는 것이 좋습니다.

이 문제를 해결하려면 Microsoft 온라인 고객 서비스에 요청을 제출하여 핫픽스를 구하십시오. 핫픽스를 구하기 위한 온라인 요청을 제출하려면 다음 Microsoft 웹 사이트를 방문하십시오.
http://go.microsoft.com/?linkid=6294451
참고 문제가 추가로 발생하거나 문제 해결이 필요한 경우 별도의 서비스 요청을 해야 할 수도 있습니다. 이 특정 핫픽스로 해결할 수 없는 추가 질문과 문제에 대해서는 지원 비용이 청구됩니다. 별도의 서비스 요청을 하려면 다음 Microsoft 웹 사이트를 방문하십시오.
기술지원 서비스 안내

파일 정보

이 핫픽스의 영어 버전은 아래와 같거나 그 이상의 파일 특성을 갖습니다. 이 파일의 날짜와 시간은 UTC(Coordinated Universal Time)로 나열되며 파일 정보를 볼 때 로컬 시간으로 변환됩니다. UTC와 로컬 시간의 차이를 보려면 제어판날짜 및 시간 도구에서 표준 시간대 탭을 사용하십시오.
표 축소표 확대
날짜시간버전크기파일 이름
2004-02-2321:265.1.2600.1348130,816Halmacpi.dll

Microsoft Windows 2000

핫픽스 정보

현재 지원되는 핫픽스를 Microsoft에서 구할 수 있지만 이 문서에서 설명하는 문제를 해결하기 위한 것일 뿐이므로 이러한 특정 문제가 발생하는 시스템에만 이 핫픽스를 적용해야 합니다.

이 문제를 해결하려면 Microsoft 고객기술지원부에 문의하여 핫픽스를 구하십시오. Microsoft 고객기술지원부의 전체 전화 번호 목록과 지원 비용에 대한 정보를 보려면 다음 Microsoft 웹 사이트를 방문하십시오.
기술지원 서비스 안내
참고?특정 업데이트로 문제를 해결할 수 있다고 Microsoft 기술지원 전문가가 판단할 경우 지원 요청에 따른 일반적 비용이 취소될 수도 있습니다. 해당 업데이트로 해결할 수 없는 추가 질문과 문제에 대해서는 지원 비용이 청구됩니다.

전제 조건

Microsoft Windows 2000 서비스 팩 3(SP3)

다시 시작 요구 사항

이 핫픽스를 적용한 후에는 컴퓨터를 다시 시작할 필요가 없습니다.

핫픽스 대체 정보

이 핫픽스는 다른 핫픽스를 대체하지 않습니다.

파일 정보

이 핫픽스의 영어 버전은 아래와 같거나 그 이상의 파일 특성을 갖습니다. 이 파일의 날짜와 시간은 UTC(Coordinated Universal Time)로 나열되며 파일 정보를 볼 때 로컬 시간으로 변환됩니다. UTC와 로컬 시간의 차이를 보려면 제어판날짜 및 시간 도구에서 표준 시간대 탭을 사용하십시오.
표 축소표 확대
날짜시간버전크기파일 이름
2004-10-1520:545.0.2195.698884,192Halaacpi.dll
2004-10-1520:545.0.2195.698868,736Halacpi.dll
2004-10-1520:545.0.2195.698885,888Halmacpi.dll


Windows 2000 기반 컴퓨터에 이 핫픽스를 적용한 후 해당 옵션을 수동으로 설정해야 합니다.

참고?이 옵션을 설정하려면 다음 방법 중 하나만 사용해야 합니다. 두 방법을 모두 사용해야 하는 것은 아닙니다.
  • Boot.ini 파일 편집?시스템 드라이브의 루트 폴더에 있는 Boot.ini 파일을 수동으로 편집하여 해당 운영 체제 줄에 /usepmtimer 스위치를 추가합니다. 이렇게 하려면 다음과 같이 하십시오.
    1. 시작, 실행을 차례로 누르고 열기 상자에 CMD를 입력한 다음 확인을 누릅니다.
    2. attrib c:\boot.ini -r을 입력한 다음 Enter 키를 누릅니다.
    3. exit를 입력한 다음 Enter 키를 누릅니다.
    4. 시작, 실행을 차례로 누르고 열기 상자에 notepad c:\boot.ini를 입력한 다음 확인을 누릅니다.

      Boot.ini 파일을 표시하는 창이 열립니다. "default"로 시작하는 줄은 Windows 2000이 사용자의 개입 없이 시작할 때 로드하는 위치입니다. 예를 들어, 줄은 다음과 같이 나타날 수 있습니다.
      default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    5. 기본 줄의 정보에 해당하는 Windows 2000의 줄을 찾습니다. 이 줄은 아래와 유사합니다.
      multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows 2000" /fastdetect
    6. 줄 맨 끝에 공백을 추가한 다음 /usepmtimer을 입력합니다. 이제 이 줄은 아래와 유사하게 나타납니다.
      multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows 2000" /fastdetect /usepmtimer
    7. 파일을 저장한 다음 메모장을 끝냅니다.
    8. 컴퓨터를 다시 시작합니다.
    다음은 /usepmtimer 스위치를 포함하는 시스템의 Boot.ini 파일 예제입니다.
     
    [boot loader] timeout=0 default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS [operating systems] multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows 2000" /fastdetect /usepmtimer
    
  • 레지스트리 편집 다음 레지스트리 설정에 값이 00000010인 14140000FFFFFFFF라는 DWORD 값을 추가합니다.
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\HAL


    경고 레지스트리 편집기를 잘못 사용하면 심각한 문제가 발생할 수 있으며 문제를 해결하기 위해 운영 체제를 다시 설치해야 할 수도 있습니다. Microsoft는 레지스트리 편집기를 잘못 사용하여 발생하는 문제에 대해 해결을 보증하지 않습니다. 레지스트리 편집기 사용에 따른 모든 책임은 사용자에게 있습니다.

    이렇게 하려면 다음과 같이 하십시오.
    1. 시작, 실행을 차례로 누르고 열기 상자에 regedit를 입력한 다음 확인을 누릅니다.
    2. 레지스트리에서 다음 하위 키를 찾아 누릅니다.
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\HAL
    3. 편집 메뉴에서 새로 만들기를 가리킨 다음 DWORD 값을 누릅니다.
    4. DWORD의 이름으로 14140000FFFFFFFF를 입력한 다음 Enter 키를 누릅니다.
    5. 14140000FFFFFFFF를 마우스 오른쪽 단추로 누른 다음 수정을 누릅니다.
    6. 값 데이터 상자에 00000010을 입력한 다음 확인을 누릅니다.
    7. 레지스트리 편집기를 종료합니다.

현재 상태

Microsoft는 이 문서의 "본 문서의 정보는 다음의 제품에 적용됩니다." 절에 나열한 제품에서 이 문제를 확인했습니다. 이 문제는 Microsoft Windows XP 서비스 팩 2에서 처음 해결되었습니다.

추가 정보

핫픽스 패키지의 이름을 지정하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
816915 Microsoft Windows 소프트웨어 업데이트 패키지의 새 파일 명명 스키마
자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
824684 Microsoft 소프트웨어 업데이트를 설명하는 데 사용되는 표준 용어에 대한 설명




Microsoft 제품 관련 기술 전문가들과 온라인으로 정보를 교환하시려면 Microsoft 뉴스 그룹에 참여하시기 바랍니다.

속성

기술 자료: 835730 - 마지막 검토: 2007년 9월 7일 금요일 - 수정: 4.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Media Center Edition 2004
  • Microsoft Windows XP Media Center Edition
키워드:?
kbbug kbfix kbqfe kbwinxpsp2fix kbwinxppresp2fix kbwin2000presp5fix kbhotfixserver KB835730

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com