Artigo: 835973 - Última revisão: segunda-feira, 5 de Fevereiro de 2007 - Revisão: 1.2

Após a instalação do Windows Messenger 5.0, o Windows deixa de responder e o processo Csrss.exe utiliza a CPU a 100 por cento

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Poderá detectar os seguintes sintomas após a instalação do Microsoft Windows Messenger 5.0:
  • O Windows tem um desempenho muito lento ou deixa de responder (não reage).
  • Se visualizar o separador Processos no Gestor de tarefas do Windows, notará que o processo Csrss.exe utiliza a CPU a 100 por cento e utiliza cerca de 200 megabytes (MB) de memória.
  • Se terminar o processo Msmsgs.exe, ou se reiniciar o Windows, este problema é temporariamente resolvido.
  • Este problema ocorre cerca de 14 dias, ou mais, após reiniciar o Windows ou o Windows Messenger, se não reiniciar um deles durante esse período.

Causa

Este problema ocorre devido a um erro da funcionalidade de temporização da recolha de dados do Service Quality Monitor (SQM) do Windows Messenger. Quando são iniciados novos temporizadores para a recolha de dados do SQM, os temporizadores anteriores não são terminados. Após cerca de 14 dias, poderão ser criados cerca de 32 000 temporizadores. Esta situação provoca o aumento da utilização da CPU e de memória no Windows.

Resolução

Para resolver este problema, transfira e instale a versão mais recente do Windows Messenger. Para obter a versão mais recente do Windows Messenger, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyID=a8d9eb73-5f8c-4b9a-940f-9157a3b3d774&DisplayLang=en (http://www.microsoft.com/downloads/details.aspx?FamilyID=a8d9eb73-5f8c-4b9a-940f-9157a3b3d774&DisplayLang=en)

Como contornar

Para contornar este problema, utilize um dos seguintes métodos.

Método 1: Reiniciar o Windows Messenger

Utilize um dos seguintes métodos de 14 em 14 dias:
  • Reinicie o Windows Messenger.
  • Reinicie o Windows.

Método 2: Desactivar o Windows Messenger

Se não utilizar o Windows Messenger, configure-o para que deixe de ser iniciado automaticamente quando inicia o Windows. Para tal, siga estes passos:
  1. Clique com o botão direito do rato no ícone do Windows Messenger, na área de notificação, e clique em Abrir.
  2. No menu Ferramentas, clique em Opções.
  3. Clique no separador Preferências, clique para desmarcar a caixa de verificação Executar o Windows Messenger quando o Windows for iniciado e clique em OK.
  4. No menu Ficheiro, clique em Fechar.
  5. Clique com o botão direito do rato no ícone do Windows Messenger, na área de notificação, e clique em Sair.

Ponto Da Situação

A Microsoft confirmou que este problema ocorre no Microsoft Windows Messenger 5.0. Este problema foi corrigido no Microsoft Windows Messenger 5.0.482.

A informação contida neste artigo aplica-se a:
  • Microsoft Office Live Communications Server 2003
  • Microsoft Windows Messenger 5.0
Palavras-chave: 
kbfix kbbug KB835973