Le message d'erreur « Une erreur irrécupérable s'est produite » ou « Money a rencontré un problème et doit fermer » s'affiche lorsque vous démarrez Money

Traductions disponibles Traductions disponibles
Numéro d'article: 836197 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous démarrez l'une des versions de Microsoft Money figurant dans la liste des produits concernés, l'un des messages d'erreur suivants s'affiche :

Message d'erreur 1

Une erreur irrécupérable s'est produite.
AppName : msmoney.exe
ModName : mnyob99.dll

Message d'erreur 2

Money version a rencontré un problème et doit fermer. Nous vous prions de nous excuser pour le désagrément encouru.
Dans ce message d'erreur, version est la version de Microsoft Money qui est installée sur l'ordinateur.

Par ailleurs, lorsque vous cliquez sur Cliquez ici dans le message d'erreur, le message suivant s'affiche :
AppName : msmoney.exe
ModName: mnyob99.dll ou uparser2.dll

Cause

Ce problème peut se produire si une ou plusieurs des conditions suivantes sont remplies :
  • Les fichiers Msxml.dll sont endommagés ou ne pas correctement enregistrés.
  • Les paramètres Microsoft Internet Explorer sont incorrects.
  • L'installation de Money est endommagée.

Résolution

Pour résoudre ce problème, appliquez l'une des méthodes suivantes ou les deux.

Remarque Dans la mesure où il existe plusieurs versions de Microsoft Windows, la procédure suivante peut varier en fonction de votre ordinateur. Si tel est le cas, reportez-vous à la documentation de votre produit pour effectuer ces opérations.

Méthode 1 : Réinitialisation des paramètres de sécurité d'Internet Explorer

Pour réinitialiser les paramètres de sécurité de Microsoft Internet Explorer 7 sous Microsoft Windows XP, procédez comme suit :
  1. Démarrez Internet Explorer.
  2. Dans le menu Outils, cliquez sur Options Internet, puis sur l'onglet Sécurité.
  3. Cliquez sur la zone de contenu Web Internet, puis sur Niveau par défaut.
  4. Cliquez sur l'onglet Avancés, sur Restaurer les paramètres par défaut, puis sur OK.
  5. Quittez Internet Explorer.
Pour réinitialiser les paramètres Internet Explorer sous Windows Vista, suivez les étapes décrites dans la rubrique d'aide suivante.

Pour résoudre ce problème, suivez les étapes présentées dans la section appropriée.

Votre ordinateur est connecté à Internet

Consultez la section « Reset Internet Explorer settings » (Réinitialisation des paramètres Internet Explorer) sur le site Web Aide et support en ligne de Windows à l'adresse suivante (en anglais) :
http://windowshelp.microsoft.com/Windows/fr-FR/default.mspx

Votre ordinateur n'est pas connecté à Internet

Consultez la section relative à la réinitialisation des paramètres Internet Explorer dans Aide et support de Windows sur le disque dur de votre ordinateur, en procédant comme suit :
  1. Cliquez sur Démarrer, puis sur Aide et support.
  2. Dans la zone Rechercher dans l'Aide ou Rechercher dans l'Aide en ligne, tapez Réinitialisation des paramètres Internet Explorer, puis cliquez sur Rechercher dans l'Aide.
  3. Dans la liste des rubriques, cliquez sur Réinitialisation des paramètres Internet Explorer.
  4. Cliquez sur le lien qui décrit le mieux le problème que vous rencontrez.
  5. Suivez les suggestions proposées pour résoudre le problème que vous rencontrez.

Méthode 2 : Suppression et réinstallation de Money

Pour plus d'informations sur la façon de désinstaller et de réinstaller Microsoft Money, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
895866 Comment faire pour supprimer et réinstaller Microsoft Money

Méthode 3 : Réenregistrement des fichiers DLL MSXML puis mise à jour des composants (Windows XP uniquement)

Pour réenregistrer les fichiers DLL MSXML, procédez comme suit :
  1. Tapez les commandes suivantes à partir d'une invite de commandes en appuyant sur Entrée après chaque commande :
    regsvr32 c:\winnt\system32\msxml.dll

    regsvr32 c:\winnt\system32\msxml3.dll

    regsvr32 c:\winnt\system32\msxml4.dll
    Remarque Suivant l'emplacement d'installation de Microsoft Windows, vous devrez peut-être modifier le chemin dans les commandes indiquées si Windows n'a pas été installé dans C:\WinNT.
  2. Démarrez Money.
  3. Si le problème persiste, téléchargez et installez MSXML.

    Pour télécharger Microsoft MSXML 4.0 Service Pack 2 (Microsoft XML Core Services), reportez-vous au site Web de Microsoft à l'adresse suivante :
    http://www.microsoft.com/downloads/details.aspx?FamilyID=3144b72b-b4f2-46da-b4b6-c5d7485f2b42&DisplayLang=fr
  4. Téléchargez et installez MDAC Component Checker afin de vérifier la version de MDAC qui est installée.

    Pour cela, reportez-vous au site Web de Microsoft à l'adresse suivante (en anglais) :
    http://www.microsoft.com/downloads/details.aspx?FamilyID=8f0a8df6-4a21-4b43-bf53-14332ef092c9&DisplayLang=en
  5. Téléchargez et installez Microsoft Windows Script 5.6.

    Pour cela, reportez-vous au site Web de Microsoft à l'adresse suivante :
    http://www.microsoft.com/downloads/details.aspx?familyid=C717D943-7E4B-4622-86EB-95A22B832CAA&displaylang=fr
  6. Réenregistrer les fichiers DLL MSXML comme décrit à l'étape 1.
  7. Redémarrez l'ordinateur.

Propriétés

Numéro d'article: 836197 - Dernière mise à jour: mardi 19 juin 2007 - Version: 4.4
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Money Essentials
  • Microsoft Money Deluxe 2007
  • Microsoft Money 2007 Home & Business
  • Microsoft Money Premium 2007
  • Microsoft Money Deluxe 2006
  • Microsoft Money Premium 2006
  • Microsoft Money Small Business 2006
  • Microsoft Money Standard 2006
  • Microsoft Money 2005 Deluxe Edition
  • Microsoft Money 2005 Premium Edition
  • Microsoft Money 2005 Small Business Edition
  • Microsoft Money 2005 Standard Edition
  • Microsoft Money 2004 Deluxe Edition
  • Microsoft Money 2004 Premium Edition
  • Microsoft Money 2004 Small Business Edition
  • Microsoft Money 2004 Standard
  • Microsoft Money 2003 Deluxe Edition
  • Microsoft Money 2003 Deluxe and Business Edition
  • Microsoft Money 2003 Standard
  • Microsoft Money 2002 Standard
Mots-clés : 
kbprb KB836197
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com