Zpráva v souboru protokolu Migration.log při použití nástroje ADMT verze 2 v systému Windows Server 2003 nebo Windows 2000 Server "serveru není funkční.

Překlady článku Překlady článku
ID článku: 836429 - Produkty, které se vztahují k tomuto článku.
Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zazálohovat. Seznamte se také s postupem při obnovení registru v případě, že nastane problém. Informace o zálohování, obnovení a úpravě registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Při použití přenesení nástroj ADMT (Active Directory) verze 2 migrovat uživatele nebo skupiny můžete obdržet chybu v souboru protokolu Migration.log podobná následující:
ERR2:7298 nelze najít LDAP: //domain.com/CN=user1,OU=User,OU=Accounts,DC=domain,DC=com doména.com, hr = 8007203a server není funkční.

Příčina

K tomuto problému dochází, když nástroj ADMT provádí vazby Lightweight Directory Access Protocol (LDAP) pro každý objekt je přenést a port volání (RPC) dočasných vzdálené procedury přidělené pro každý z těchto připojení. Microsoft Windows Server 2003 a Microsoft Windows 2000 Server podržení každý port pro čtyři minut a potom uvolněte každý port pro jiné připojení sítě. Ve výchozím nastavení výčet porty 5000 Windows Server 2003 a Windows 2000 Server. První port, který je k dispozici pro použití aplikacemi je 1024 pro maximální 3977 aktivní připojení. V některých konfiguracích hardwaru high-powered úlohu přenesení zpracovány tak rychle rychlost síťové požadavky překračuje rychlost otevřené porty jsou k dispozici znovu. Pokud jsou spotřebovány všech dočasných portů ADMT může vrátit chybu, která je uvedena v části "Příznaky".

Řešení

Tento problém vyřešit, zvyšte výchozí počet portů, které jsou k dispozici pro program přenos. Číslo další porty musí být dostatečná úchyt počet současných síťových požadavků, které jsou prováděny všechny programy. Počet přidělených portů je řízen TCP/IP položka registru
MaxUserPort
. Ve výchozím tato položka neexistuje. Vytvoření této položky, postupujte takto.

Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zazálohovat. Seznamte se také s postupem při obnovení registru v případě, že nastane problém. Informace o zálohování, obnovení a úpravě registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986Popis registru systému Microsoft Windows
  1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, do pole Otevřít zadejte příkaz regedit a klepněte na tlačítko OK.
  2. Vyhledejte následující podklíč a klikněte na něj:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters
  3. V nabídce Úpravy přejděte na příkaz Nový, klepněte na příkaz Hodnota DWORD a pak zadejte MaxUserPort.
  4. Poklepejte na MaxUserPort a potom nastavit desetinnou hodnotu na číslo větší než 5000.

    Poznámka:Tato hodnota řídí číslo maximální dynamických portů. Platný rozsah tato hodnota je 5000-65534. Ve výchozím nastavení je počet dostupných portů 3977, protože první port k dispozici je 1024.
  5. Ukončete program Editor registru.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech společnosti, které jsou uvedeny v části "Platí pro" v tomto článku.

Vlastnosti

ID článku: 836429 - Poslední aktualizace: 30. října 2006 - Revize: 2.2
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Klíčová slova: 
kbmt kbwinservds kbactivedirectory kbfix kbprb kberrmsg KB836429 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:836429

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com