Article ID: 836432 - Last Review: November 27, 2007 - Revision: 2.10

Large MIF hardware inventory files process slowly in Systems Management Server 2.0

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SYMPTOMS

The Dataloader component on a Microsoft Systems Management Server (SMS) 2.0 site may process large Management Information Format (MIF) inventory files slowly.

You may especially notice this delay when the client already exists in the database. For example, a MIF inventory file that is as large as one megabyte may take several minutes to process. However, if the client's inventory is not in the database, perhaps because it is a new client, the one-megabyte MIF file may process in seconds.

CAUSE

This problem may occur if the MIF files contain many references to a particular inventory group. The inventory process slows when SMS determines the client data that it will delete from the current inventory record in the database and the data that it will store as history for the client. The data comparison can be very slow when the MIF contains large numbers of inventory items for the same inventory group class.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have SMS 2.0 Service Pack 5 installed to apply this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   25-Feb-2003  19:15  2.0.1493.5187   1,630,624  Basesvr.dll 

Installation information

To apply this hotfix, follow these steps:
  1. Create a folder that is accessible to your SMS site servers.
  2. Copy the SMS2.0-SP5-KB836432-X86-ENU.exe update file to the new folder.
  3. From each SMS primary and secondary site server in your environment, log on as an administrator.
  4. Quit the SMS Administrator console if it is running.
  5. Run the SMS2.0-SP5-KB836432-X86-ENU.exe update file, and then follow the instructions that are on the screen.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about standard terminology used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

This hotfix implements an optimization for inventory group classes where the no history property has been set. Only groups that have been created by either modifying the SMS_DEF.MOF or through the collection of NOID MIF files on the client can be modified in this way.

When you define the no history property for an inventory group, MIF processing can increase substantially, particularly when the inventory group contains fifty to several hundred instances of the group class.

To configure the no history property on an inventory group class, follow these steps:
  1. Use the Delete Group Class utility (Delgrp.exe) from the SMS 2003 Toolkit 1. To download the SMS 2003 Toolkit, visit the following Microsoft Web site:
    http://technet.microsoft.com/en-us/sms/bb676787.aspx (http://technet.microsoft.com/en-us/sms/bb676787.aspx)
  2. Copy the Delgrp.exe file to a folder on the SMS site server computer.
  3. Click Start, point to Administrative Tools, and then click Services.
  4. Stop the SMS Site Component Manager service and the SMS Executive service.
  5. Click Start, and then click Run.
  6. Type cmd, and then click OK.
  7. Change to the folder where you copied the Delgrp.exe file in step 2.
  8. To view a list of the group classes that you can modify or delete, type DelGrp.exe /L, and then press ENTER.
  9. After you identify the group where you want to configure the no history property, type Delgrp group /H, where group is the group that you want to modify, and then press ENTER. For example, type Delgrp.exe "COMPANY|CUSTOM_CLASS|1.0" /H, and then press ENTER.
  10. From SQL Query Analyzer, with the focus on the SMS database, run the following query:
    update GroupMap set HistoryTableName = '' where HistoryTableName is NULL and GroupName = 'Inventory group name'
  11. Start the SMS Site Component Manager service and the SMS Executive service.
You cannot use the Delete Group Class tool to modify or delete the following default inventory classes:
MICROSOFT|ADD_REMOVE_PROGRAMS|1.0
MICROSOFT|PC_BIOS|1.0
MICROSOFT|CDROM|1.0
MICROSOFT|COMPUTER_SYSTEM|1.0
MICROSOFT|DESKTOP_MONITOR|1.0
MICROSOFT|DISK|1.0
MICROSOFT|IDE_CONTROLLER|1.0
MICROSOFT|KEYBOARD_DEVICE|1.0
MICROSOFT|LOGICAL_DISK|1.0
MICROSOFT|X86_PC_MEMORY|1.0
MICROSOFT|MODEM_DEVICE|1.0
MICROSOFT|MOTHERBOARD_DEVICE|1.0
MICROSOFT|NETWORK_ADAPTER|1.0
MICROSOFT|NETWORK_ADAPTER_CONFIGURATION|1.0
MICROSOFT|NETWORK_CLIENT|1.0
MICROSOFT|OPERATING_SYSTEM|1.0
MICROSOFT|PARALLEL_PORT|1.0
MICROSOFT|PARTITION|1.0
MICROSOFT|POINTING_DEVICE|1.0
MICROSOFT|PROCESSOR|1.0
MICROSOFT|SCSI_CONTROLLER|1.0
MICROSOFT|SERVICE|1.0
MICROSOFT|PATCHSTATE|1.0
MICROSOFT|SOUND_DEVICE|1.0
SYSTEM
MICROSOFT|SYSTEM_ENCLOSURE|1.0
MICROSOFT|TAPE_DRIVE|1.0
MICROSOFT|USB_CONTROLLER|1.0
MICROSOFT|VIDEO_CONTROLLER|1.0
MICROSOFT|WORKSTATION_STATUS|1.0

APPLIES TO
  • Microsoft Systems Management Server 2.0 Standard Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbsms200presp6fix kbperformance kbinventory kbfix kbbug KB836432
 

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