Help and Support

Article ID: 836553 - Last Review: July 24, 2007 - Revision: 6.7

A backlog in schedule.box slows performance and delays site-to-site communication in SMS

Hotfix download is availableHotfix Download Available
View and request hotfix downloads

On This Page

Expand all | Collapse all

SYMPTOMS

In large Microsoft Systems Management Server (SMS) hierarchies with many primary and secondary sites, the SMS Scheduler component may slow down or pause on the primary site. In this scenario, the Schedule.box folder may become backlogged with job files.

CAUSE

This problem occurs when the SMS Scheduler component becomes backlogged from trying to clean up completed jobs and from sending requests that are used for site-to-site communication. In this scenario, it is very difficult for the Scheduler component to work through the backlog of jobs even after the job-creation rate returns to standard levels. The main factors that contribute to job backlogs include the following:
  • The distribution of large software packages.
  • An SMS hierarchy that includes offline sites.

    Note In a large SMS hierarchy, the SMS primary site does not have an address for a third-tier SMS site or cannot communicate with a third-tier SMS site.
  • Restrictive bandwidth-utilization policies -- for example, outbox scheduling or the use of bandwidth controls in the SMS site.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Systems Management Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
885643  (http://support.microsoft.com/kb/885643/ ) How to obtain the latest Systems Management Server 2003 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
SMS 2.0 English download file:
   Date         Time   Version         Size      File name
   -----------------------------------------------------------------------------
   12-Mar-2004  21:48  2.0.1493.5188  1,231,080  Sms2.0-sp5-kb836553-x86-enu.exe
SMS 2.0 English install file:
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   25-Feb-2003  20:20  2.0.1493.5188  1,632,672  Basesvr.dll

SMS 2.0 International Client Pack 1 (ICP1) download file:
   Date         Time   Version        Size       File name
   ------------------------------------------------------------------------------
   12-Mar-2004  21:48  2.0.1493.5188  1,230,056  Sms2.0-sp5-kb836553-x86-icp1.exe
SMS 2.0 International Client Pack 1 (ICP1) install file:
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   25-Feb-2003  20:20  2.0.1493.5188  1,632,672  Basesvr.dll

SMS 2.0 International Client Pack 4 (ICP4) download file:
   Date         Time   Version        Size       File name
   ------------------------------------------------------------------------------
   12-Mar-2004  21:48  2.0.1493.5188  1,229,032  Sms2.0-sp5-kb836553-x86-icp4.exe
SMS 2.0 International Client Pack 4 (ICP4) install file:
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   25-Feb-2003  20:20  2.0.1493.5188  1,632,672  Basesvr.dll

SMS 2.0 International Client Pack 5 (ICP5) download file:
   Date         Time   Version        Size       File name
   ------------------------------------------------------------------------------
   12-Mar-2004  21:48  2.0.1493.5188  1,229,032  Sms2.0-sp5-kb836553-x86-icp5.exe
SMS 2.0 International Client Pack 5 (ICP5) install file:
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   25-Feb-2003  20:20  2.0.1493.5188  1,632,672  Basesvr.dll

SMS 2003 English download file:
   Date         Time   Version        Size       File name
   ------------------------------------------------------------------------------
   13-May-2004  13:24  2.50.2726.132  1,149,160  Sms2003-rtm-kb836553-x86-enu.exe
SMS 2003 English install file:
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   25-Dec-2003  09:35  2.50.2726.132  1,740,800  Basesvr.dll

SMS 2003 International Client Pack 1 (ICP1) download file:
   Date         Time   Version        Size       File name
   -------------------------------------------------------------------------------
   13-May-2004  13:24  2.50.2726.132  1,149,160  Sms2003-rtm-kb836553-x86-icp1.exe
SMS 2003 International Client Pack 1 (ICP1) install file:
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   25-Dec-2003  09:35  2.50.2726.132  1,740,800  Basesvr.dll

SMS 2003 International Client Pack 2 (ICP2) download file:
   Date         Time   Version        Size       File name
   -------------------------------------------------------------------------------
   13-May-2004  13:24  2.50.2726.132  1,149,160  Sms2003-rtm-kb836553-x86-icp2.exe
SMS 2003 International Client Pack 2 (ICP2) install file:
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   25-Dec-2003  09:35  2.50.2726.132  1,740,800  Basesvr.dll

SMS 2003 (post-SP1) English download file:
   Date         Time   Version         Size     File name
   -----------------------------------------------------------------------------
   30-Nov-2004  21:33  2.50.3174.1108  786,664  Sms2003-sp1-kb836553-x86-enu.exe
SMS 2003 (post-SP1) English install file:
   Date         Time   Version         Size       File name
   ----------------------------------------------------------
   20-Oct-2004  08:40  2.50.3174.1108  1,765,376  Basesvr.dll

SMS 2003 International Client Pack 1 (post-SP1) download file:
   Date         Time   Version        Size       File name
   -------------------------------------------------------------------------------
   30-Nov-2004  21:33  2.50.3174.1108  787,176  Sms2003-sp1-kb836553-x86-icp1.exe
SMS 2003 International Client Pack 1 (post-SP1) install file:
   Date         Time   Version         Size       File name
   ----------------------------------------------------------
   20-Oct-2004  08:40  2.50.3174.1108  1,765,376  Basesvr.dll

SMS 2003 International Client Pack 2 (post-SP1) download file:
   Date         Time   Version        Size       File name
   -------------------------------------------------------------------------------
   30-Nov-2004  21:33  2.50.3174.1108  787,688  Sms2003-sp1-kb836553-x86-icp2.exe
SMS 2003 International Client Pack 2 (post-SP1) install file:
   Date         Time   Version         Size       File name
   ----------------------------------------------------------
   20-Oct-2004  08:40  2.50.3174.1108  1,765,376  Basesvr.dll

Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

Installation information

  1. Create a shared folder that can be accessed by all the site servers in your SMS hierarchy.
  2. Copy the Version-KB836553-X86-Language.exe update file to the new folder.
  3. From each SMS primary and secondary site server in your environment, use an account that has administrative credentials.
  4. Close the SMS Administrator console if it is open.
  5. On each primary and secondary site server, connect to the shared folder that contains the hotfix, double-click Version-KB836553-X86-Language.exe, and then follow the instructions in the SMS Update Wizard.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Systems Management Server 2003 Service Pack 2.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
To improve scalability and backlog-processing of the Scheduler component in SMS, the following changes are implemented after you install this hotfix:
  • The life cycle of a job is reduced by 25 percent.
  • Completed jobs and send requests are deleted sooner.
  • The handling of send requests by the Scheduler component is more efficient because the process now uses less processor resources and less disk I/O.
  • The Scheduler component cleanup process no longer runs every hour. Instead, this process now runs every 12 hours and after each complete work cycle.

APPLIES TO
  • Microsoft Systems Management Server 2.0 Standard Edition
  • Microsoft Systems Management Server 2003
  • Microsoft Systems Management Server 2003 Service Pack 1
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbsms200presp6fix kbfix kbbug KB836553

Article Translations