Article ID: 836606 - Last Review: July 24, 2007 - Revision: 3.10

"This program is currently not available" error when you try to manually run an advertised program in Systems Management Server 2003

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SYMPTOMS

After you log on to a Microsoft Systems Management Server (SMS) 2003 Advanced Client, mandatory assignment and other advertised programs do not run.

If you use the Run Advertised Programs tool in Control Panel to manually start the advertised program, you receive the following error message:
This program is currently not available. For more information, please contact your administrator or helpdesk operator.

CAUSE

This problem may occur when the following conditions are true:
  • You turn on the Run logon scripts synchronously policy in your Microsoft Windows 2000 Server-based domain.
  • On the Environment tab of the program properties, you set the Only when a user is logged on option for packages.
  • The user logon scripts take over a minute to complete.
To determine if Run logon scripts synchronously is turned on in your domain, follow these steps:
  1. Click Start, point to Programs, point to Administrative Tools, and then click Active Directory Users and Computers.
  2. Right-click your domain, and then click Properties.
  3. On the Group Policy tab, click Default Domain Policy, and then click Edit.
  4. Expand User Configuration\Administrative Templates\System, and then click Logon to view the policies.

    Note For a Windows Server 2003-based domain, expand User Configuration\Administrative Templates\System, and then click Scripts to view the policies.

RESOLUTION

Important Advertisement status for this hotfix may be reported incorrectly if you have distributed additional Advanced client hotfixes. For more information, view the following article in the Microsoft Knowledge Base:
840864  (http://support.microsoft.com/kb/840864/ ) Incorrect status is returned after you distribute an update for the Advanced Client in Systems Management Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

English download file:
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Mar-2004  08:23  2.50.2726.118   5,531,368  Sms2003-rtm-kb836606-x86-enu.exe 
Installed files:
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Mar-2004  12:46                     13,255  Filemap.ini
   20-Feb-2004  08:03  2.0.6.7           355,242  Smsupdate.exe    
   25-Dec-2003  00:30  2.50.2726.118     288,768  Ccmcore.dll      
   05-Aug-2000  23:51  2000.80.194.0     274,489  Ntwdblib.dll     
   23-Feb-2003  00:05  2.0.1493.5011     855,312  Preinst.exe
   25-Dec-2003  01:30                  6,449,664  Mp.msi      
   25-Dec-2003  00:30                    468,480  Sms2003ac-kb836606-x86.msp
International Client Pack 1 (ICP1) download file:
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Apr-2004  11:12  2.50.2726.118   5,456,104  Sms2003-rtm-kb836606-x86-icp1.exe
ICP1 installed files:
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Mar-2004  12:46                     13,255  Filemap.ini
   19-Mar-2004  12:46                        179  Smslang.ini
   20-Feb-2004  08:03  2.0.6.7           355,242  Smsupdate.exe    
   25-Dec-2003  00:30  2.50.2726.118     288,768  Ccmcore.dll      
   05-Aug-2000  23:51  2000.80.194.0     274,489  Ntwdblib.dll     
   23-Feb-2003  00:05  2.0.1493.5011     855,312  Preinst.exe
   25-Dec-2003  01:30                  6,449,664  Mp.msi      
   25-Dec-2003  00:30                    468,480  Sms2003ac-kb836606-x86.msp
International Client Pack 2 (ICP2) download file:
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Apr-2004  11:12  2.50.2726.118   5,457,640  Sms2003-rtm-kb836606-x86-icp2.exe 
ICP2 installed files:
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Mar-2004  12:46                     13,255  Filemap.ini
   19-Mar-2004  12:46                        179  Smslang.ini
   20-Feb-2004  08:03  2.0.6.7           355,242  Smsupdate.exe    
   25-Dec-2003  00:30  2.50.2726.118     288,768  Ccmcore.dll      
   05-Aug-2000  23:51  2000.80.194.0     274,489  Ntwdblib.dll     
   23-Feb-2003  00:05  2.0.1493.5011     855,312  Preinst.exe
   25-Dec-2003  01:30                  6,449,664  Mp.msi      
   25-Dec-2003  00:30                    468,480  Sms2003ac-kb836606-x86.msp

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Systems Management Server 2003
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbadvertisement kbpackage kbcpapplet kbclient kberrmsg kbsmstopazfix kbpolicy kbuser kbsoftwaredist kbfix kbbug KB836606
 

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