Article ID: 836723 - Last Review: August 5, 2009 - Revision: 2.0

Some address lists may be missing when you use Outlook 2003 in Cached Exchange Mode

On This Page

Expand all | Collapse all

SYMPTOMS

If you click the Show Names from the list in the Address Book dialog box while using Microsoft Office Outlook 2003 in Cached Exchange Mode, some of your address lists may be missing, and you cannot select the address list that you want.

Note When you turn off Cached Exchange Mode and then restart Outlook 2003, all your address lists appear in the Show Names from the list in the Address Book dialog box.

CAUSE

This problem occurs if the following conditions are true:
  • You use Outlook 2003 in Cached Exchange Mode.
  • You have one thousand or more address lists in the address book.

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you installed the latest Microsoft Office 2003 service pack, you do not have to install the hotfix.

Service pack information

This problem is corrected in Microsoft Office 2003 Service Pack 1 (SP1).
To resolve this problem, obtain the latest service pack for Microsoft Office 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
870924  (http://support.microsoft.com/kb/870924/ ) How to obtain the latest service pack for Office 2003

Hotfix information

How to obtain the hotfix

This issue is fixed in the Outlook 2003 Hotfix Package that is dated May 20, 2004. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
834716  (http://support.microsoft.com/kb/834716/ ) Description of the Outlook 2003 hotfix package: May 20, 2004

After you install this hotfix, follow the steps that are listed in the "More Information" section of this article to set the CacheRowsLimit registry key and to activate the hotfix.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Office 2003 Service Pack 1.

MORE INFORMATION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows


To activate this hotfix, follow these steps:
  1. Quit Outlook 2003.
  2. Click Start, and then click Run.
  3. In the Open box, type regedit, and then click OK.
  4. Locate and then click to select one of the following registry subkeys:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\Cached Mode

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\11.0\Outlook\Cached Mode
  5. After you select one of the subkeys that are specified in step 4, point to New on the Edit menu, and then click DWORD Value.
  6. Type CacheRowsLimit, and then press ENTER.
  7. Right-click CacheRowsLimit, and then click Modify.
  8. In the Value data box, type a number that is equal to or greater than the number of address books that you use (for example, if you use 1,200 lists in the address books, type 1,200 or greater), and then click OK.
  9. Repeat steps 5 through 8 for the other subkey that is listed in step 4.
  10. On the File menu, click Exit to quit Registry Editor.
To turn off Cached Exchange Mode in Outlook 2003, follow these steps:
  1. Start Outlook 2003.
  2. On the Tools menu, click E-mail Accounts.
  3. Click View or change existing e-mail accounts, and then click Next.
  4. Click your Exchange server, and then click Change.
  5. In the E-mail Accounts dialog box, click to clear the Use Cached Exchange Mode check box under Microsoft Exchange Server.
  6. Click Next.
  7. Click OKwhen you receive the following message:
    The operation you selected will not complete until you choose Exit from the file menu, and then restart Microsoft Office Outlook.
  8. Click Finish to close the E-mail Accounts dialog box.
  9. Click Exit on the File menu, and then restart Outlook 2003.

APPLIES TO
  • Microsoft Office Outlook 2003
Keywords: 
kboffice2003sp1fix kbaddressbook kbqfe kbbug kbfix KB836723
 

Article Translations

 

Related Support Centers