Article ID: 836767 - Last Review: October 26, 2006 - Revision: 3.5

Data is not completely written to files that are located on a network share after you set the attributes of the files in Windows XP Service Pack 1 (SP1)

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SYMPTOMS

On your Microsoft Windows XP Service Pack 1 (SP1)-based computer, if you use the WriteFile function to write data to a file that is located on a network share, and then you set the attributes of the file by using the SetFileAttributes function, you notice the following symptoms:
  • Not all data is written to the file. The size of the file that is located on the network share is smaller than you expected.
  • You do not receive an error message, and no error messages are logged to the event log.
  • If you perform a Network Monitor trace of the operation, the size of the file is truncated to the same size that is returned to the CreateAndX request in the Windows XP Server Message Block (SMB) packet.
  • You may not be able to open, to rotate, or to view the file on the network share by using the Microsoft Office Document Imaging program.

CAUSE

This problem occurs in situations where SMB incorrectly processes multiple open operations of the file.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/EN-US/ ) How to obtain the latest Windows XP service pack

Hotfix information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/ ) How to obtain the latest Windows XP service pack
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition SP1
Keywords: 
kbautohotfix kbhotfixserver kbwinxpsp2fix kbqfe kbfix kbbug KB836767