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Id. de artículo: 836941 - Última revisión: martes, 30 de septiembre de 2008 - Versión: 23.1

Puede encontrar errores temporales relacionados con la conexión cuando usa Windows Update o Microsoft Update para instalar actualizaciones

Importante: este artículo contiene información que muestra cómo reducir la configuración de seguridad o cómo desactivar las opciones de seguridad en un equipo. Puede realizar estos cambios para solucionar temporalmente un problema concreto. Pero antes de realizarlos, recomendamos que evalúe los riesgos asociados a esta solución temporal en su entorno concreto. Si decide implementar esta solución temporal, tome las medidas adicionales oportunas para ayudar a proteger el equipo.

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Introducción

Al utilizar el sitio web Windows Update o el sitio web Microsoft Update para comprobar las actualizaciones que hay e instalarlas, puede recibir uno de los errores enumerados en la sección "Síntomas".

Importante: en la mayoría de los casos, estos mensajes son problemas temporales o breves, producidos por interrupciones muy ligeras en las comunicaciones entre el equipo que está actualizando y los servidores de actualización de Windows. Estos problemas generalmente se autorreparan. Por tanto, antes de probar los métodos de solución de problemas de este artículo, salga del sitio Windows Update, espere de 10 a 15 minutos, inicie Windows Update de nuevo y, a continuación, compruebe las actualizaciones. También puede permitir que Actualización automática de Windows instale las actualizaciones en su ciclo habitual de 24 horas.

Nota: estos errores se pueden producir aunque no se hayan realizado cambios en la configuración de red.

Síntomas

Cuando usa el sitio web de Windows Update o Microsoft Update para comprobar las actualizaciones que hay e instalarlas, es posible que aparezca uno de los mensajes de error siguientes:
Contraer esta tablaAmpliar esta tabla
Error 0x80070008Error 0x800705B4
Error 0x8007000E Error 0x80072EE2
Error 0x80072EFD Error 0x80072EE7
Error 0x80072EFE Error 0x8024400E
Error 0x80072F76 Error 0x80244016
Error 0x80072F78 Error 0x80244022
Error 0x80090305 Error 0x8024402F
Error 0x8009033F Error 0xC80003FA
Error 0x80244008 Error 0xC800042D
Error 0x8024400A Error 0x80071A90
Error 0x8024400D
Para obtener información avanzada sobre los códigos de error individuales, vea la sección "Información adicional de códigos de error para usuarios avanzados".

Causa

Estos errores pueden deberse a cualquiera de los problemas siguientes:
  • Aplicaciones o procesos que interfieren con comunicaciones de Internet
  • Problemas de recursos en su equipo
  • Demasiada actividad en el sitio de la actualización
  • Actividad de Internet alta
  • Errores recuperables de la base de datos
  • Problemas de inactividad del servidor del sitio Windows Update o del sitio Microsoft Update

Solución

Si intentó salir de Windows Update, esperó de 10 a 15 minutos e inició de nuevo Windows Update, o si permitió que Actualizaciones automáticas de Windows instalara las actualizaciones durante su ciclo habitual de 24 horas, y el mensaje de error persiste, utilice los métodos siguientes, empezando por el método A, para resolver el problema.

Método A: comprobar la conectividad de Internet

Asegúrese de que puede tener acceso correctamente a otros sitios web. Si no puede tener acceso correctamente a otros sitios web, es posible que su conexión a Internet no funcione correctamente, por lo que quizá debería ponerse en contacto con su proveedor de acceso a Internet para obtener ayuda.

Si obtiene acceso correctamente a otros sitios web, continúe con el método B.

Método B: comprobar que Firewall de Windows está activado y deshabilitar temporalmente los servidores de seguridad de otro fabricante

Advertencia: esta solución temporal puede hacer que un equipo o una red sean más vulnerables a los ataques de usuarios malintencionados o de software malintencionado, como los virus. No recomendamos esta solución temporal, pero proporcionamos la información necesaria para que pueda decidir por sí mismo si la implementa. Utilice esta solución temporal bajo su responsabilidad.

Para completar este método, siga estos pasos.

Paso 1: comprobar que Firewall de Windows esté activado.

Para ello, en Windows Vista y en Windows Server 2008 siga estos pasos:
  1. Para abrir Firewall de Windows, haga clic en Inicio
    Contraer esta imagenAmpliar esta imagen
    botón Inicio
    , haga clic en Panel de control, en Seguridad y, a continuación, haga clic en Firewall de Windows.
  2. Haga clic en Activar o desactivar Firewall de Windows.

    Contraer esta imagenAmpliar esta imagen
    Permiso de Control de acceso de usuario
    Si se le pide la contraseña de administrador o su confirmación, escriba la contraseña o proporcione la confirmación.
  3. Haga clic en Activado (recomendado) y en Aceptar.
Para hacerlo en Windows 2000, Windows XP o Windows Server 2003, siga estos pasos:
  1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
  2. Copie y pegue (o escriba) el comando siguiente en el cuadro Ejecutar y presione ENTRAR:
    firewall.cpl
  3. En la ficha General, compruebe que Activado (recomendado) está seleccionado y, a continuación, haga clic en Aceptar.

Paso 2: deshabilitar temporalmente los servidores de seguridad de otros fabricantes

Para ello, en Windows Vista y en Windows Server 2008 siga estos pasos:
  1. Haga clic en Inicio
    Contraer esta imagenAmpliar esta imagen
    botón Inicio
    y haga clic en Panel de control.
  2. Haga clic en Seguridad y, a continuación, haga clic en Centro de seguridad.

    Contraer esta imagenAmpliar esta imagen
    Permiso de Control de acceso de usuario
    Si se le pide la contraseña de administrador o su confirmación, escriba la contraseña o proporcione la confirmación.

    Nota: seleccione Ventana principal del Panel de control en el panel de navegación del lado izquierdo si todavía no está seleccionada esta opción.
  3. En Firewall, lea la nota de estado del firewall. Esta información indicará si hay un firewall instalado y si está activado. Por ejemplo, para ZoneAlarm, el aviso dirá El firewall de ZoneAlarm está activado actualmente. Habrá también un botón verde Activado en la esquina del lado derecho de la sección de firewall que indica que el firewall se está ejecutando actualmente.
  4. Abra la aplicación de firewall de otro fabricante que se enumera en la nota de estado del firewall y deshabilite temporalmente ese firewall. Si es necesario, consulte la documentación de la aplicación de firewall o póngase en contacto con el proveedor de la aplicación para obtener más información acerca de cómo deshabilitar la aplicación temporalmente.
Para hacerlo en Windows 2000, Windows XP o Windows Server 2003, seleccione una de las opciones siguientes:
  • Consulte la documentación que se incluía con el programa.
  • Vea los archivos de Ayuda para su programa.
  • Póngase en contacto con el proveedor del programa. Para obtener más información acerca de cómo ponerse en contacto con el proveedor del programa, visite el siguiente sitio web de Microsoft:
    http://support.microsoft.com/gp/vendors (http://support.microsoft.com/gp/vendors)

Paso 3: tratar de instalar de nuevo las actualizaciones

Si este método resolvió el problema, siga los pasos del método B, paso 2 para rehabilitar su firewall de otro fabricante. Es posible que también desee comprobar cualquier actualización necesaria para su firewall de otro fabricante con el fin de instalarla.

Si este método no resolviera su problema, continúe con el método C.

Método C: deshabilitar temporalmente el software antivirus de otro fabricante

Advertencia: esta solución temporal puede hacer que un equipo o una red sean más vulnerables a los ataques de usuarios malintencionados o de software malintencionado, como los virus. No recomendamos esta solución temporal, pero proporcionamos la información necesaria para que pueda decidir por sí mismo si la implementa. Utilice esta solución temporal bajo su responsabilidad.

Nota: si su firewall de otro fabricante todavía está deshabilitado tras el método B, no abra los mensajes de correo electrónico, ni navegue por Internet ni use un programa de mensajería instantánea.

Paso 1: buscar y deshabilitar temporalmente su software antivirus de otro fabricante

Nota: Windows no detecta todo el software antivirus y algunos programas de software antivirus no notifican su estado a Windows. Si su software antivirus no se muestra en el Centro de seguridad de Windows, y no está seguro de cómo buscarlo, pruebe alguna de las acciones siguientes:
  • Busque el software antivirus en la lista de programas del menú Inicio.
  • Escriba el nombre del software o su editor en el cuadro Buscar del menú Inicio.
  • Busque el icono en el área de notificación en el extremo derecho de la barra de tareas.
Para ello, en Windows Vista y en Windows Server 2008 siga estos pasos:
  1. Haga clic en Inicio
    Contraer esta imagenAmpliar esta imagen
    botón Inicio
    y, a continuación, copie y pegue (o escriba) el comando siguiente en el cuadro de texto Iniciar búsqueda:
    wscui.cpl
  2. En la lista de programas, haga clic en wscui.cpl.
  3. En la ventana Seguridad de Windows, haga clic en Protección contra malware.

    Nota: si Windows puede detectar su software antivirus, lo enumerará bajo Protección antivirus.
  4. Si el software está activado, compruebe la documentación de la Ayuda que se incluía con el software para obtener información acerca de cómo deshabilitarlo.
Para hacerlo en Windows 2000, Windows XP o Windows Server 2003, siga estos pasos:
  1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
  2. Copie y pegue (o escriba) el comando siguiente en el cuadro Ejecutar y presione ENTRAR:
    wscui.cpl
  3. En la ventana Seguridad de Windows, haga clic en Protección antivirus.
  4. Si el software está activado, vea la información acerca de la aplicación antivirus y anote el nombre de la aplicación.
  5. Haga clic en Inicio, haga clic en Todos los Programas y, a continuación, vaya a la aplicación antivirus e iníciela.
  6. Deshabilitar temporalmente el software.

    Nota: quizá tenga que mirar en la documentación de la aplicación para determinar cómo hacerlo.

Paso 2: comprobar Windows Updates

En cuanto el software antivirus esté deshabilitado temporalmente, visite Windows Update o Microsoft Update de nuevo e intente descargar e instalar las actualizaciones.

Si este método resolvió su problema, y pudo instalar las actualizaciones correctamente, debería rehabilitar su software antivirus de otro fabricante. Para ello, utilice el paso 2 del método B.

Si este método no resolvió su problema, continúe con el método D.

Método D: deshabilitar los programas de aceleración mediante software

Deshabilite los programas de aceleración mediante software que se puedan estar ejecutando. Algunos ejemplos de estos programas son los aceleradores de descarga de archivos y los aceleradores de velocidad de Internet.

Nota: si su firewall de otro fabricante todavía está deshabilitado tras el método B, no abra los mensajes de correo electrónico, ni navegue por Internet ni use un programa de mensajería instantánea.

Paso 1: deshabilitar los programas de aceleración mediante software

Para ello, seleccione entre las opciones siguientes:
  • Consulte la documentación que se incluía con el programa.
  • Vea los archivos de Ayuda para su programa.
  • Póngase en contacto con el proveedor del programa. Para obtener más información acerca de cómo ponerse en contacto con el proveedor del programa, visite el siguiente sitio web de Microsoft:
    http://support.microsoft.com/gp/vendors (http://support.microsoft.com/gp/vendors)

Paso 2: instalar las actualizaciones

En cuanto el programa de aceleración mediante software esté deshabilitado, visite Windows Update o Microsoft Update de nuevo e intente descargar e instalar las actualizaciones.

Si este método resolvió su problema, debería habilitar los programas de aceleración mediante software que deshabilitó en el paso 1.

Si este método no resolvió su problema, continúe con el método E.

Método E: agregar el sitio web de Windows Update y el sitio web de Microsoft Update a la lista de sitios de confianza

Nota: si su firewall de otro fabricante todavía está deshabilitado tras el método B, no abra los mensajes de correo electrónico, ni navegue por Internet ni use un programa de mensajería instantánea.

Para agregar el sitio web de Windows Update y el sitio web de Microsoft Update a la lista de sitios de confianza, siga estos pasos:
  1. Inicie Windows Internet Explorer.
  2. En el menú Herramientas, haga clic en Opciones de Internet.

    Nota: si está utilizando Internet Explorer 7, y el menú no está disponible, presione la tecla ALT en su teclado para tener acceso al menú Internet Explorer.
  3. Haga clic en la ficha Seguridad y, después, en Sitios de confianza.
  4. Haga clic en Sitios y después desactive la casilla Requerir comprobación del servidor (https:) para todos los sitios de esta zona.
  5. En el cuadro Agregar este sitio Web a la zona, escriba todas las direcciones siguientes y haga clic en Agregar después de escribir cada dirección:
    • http://update.microsoft.com
    • http://windowsupdate.microsoft.com
  6. Haga clic dos veces en Aceptar.
  7. Intente instalar de nuevo las actualizaciones.
Si este método resolvió su problema y pudo instalar las actualizaciones correctamente, debería rehabilitar su firewall de otro fabricante si todavía está deshabilitado. Para ello, utilice el paso 2 del método B.

Si este método no resolvió su problema, continúe con el método F.

Método F: comprobar que tiene instalada la actualización más reciente del Servicio de transferencia inteligente en segundo plano (BITS)

Nota: si su firewall de otro fabricante todavía está deshabilitado tras el método B, no abra los mensajes de correo electrónico, ni navegue por Internet ni use un programa de mensajería instantánea.

Para obtener más información acerca de cómo asegurarse de que tiene instalada la actualización más reciente del Servicio de transferencia inteligente en segundo plano (BITS), haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
842773   (http://support.microsoft.com/kb/842773/ ) Hay un paquete de actualización que incluye BITS 2.0 y WinHTTP 5.1 disponible para Windows Server 2003, para Windows XP y para Windows 2000
Si este método funcionó y pudo instalar las actualizaciones correctamente, ya lo ha solucionado. Sin embargo, si su firewall de otro fabricante todavía está deshabilitado desde el método B, debería rehabilitarlo ahora. Para ello, utilice el paso 2 del método B.

Si este método no funcionó, y se siente cómodo con la solución de problemas avanzada, pruebe los pasos de la sección "Solución de problemas avanzada".

Si no se siente cómodo con la solución de problemas avanzada, desgraciadamente este contenido no le será de más ayuda. Para sus siguientes pasos, quizás desee pedir ayuda a alguien o ponerse en contacto con el Servicio de soporte técnico. Para ello, visite el siguiente sitio web de Microsoft:
http://support.microsoft.com/contactus/ (http://support.microsoft.com/contactus/)

Más información

Los métodos de solución de problemas y otras informaciones de la sección siguiente están pensados para los usuarios avanzados o para los usuarios que están en un entorno corporativo que actualmente utiliza archivos hosts y servidores proxys.

Métodos de solución de problemas avanzada

Método avanzado A: quite las entradas de Windows Update y Microsoft Update del archivo hosts

Algunos programas pueden modificar el archivo hosts para controlar la resolución de nombres DNS. A veces, puede haber una entrada para el sitio web de Windows Update o para el sitio web de Microsoft Update en el archivo hosts.

Para quitar estas entradas del archivo hosts, siga estos pasos:
  1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
  2. Copie y pegue (o escriba) el comando siguiente en el cuadro Ejecutar y presione ENTRAR:
    notepad %windir%\system32\drivers\etc\hosts
    Nota: si se le pide que elija un programa con el que abrir el archivo hosts, haga clic en Bloc de notas, haga clic en la opción Utilizar siempre el programa seleccionado para abrir este tipo de archivos para seleccionarla y, a continuación, haga clic en Aceptar.
  3. En el Bloc de notas, quite o marque como comentario las líneas del archivo hosts que contengan entradas para Windows Update con objeto de que no se lean al tener acceso al archivo. Para ello, ponga el carácter de almohadilla (#) delante de las líneas que contengan "microsoft" y "update". Por ejemplo, agregue el carácter de almohadilla (#) al principio de las siguientes entradas:
    • # 64.4.21.125 http://update.microsoft.com
    • # 64.4.21.125 http://windowsupdate.microsoft.com
    • # http://update.microsoft.com
  4. En el menú Archivo haga clic en Guardar.
  5. Cierre el Bloc de notas.
  6. Reinicie el equipo.

    Nota: si no desea reiniciar el equipo, también puede vaciar la caché de resolución DNS. Para ello, siga estos pasos:
    1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
    2. En el cuadro Ejecutar, escriba cmd y presione ENTRAR.
    3. En el símbolo del sistema, escriba ipconfig /flushdns y presione ENTRAR.

Método avanzado B: quite la entrada del servidor proxy de la configuración de servidor proxy de WinHTTP

Nota: este método solamente se aplica a los usuarios de Windows XP y Windows Server 2003. No se aplica a los usuarios de Windows Vista 2000.

Para quitar la entrada del servidor proxy de la configuración de servidor proxy de WinHTTP, siga estos pasos:
  1. Abra Internet Explorer.
  2. En el menú Herramientas, haga clic en Opciones de Internet.
  3. Haga clic en la ficha Conexiones y, después, en Configuración de LAN.
  4. En el cuadro de diálogo Configuración de LAN, haga clic en la casilla Detectar la configuración automáticamente para activarla y, a continuación, haga clic en Aceptar.
  5. Salga de Internet Explorer.
  6. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
  7. Copie y pegue (o escriba) el comando siguiente en el cuadro Ejecutar y presione ENTRAR:
    cmd
  8. Escriba los comandos siguientes. Presione ENTRAR después de cada comando.
    1. proxycfg -d
    2. net stop wuauserv
    3. net start wuauserv
    4. exit
  9. Regrese a Windows Update o a Microsoft Update e intente descargar e instalar las actualizaciones de nuevo.

Método avanzado C: ver cómo el cliente de Windows Update detecta y utiliza los servidores proxy

Para usuarios corporativos y del servidor proxy

Si es un usuario corporativo o está detrás de un servidor proxy, vea el artículo siguiente de Microsoft Knowledge Base (KB) para obtener información acerca de cómo el cliente de Windows Update detecta y utiliza los servidores proxy:
900935  (http://support.microsoft.com/kb/900935/ ) Cómo determina el cliente de Windows Update qué servidor proxy debe utilizarse para conectarse al sitio Web de Windows Update

Información adicional de código de error para usuarios avanzados

Contraer esta tablaAmpliar esta tabla
Código de error hexadecimal Código de error decimalDescripción de error de API
0x80070008-2147024888ERROR_NOT_ENOUGH_MEMORY
0x800705B4-2147023436Error_Timeout
0x8007000E-2147024882E_OUTOFMEMORY
0x80072EE2-2147012894ERROR_INTERNET_TIMEOUT
0x80072EFD-2147012867ERROR_INTERNET_CANNOT_CONNECT
0x80072EE7-2147012889ERROR_INTERNET_NAME_NOT_RESOLVED
0x80072EFE-2147012866ERROR_INTERNET_CONNECTION_ABORTED
0x8024400E-2145107954SUS_E_PT_SOAP_SERVER
0x80072F76-2147012746ERROR_WINHTTP_HEADER_NOT_FOUND
0x80244016-2145107946SUS_E_PT_HTTP_STATUS_BAD_REQUEST
0x80072F78-2147012744ERROR_WINHTTP_INVALID_SERVER_RESPONSE
0x80244022-2145107934SUS_E_PT_HTTP_STATUS_SERVICE_UNAVAIL
0x80090305-2146893051SEC_E_SECPKG_NOT_FOUND
0x8024402F-2145107921WU_E_PT_ECP_SUCCEEDED_WITH_ERRORS
0x8009033F-2146892993SEC_E_Shutdown_IN_Progress
0xC80003FA-939523078hrReadVerifyFailure
0x80244008-2145107960SUS_E_PT_SOAPCLIENT_PARSEFAULT
0xC800042D-939523027HrVersionStoreOutOfMemory
0x8024400A -2145107958SUS_E_PT_SOAPCLIENT_PARSE
0x80071A90-2147018096ERROR_TRANSACTIONAL_CONFLICT
0x8024400D-2145107955SUS_E_PT_SOAP_CLIENT

La información de este artículo se refiere a:
  • Microsoft Windows Update Corporate Edition 1.0
  • Microsoft Update
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