Pri použití služby Windows Update alebo Microsoft Update sa môžu vyskytnúť dočasné chyby súvisiace s pripojením

ID článku: 836941 - Zobraziť produkty, ktorých sa tento článok týka.
Ak ste zákazníkom z radu malých podnikov, ďalšie informácie týkajúce sa riešenia problémov a vzdelávania získate na lokalite podpory pre malé podniky.
Dôležité upozornenie: Tento článok obsahuje postupy, ktoré vedú k oslabeniu zabezpečenia počítača alebo k vypnutiu funkcií zabezpečenia v počítači. Vykonaním týchto zmien môžete vyriešiť špecifické problémy. Pred vykonaním zmien sa však odporúča vyhodnotiť riziká spojené s nasadením tohto riešenia v konkrétnom prostredí. Ak implementujete toto riešenie, vykonajte všetky zodpovedajúce dodatočné opatrenia na ochranu počítača.
Rozbaliť všetko | Zbaliť všetko

Úvod

Pri použití webovej lokality Windows Update alebo Microsoft Update na vyhľadanie a nainštalovanie aktualizácií sa môže zobraziť jedna z chýb uvedených v časti Príznaky.

Dôležité upozornenie: Vo väčšine prípadov sú tieto chyby spôsobené krátkymi prerušeniami komunikácie medzi aktualizovaným počítačom a preberanou aktualizáciou. Tieto problémy sa zvyčajne vyriešia samé od seba. Skôr než vyskúšate postupy na riešenie problémov uvedené v tomto článku, vyskúšajte jeden alebo oba nasledujúce kroky.
  • Ukončite službu Windows Update, počkajte 10 až 15 minút a potom znova spustite službu Windows Update a vyhľadajte aktualizácie.
  • Zapnite funkciu Automatické aktualizácie systému Windows tak, aby sa aktualizácie automaticky inštalovali každých 24 hodín.


Poznámka: Tieto chyby sa môžu vyskytovať aj v prípade, že ste nevykonali žiadne zmeny v nastavení siete.

Príznaky

Pri použití webovej lokality Windows Update alebo Microsoft Update na vyhľadanie a nainštalovanie aktualizácií môže byť v chybovom hlásení uvedený jeden z nasledujúcich kódov chyby:
Zbaliť túto tabuľkuRozbaliť túto tabuľku
0x800700080x800705B40x8007000E
0x80072EE20x80072EFD0x80072EE7
0x80072EFE0x8024400E0x80072F76
0x802440160x80072F780x80244022
0x800903050x8024402F0x8009033F
0xC80003FA0x802440080xC800042D
0x8024400A0x80071A900x8024400D

Ďalšie informácie o jednotlivých kódoch chýb nájdete v časti Ďalšie informácie o kódoch chýb pre pokročilých používateľov.

Príčina

Príčinou týchto chýb môže byť niektorý z nasledujúcich problémov:
  • programy alebo procesy, ktoré rušia internetovú komunikáciu,
  • problémy s prostriedkami v počítači,
  • vysoká internetová aktivita,
  • opraviteľné chyby databáz.

Riešenie

Ak sa chybové hlásenie zobrazuje aj po ukončení a opätovnom spustení služby Windows Update alebo po povolení funkcie Automatické aktualizácie systému Windows tak, aby sa aktualizácie automaticky inštalovali každých 24 hodín, vyriešte problém podľa nasledujúcich postupov.

Postup A: Overenie pripojenia na internet

Zbaliť tento obrázokRozbaliť tento obrázok
Ak nemôžete získať prístup k iným webovým lokalitám, je možné, že vaše pripojenie na internet nefunguje správne. Skontrolujte pripojenie na internet alebo požiadajte o pomoc svojho poskytovateľa internetových služieb.

Ak môžete získať prístup k iným webovým lokalitám, prejdite na postup B.
Zbaliť tento obrázokRozbaliť tento obrázok

Postup B: Kontrola, či je zapnutá brána Windows Firewall, a dočasné vypnutie brán firewall od iných výrobcov

Zbaliť tento obrázokRozbaliť tento obrázok

Upozornenie: Toto riešenie môže oslabiť zabezpečenie počítača alebo siete voči útokom zlomyseľných používateľov alebo nebezpečnému softvéru, ako sú napríklad vírusy. Toto riešenie sa neodporúča používať, ale chceme vás o ňom informovať, aby ste ho mohli použiť, ak to sami uznáte za vhodné. Toto riešenie používate na vlastné riziko.

Ak chcete dokončiť tento postup, postupujte podľa nasledujúcich krokov.
Krok 1: Kontrola, či je zapnutá brána Windows Firewall
Ak používate systém Windows 8, postupujte podľa nasledujúcich krokov:
  1. Otvorte bránu Windows Firewall tak, že potiahnete prstom z pravého okraja obrazovky, ťuknete na položku Vyhľadávanie (ak používate myš, ukážte do pravého horného rohu obrazovky, posuňte ukazovateľ myši nadol a kliknite na položku Vyhľadávanie), zadáte text firewall do vyhľadávacieho poľa, ťuknete alebo kliknete na položku Nastavenie a potom ťuknete alebo kliknete na položku Windows Firewall.
  2. Ťuknite alebo kliknite na položku Zapnúť bránu Windows Firewall pod každým typom siete, ktorú chcete zabezpečiť, a potom ťuknite alebo kliknite na tlačidlo OK.
Ak používate systém Windows 7 alebo Windows Server 2008 R2, postupujte podľa nasledujúcich krokov:
  1. Otvorte bránu Windows Firewall tak, že kliknete na tlačidlo Start
    Zbaliť tento obrázokRozbaliť tento obrázok
    Tlačidlo Start (Štart)
    (Štart), kliknete na položku Control Panel (Ovládací panel), kliknete na položku System and Security (Systém a zabezpečenie) a potom kliknete na položku Windows Firewall.
  2. Na ľavej table kliknite na položku Turn Windows Firewall on or off (Zapnúť alebo vypnúť bránu Windows Firewall).

    Zbaliť tento obrázokRozbaliť tento obrázok
    Povolenie kontroly používateľských kont
    Ak sa zobrazí výzva na zadanie hesla správcu alebo na potvrdenie, zadajte heslo alebo poskytnite potvrdenie.
  3. Uistite sa, že pre položku Home or work (private) network location settings (Nastavenia umiestnenia domácej alebo pracovnej (súkromnej) siete) aj pre položku Public network locations settings (Nastavenia umiestnenia verejnej siete) je vybratá možnosť Turn on Windows Firewall (Zapnúť bránu Windows Firewall) a potom kliknite na tlačidlo OK.
Video: Zapnutie brány Windows Firewall v systéme Windows 7 (video je v angličtine)

Zbaliť tento obrázokRozbaliť tento obrázok
uuid=606771cc-ac77-4deb-af3b-185690bd57ff VideoUrl=http://aka.ms/o2vkgq
Zbaliť tento obrázokRozbaliť tento obrázok



Ak používate systém Windows Vista alebo Windows Server 2008, postupujte podľa nasledujúcich krokov:
  1. Otvorte bránu Windows Firewall tak, že kliknete na tlačidlo Start
    Zbaliť tento obrázokRozbaliť tento obrázok
    Tlačidlo Start (Štart)
    (Štart), kliknete na položku Control Panel (Ovládací panel), kliknete na položku Security (Zabezpečenie) a potom kliknete na položku Windows Firewall.
  2. Kliknite na položku Turn Windows Firewall on or off (Zapnúť alebo vypnúť bránu Windows Firewall).

    Zbaliť tento obrázokRozbaliť tento obrázok
    Povolenie kontroly používateľských kont
    Ak sa zobrazí výzva na zadanie hesla správcu alebo na potvrdenie, zadajte heslo alebo poskytnite potvrdenie.
  3. Kliknite na možnosť On (recommended) (Zapnuté (odporúča sa)) a potom kliknite na tlačidlo OK.
Ak používate systém Windows 2000, Windows XP alebo Windows Server 2003, postupujte podľa nasledujúcich krokov:
  1. Kliknite na tlačidlo Start (Štart) a potom na položku Run (Spustiť).
  2. Skopírujte nasledujúci príkaz, prilepte ho do poľa Run (Spustiť) a potom stlačte kláves Enter:
    firewall.cpl
  3. Na karte General (Všeobecné) sa uistite, že je vybratá možnosť On (Recommended) (Zapnuté (odporúča sa)) a potom kliknite na tlačidlo OK.
Krok 2: Dočasné vypnutie brán firewall od iných výrobcov
Ak používate systém Windows 8, Windows 7 alebo Windows Server 2008 R2, použite jednu z nasledujúcich možností:Ak používate systém Windows Vista alebo Windows Server 2008, postupujte podľa nasledujúcich krokov:
  1. Kliknite na tlačidlo Start
    Zbaliť tento obrázokRozbaliť tento obrázok
    Tlačidlo Start (Štart)
    (Štart) a potom kliknite na položku Control Panel (Ovládací panel).
  2. Kliknite na položku Security (Zabezpečenie) a potom kliknite na položku Security Center (Centrum zabezpečenia).

    Zbaliť tento obrázokRozbaliť tento obrázok
    Povolenie kontroly používateľských kont
    Ak sa zobrazí výzva na zadanie hesla správcu alebo na potvrdenie, zadajte heslo alebo poskytnite potvrdenie.
  3. Ak na ľavej table nie je vybratá položka Control Panel Home (Ovládací panel – domovská stránka), vyberte ju.
  4. V časti Firewall (Brána firewall) si prečítajte informáciu o stave brány firewall. Táto informácia udáva, či je brána firewall nainštalovaná a či je zapnutá. Ak používate napríklad bránu ZoneAlarm, bude sa zobrazovať text ZoneAlarm Firewall is currently ON (Brána ZoneAlarm Firewall je momentálne ZAPNUTÁ). V pravom rohu časti okna brány firewall sa bude zobrazovať aj zelené tlačidlo On (Zapnuté), ktoré označuje, či je brána firewall momentálne zapnutá.
  5. Otvorte program brány firewall od iného výrobcu, ktorý je uvedený v informácii o stave, a dočasne ho vypnite. V prípade potreby si prečítajte dokumentáciu k programu brány firewall alebo sa obráťte na dodávateľa programu brány firewall a požiadajte ho o ďalšie informácie o postupe pri dočasnom vypnutí daného programu.
Ak používate systém Windows 2000, Windows XP alebo Windows Server 2003, vyberte jednu z nasledujúcich možností:
  • Prečítajte si dokumentáciu dodanú s programom.
  • Zobrazte si Pomocníka daného programu.
  • Obráťte sa na dodávateľa programu. Informácie o kontaktovaní dodávateľa programu získate na nasledujúcej webovej lokalite spoločnosti Microsoft:
Krok 3: Pokus o opätovnú inštaláciu aktualizácií
Ak sa vám pomocou tohto postupu podarí vyriešiť daný problém, postupujte podľa kroku 2 v postupe B na opätovné zapnutie brány firewall od iného výrobcu. Môžete tiež vyhľadať a nainštalovať všetky potrebné aktualizácie brány firewall od iného výrobcu.

Ak sa vám pomocou tohto postupu nepodarilo problém vyriešiť, prejdite na postup C.
Zbaliť tento obrázokRozbaliť tento obrázok

Postup C: Dočasné vypnutie antivírusového softvéru od iného výrobcu

Zbaliť tento obrázokRozbaliť tento obrázok

Upozornenie: Toto riešenie môže oslabiť zabezpečenie počítača alebo siete voči útokom zlomyseľných používateľov alebo nebezpečnému softvéru, ako sú napríklad vírusy. Toto riešenie sa neodporúča, no poskytujeme tieto informácie, pomocou ktorých môžete riešenie implementovať podľa vlastného uváženia. Toto riešenie používate na vlastné riziko.

Dôležité upozornenie: Ak je brána firewall od iného výrobcu stále vypnutá po vykonaní postupu B, dočasne neotvárajte e-mailové správy, neprehľadávajte web ani nepoužívajte softvér na výmenu okamžitých správ.
Krok 1: Vyhľadanie a dočasné vypnutie antivírusového softvéru od iného výrobcu
Poznámka: Systém Windows nedokáže zistiť všetky antivírusové softvéry, pričom niektoré antivírusové programy nehlásia systému Windows svoj stav. Ak váš antivírusový softvér nie je uvedený v okne Security Center (Centrum zabezpečenia) systému Windows a neviete, ako ho nájsť, skúste vykonať niektorý z nasledujúcich krokov:
  • V ponuke Start (Štart) vyhľadajte antivírusový softvér v zozname programov.
  • V ponuke Start (Štart) zadajte názov softvéru alebo vydavateľa do poľa Search (Vyhľadať).
  • Na pravej strane panela úloh vyhľadajte ikonu softvéru v oblasti oznámení.
Ak používate systém Windows 8, postupujte podľa nasledujúcich krokov:
  1. Otvorte ovládací panel tak, že potiahnete prstom z pravého okraja obrazovky, ťuknete na položku Vyhľadávanie (ak používate myš, ukážte do pravého horného rohu obrazovky, posuňte ukazovateľ myši nadol a kliknite na položku Vyhľadávanie), zadáte text Ovládací panel do vyhľadávacieho poľa, ťuknete alebo kliknete na položku Aplikácie a potom ťuknete alebo kliknete na položku Ovládací panel.
  2. V časti Systém a zabezpečenie ťuknite alebo kliknite na položku Skontrolovať stav počítača.
  3. Ťuknite alebo kliknite na šípku vedľa položky Zabezpečenie.
  4. V časti Ochrana proti vírusom skontrolujte, či je softvér zapnutý. Ak je softvér zapnutý, návod na jeho vypnutie nájdete v dokumentácii, ktorú ste získali spolu so softvérom.

Ak používate systém Windows 7, postupujte podľa nasledujúcich krokov:
  1. Kliknite na tlačidlo Štart a zadajte text wscui.cpl do poľa Prehľadať programy a súbory.
  2. V zozname Programy kliknite na položku wscui.cpl.
  3. Kliknite na šípku vedľa položky Zabezpečenie.
  4. V časti Ochrana proti vírusom skontrolujte, či je softvér zapnutý. Ak je softvér zapnutý, návod na jeho vypnutie nájdete v dokumentácii, ktorú ste získali spolu so softvérom.

Ak používate systém Windows Vista alebo Windows Server 2008, postupujte podľa nasledujúcich krokov:
  1. Kliknite na tlačidlo Start
    Zbaliť tento obrázokRozbaliť tento obrázok
    Tlačidlo Start (Štart)
    a potom skopírujte nasledujúci príkaz a prilepte ho do textového poľa Start Search (Vyhľadať):
    wscui.cpl
  2. V zozname programov kliknite na položku wscui.cpl.
  3. V okne zabezpečenia systému Windows kliknite na položku Malware protection (Ochrana pred programami typu malware).

    Poznámka: Ak systém Windows zistí váš antivírusový softvér, daný softvér bude uvedený v časti Virus protection (Ochrana pred vírusmi).
  4. Ak je softvér zapnutý, návod na jeho vypnutie nájdete v dokumentácii, ktorú ste získali spolu so softvérom.
Ak používate systém Windows 2000, Windows XP alebo Windows Server 2003, postupujte podľa nasledujúcich krokov:
  1. Kliknite na tlačidlo Start (Štart) a potom kliknite na položku Run (Spustiť).
  2. Skopírujte nasledujúci príkaz, prilepte ho do poľa Run (Spustiť) a potom stlačte kláves Enter:
    wscui.cpl
  3. V okne zabezpečenia systému Windows kliknite na položku Virus Protection (Ochrana pred vírusmi).
  4. Ak je antivírusový softvér zapnutý, prečítajte si informácie o danom programe a poznačte si jeho názov.
  5. Kliknite na tlačidlo Start (Štart), kliknite na položku All Programs (Všetky programy), prejdite na príslušný antivírusový program a spustite ho.
  6. Dočasne zakážte softvér.

    Poznámka: Informácie o postupe pri spustení programu nájdete v dokumentácii k danému programu.
Krok 2: Vyhľadanie aktualizácií pre systém Windows
Po dočasnom vypnutí antivírusového softvéru znova prejdite na lokalitu Windows Update alebo Microsoft Update a pokúste sa prevziať a nainštalovať aktualizácie.

Ak sa problém vyriešil vykonaním tohto postupu a podarilo sa vám úspešne nainštalovať aktualizácie, znova zapnite antivírusový softvér od iného výrobcu. Postupujte pri tom podľa kroku 2 v postupe B.

Ak sa vám pomocou tohto postupu nepodarilo problém vyriešiť, prejdite na postup D.
Zbaliť tento obrázokRozbaliť tento obrázok

Postup D: Vypnutie programov na urýchľovanie softvéru

Zbaliť tento obrázokRozbaliť tento obrázok
Vypnite všetky programy na urýchľovanie softvéru, ktoré môžu byť spustené, ako sú napríklad urýchľovače preberania súborov a urýchľovače internetového pripojenia.

Dôležité upozornenie: Ak je brána firewall od iného výrobcu stále vypnutá po vykonaní postupu B, dočasne neotvárajte e-mailové správy, neprehľadávajte web ani nepoužívajte softvér na výmenu okamžitých správ.
Krok 1: Vypnutie programov na urýchľovanie softvéru
Ak ich chcete vypnúť, vykonajte niektorú z týchto akcií:
  • Prečítajte si dokumentáciu dodanú s programom.
  • Zobrazte si Pomocníka daného programu.
  • Obráťte sa na dodávateľa programu. Informácie o kontaktovaní dodávateľa programu získate na nasledujúcej webovej lokalite spoločnosti Microsoft:
Krok 2: Inštalácia aktualizácií
Okamžite po vypnutí programu na urýchľovanie softvéru znova prejdite na lokalitu Windows Update alebo Microsoft Update a pokúste sa prevziať a nainštalovať aktualizácie.

Ak sa vykonaním tohto postupu problém vyrieši, mali by ste znovu zapnúť programy na urýchľovanie softvéru, ktoré ste vypli v kroku 1.

Ak sa vám pomocou tohto postupu nepodarilo problém vyriešiť, prejdite na postup E.
Zbaliť tento obrázokRozbaliť tento obrázok

Postup E: Pridanie webových lokalít Windows Update a Microsoft Update do zoznamu dôveryhodných lokalít

Zbaliť tento obrázokRozbaliť tento obrázok
Dôležité upozornenie: Ak je brána firewall od iného výrobcu stále vypnutá po vykonaní postupu B, dočasne neotvárajte e-mailové správy, neprehľadávajte web ani nepoužívajte softvér na výmenu okamžitých správ.

Pri pridaní webových lokalít Windows Update a Microsoft Update do zoznamu dôveryhodných lokalít postupujte podľa krokov, ktoré zodpovedajú vašej verzii systému Windows:

Ak používate systém Windows 8, postupujte podľa nasledujúcich krokov:
  1. Otvorte okno Ovládací panel tak, že potiahnete prstom z pravého okraja obrazovky, ťuknete na položku Vyhľadávanie (ak používate myš, ukážte do pravého horného rohu obrazovky, posuňte ukazovateľ myši nadol a potom kliknite na položku Vyhľadávanie), zadáte text Ovládací panel do vyhľadávacieho poľa, ťuknete alebo kliknete na položku Aplikácie a potom ťuknete alebo kliknete na položku Ovládací panel.
  2. Ťuknite alebo kliknite na položku Sieť a internet a potom ťuknite alebo kliknite na položku Možnosti siete internet.
  3. Ťuknite alebo kliknite na kartu Zabezpečenie a potom ťuknite alebo kliknite na položku Dôveryhodné lokality.
  4. Ťuknite alebo kliknite na položku Lokality a potom zrušte začiarknutie políčka Žiadať overenie servera (https:) pre všetky lokality v zóne.
  5. Skopírujte nasledujúce adresy, prilepte ich do poľa Pridať túto webovú lokalitu do zóny a po zadaní každej adresy ťuknite alebo kliknite na tlačidlo Pridať:
    • http://update.microsoft.com
    • https://update.microsoft.com
    • http://*.update.microsoft.com
    • https://*.update.microsoft.com
    • http://download.windowsupdate.com
  6. Ťuknite alebo kliknite na tlačidlo Zavrieť a potom ťuknite alebo kliknite na tlačidlo OK.
  7. Systém Windows sa znova pokúsi nainštalovať aktualizácie.

Ak používate systém Windows 7 alebo Windows Vista, postupujte podľa nasledujúcich krokov:
  1. Spustite program Windows Internet Explorer.
  2. V ponuke Nástroje kliknite na položku Možnosti siete Internet.

    Poznámka: Ak používate program Internet Explorer a ponuka Nástroje nie je dostupná, prístup k ponuke získate stlačením klávesu ALT na klávesnici.
  3. Kliknite na kartu Zabezpečenie a potom kliknite na položku Dôveryhodné lokality.
  4. Kliknite na položku Lokality a potom zrušte začiarknutie políčka Žiadať overenie servera (https:) pre všetky lokality v zóne.
  5. Skopírujte nasledujúce adresy, prilepte ich do poľa Pridať túto webovú lokalitu do zóny a po zadaní každej adresy kliknite na tlačidlo Pridať:
    • http://update.microsoft.com
    • https://update.microsoft.com
    • http://*.update.microsoft.com
    • https://*.update.microsoft.com
    • http://download.windowsupdate.com
  6. Kliknite na tlačidlo Zavrieť.
  7. Kliknite na tlačidlo OK.
  8. Znova sa pokúste nainštalovať aktualizácie.
Ak sa problém vyriešil vykonaním tohto postupu a podarilo sa vám úspešne nainštalovať aktualizácie, znova zapnite bránu firewall od iného výrobcu, ak je stále vypnutá. Postupujte pri tom podľa kroku 2 v postupe B.

Ak sa vám pomocou tohto postupu nepodarilo problém vyriešiť, prejdite na postup F.
Zbaliť tento obrázokRozbaliť tento obrázok

Postup F: Kontrola, či je nainštalovaná najnovšia aktualizácia služby BITS (Background Intelligent Transfer Service)

Zbaliť tento obrázokRozbaliť tento obrázok
Dôležité upozornenie: Ak je brána firewall od iného výrobcu stále vypnutá po vykonaní postupu B, dočasne neotvárajte e-mailové správy, neprehľadávajte web ani nepoužívajte softvér na výmenu okamžitých správ.

Ďalšie informácie o kontrole, či je nainštalovaná najnovšia aktualizácia služby BITS, získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:
842773 K dispozícii je balík aktualizácií obsahujúci službu BITS 2.0 a službu WinHTTP 5.1 pre systémy Windows Server 2003, Windows XP a Windows 2000
Ak sa problém vyriešil vykonaním tohto postupu a podarilo sa vám úspešne nainštalovať aktualizácie, proces riešenia problému ste dokončili. Ak je však brána firewall od iného výrobcu stále vypnutá (vypli ste ju pri vykonávaní postupu B), znova ju zapnite. Postupujte pri tom podľa kroku 2 v postupe B.

Ak sa problém pomocou tohto postupu nevyriešil, môžete pokračovať časťou Postupy riešenia problémov pre pokročilých používateľov. Ak potrebujete pomoc pri riešení problémov pre pokročilých používateľov, obráťte sa na správcu systému alebo kontaktujte oddelenie technickej podpory spoločnosti Microsoft prostredníctvom nasledujúcej stránky:
Zbaliť tento obrázokRozbaliť tento obrázok

Postupy riešenia problémov pre pokročilých používateľov

Postupy riešenia problémov a ďalšie informácie uvedené v nasledujúcej časti sú určené pre pokročilých používateľov a pre používateľov, ktorí pracujú v podnikovom prostredí používajúcom súbory hosts a servery proxy.

Rozšírený postup A: Odstránenie položiek webových lokalít Windows Update a Microsoft Update zo súboru hosts

Zbaliť tento obrázokRozbaliť tento obrázok
Niektoré programy môžu z dôvodu prekladu názvov DNS upraviť súbor hosts. V niektorých prípadoch existuje v súbore hosts položka pre webovú lokalitu Windows Update alebo Microsoft Update.

Položky odstránite zo súboru hosts vykonaním týchto krokov:
  1. V systéme Windows Vista alebo Windows 7 kliknite na tlačidlo Štart a potom kliknite na položku Spustiť. V systéme Windows 8 potiahnite prstom z pravého okraja obrazovky, ťuknite na položku Vyhľadávanie (ak používate myš, ukážte do pravého horného rohu obrazovky, posuňte ukazovateľ myši nadol a potom kliknite na položku Vyhľadávanie), zadajte text spustiť do vyhľadávacieho poľa, ťuknite alebo kliknite na položku Aplikácie a potom ťuknite alebo kliknite na položku Spustiť.
  2. V programe Poznámkový blok odstráňte alebo vylúčte riadky súboru hosts týkajúce sa webovej lokality Windows Update tak, aby sa pri prístupe k súboru nečítali. Vykonáte to tak, že pred každý riadok, ktorý obsahuje reťazce „microsoft“ a „update“, umiestnite znak #. Znak # vložte napríklad na začiatok nasledovných riadkov:
    • # 64.4.21.125 http://update.microsoft.com
    • # 64.4.21.125 http://update.microsoft.com
    • # http://update.microsoft.com
  3. V ponuke Súbor ťuknite alebo kliknite na položku Uložiť.
  4. Zatvorte program Poznámkový blok.
  5. Reštartujte počítač.

    Poznámka: Ak nechcete reštartovať počítač, môžete tiež vyprázdniť vyrovnávaciu pamäť prekladania DNS. Ak chcete tento postup vykonať v systéme Windows 7 alebo Windows Vista, postupujte podľa nasledujúcich krokov:
    1. Kliknite na tlačidlo Štart a potom kliknite na položku Spustiť.
    2. Zadajte text cmd do poľa Spustiť a potom stlačte kláves Enter.
    3. Do príkazového riadka zadajte príkaz ipconfig /flushdns a potom stlačte kláves Enter.
Zbaliť tento obrázokRozbaliť tento obrázok

Rozšírený postup B: Odstránenie položky servera proxy z konfigurácie servera proxy služby WinHTTP

Zbaliť tento obrázokRozbaliť tento obrázok
Windows 8

Ak chcete v systéme Windows 8 odstrániť položku servera proxy z konfigurácie servera proxy služby WinHTTP, postupujte podľa nasledujúcich krokov:
  1. Otvorte okno Príkazový riadok tak, že potiahnete prstom z pravého okraja obrazovky, ťuknete na položku Vyhľadávanie (ak používate myš, ukážte do pravého horného rohu obrazovky, posuňte ukazovateľ myši nadol a potom kliknite na položku Vyhľadávanie), do vyhľadávacieho poľa zadáte text príkazový riadok, ťuknete alebo kliknete na položku Aplikácie, ťuknete na položku Príkazový riadok a podržíte ju alebo na ňu kliknete pravým tlačidlom myši a potom ťuknete alebo kliknete na položku Spustiť ako správca.
  2. Zadajte príkaz netsh winhttp show proxy a potom stlačte kláves Enter. Poznámka: Nastavenie servera proxy je uvedené vedľa položky Server proxy. Ak sa nezobrazuje žiadny server proxy, v okne príkazového riadka sa zobrazuje položka Priamy prístup <žiadny server proxy>.
  3. Zadajte príkaz netsh winhttp reset proxy a potom stlačte kláves Enter.
  4. Systém Windows by sa mal znova pokúsiť nainštalovať aktualizácie.

Windows 7
Ak chcete v systéme Windows 7 odstrániť položku servera proxy z konfigurácie servera proxy služby WinHTTP, postupujte podľa nasledujúcich krokov:
  1. Kliknite na tlačidlo Štart a zadajte reťazec cmd do poľa Prehľadať programy a súbory.
  2. Kliknite pravým tlačidlom myši na položku cmd.exe v zozname Programy a potom kliknite na položku Spustiť ako správca.

    Poznámka: Ak sa zobrazí výzva na potvrdenie alebo zadanie hesla správcu, zadajte heslo alebo kliknite na tlačidlo Pokračovať.
  3. Zadajte nasledujúci príkaz a potom stlačte kláves Enter:
    netsh winhttp show proxy
    Poznámka: Nastavenie servera proxy je uvedené vedľa položky Server proxy. Ak nie je zobrazený žiadny server proxy, v okne príkazového riadka sa zobrazí položka Priamy prístup <žiadny server proxy>.
  4. Ak chcete odstrániť uvedené nastavenie servera proxy, zadajte nasledujúci príkaz a potom stlačte kláves Enter:
    netsh winhttp reset proxy
  5. Kliknite na tlačidlo Štart, na položku Všetky programy, potom na položku Windows Update a skúste znovu prevziať a nainštalovať aktualizácie.
Windows Vista
Ak chcete v systéme Windows Vista odstrániť položku servera proxy z konfigurácie servera proxy služby WinHTTP, postupujte podľa nasledujúcich krokov:
  1. Kliknite na tlačidlo Štart a zadajte príkaz cmd do poľa Vyhľadať.
  2. Kliknite pravým tlačidlom myši na položku cmd.exe v zozname Programy a potom kliknite na položku Spustiť ako správca.

    Poznámka: Ak sa zobrazí výzva na potvrdenie alebo zadanie hesla správcu, zadajte heslo alebo kliknite na tlačidlo Pokračovať.
  3. Zadajte nasledujúci príkaz a potom stlačte kláves Enter:
    netsh winhttp show proxy
    Poznámka: Nastavenie servera proxy je uvedené vedľa položky Server proxy. Ak nie je zobrazený žiadny server proxy, v okne príkazového riadka sa zobrazí položka Priamy prístup <žiadny server proxy>.
  4. Ak chcete odstrániť uvedené nastavenie servera proxy, zadajte nasledujúci príkaz a potom stlačte kláves Enter:
    netsh winhttp reset proxy
  5. Kliknite na tlačidlo Štart, na položku Všetky programy, potom na položku Windows Update a skúste znovu prevziať a nainštalovať aktualizácie.
Windows XP a Windows Server 2003
Ak chcete v systéme Windows XP alebo Windows Server 2003 odstrániť položku servera proxy z konfigurácie servera proxy služby WinHTTP, postupujte podľa nasledujúcich krokov:
  1. Otvorte program Internet Explorer.
  2. V ponuke Tools (Nástroje) kliknite na položku Internet Options (Možnosti siete Internet).
  3. Kliknite na kartu Connections (Pripojenia) a potom kliknite na tlačidlo LAN Settings (Nastavenia siete LAN).
  4. V dialógovom okne Local Area Network (LAN) Settings (Nastavenia lokálnej počítačovej siete (LAN)) začiarknite políčko Automatically detect settings (Automaticky zistiť nastavenie) a potom kliknite na tlačidlo OK.
  5. Ukončite program Internet Explorer.
  6. Kliknite na tlačidlo Start (Štart) a potom kliknite na položku Run (Spustiť).
  7. Zadajte text cmd do poľa Run (Spustiť) a potom stlačte kláves Enter.
  8. Zadajte nasledujúce príkazy a po každom príkaze stlačte kláves Enter:
    1. proxycfg -d
    2. net stop wuauserv
    3. net start wuauserv
    4. exit
  9. Vráťte sa na lokalitu Windows Update alebo Microsoft Update a znova sa pokúste prevziať a nainštalovať aktualizácie.
Zbaliť tento obrázokRozbaliť tento obrázok

Rozšírený postup C: Kontrola spôsobu zisťovania a používania serverov proxy klientom služby Windows Update

Zbaliť tento obrázokRozbaliť tento obrázok

Pre používateľov v podnikovom prostredí a používateľov servera proxy
Ak ste podnikový používateľ alebo používateľ, ktorý sa nachádza za serverom proxy, informácie o tom, ako klient služby Windows Update zisťuje a používa servery proxy, získate v nasledujúcom článku databázy Microsoft Knowledge Base:
900935 Akým spôsobom klient služby Windows Update určuje, ktorý server proxy sa má použiť na pripojenie k webovej lokalite Windows Update
Zbaliť tento obrázokRozbaliť tento obrázok

Ďalšie informácie o kódoch chýb pre pokročilých používateľov

Zbaliť túto tabuľkuRozbaliť túto tabuľku
Šestnástkový kód chyby Desiatkový kód chybyPopis chyby API
0x80070008-2147024888ERROR_NOT_ENOUGH_MEMORY
0x800705B4-2147023436Error_Timeout
0x8007000E-2147024882E_OUTOFMEMORY
0x80072EE2-2147012894ERROR_INTERNET_TIMEOUT
0x80072EFD-2147012867ERROR_INTERNET_CANNOT_CONNECT
0x80072EE7-2147012889ERROR_INTERNET_NAME_NOT_RESOLVED
0x80072EEF-2147012881ERROR_INTERNET_LOGIN_FAILURE
0x80072EFE-2147012866ERROR_INTERNET_CONNECTION_ABORTED
0x8024400E-2145107954SUS_E_PT_SOAP_SERVER
0x80072F76-2147012746ERROR_WINHTTP_HEADER_NOT_FOUND
0x80244016-2145107946SUS_E_PT_HTTP_STATUS_BAD_REQUEST
0x80072F78-2147012744ERROR_WINHTTP_INVALID_SERVER_RESPONSE
0x80244022-2145107934SUS_E_PT_HTTP_STATUS_SERVICE_UNAVAIL
0x80090305-2146893051SEC_E_SECPKG_NOT_FOUND
0x8024402F-2145107921WU_E_PT_ECP_SUCCEEDED_WITH_ERRORS
0x8009033F-2146892993SEC_E_Shutdown_IN_Progress
0xC80003FA-939523078hrReadVerifyFailure
0x80244008-2145107960SUS_E_PT_SOAPCLIENT_PARSEFAULT
0xC800042D-939523027HrVersionStoreOutOfMemory
0x8024400A -2145107958SUS_E_PT_SOAPCLIENT_PARSE
0x80071A90-2147018096ERROR_TRANSACTIONAL_CONFLICT
0x8024400D-2145107955SUS_E_PT_SOAP_CLIENT

Vlastnosti

ID článku: 836941 - Posledná kontrola: 28. decembra 2012 - Revízia: 33.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Update
Kľúčové slová: 
kbresolve kbhowto kbacwsurvey kbwindowsupdatev6 kbwindowsupdate kberrmsg kbprb kbcip kbvideocontent KB836941

Odošlite odozvu