Remote Shell (Rsh.exe) stops responding when you press any key on a Windows 2000-based computer

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Article ID: 837090 - View products that this article applies to.
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Symptoms

If you run the Remote Shell utility (Rsh.exe) on a computer that is running Microsoft Windows 2000 Service Pack 4 (SP4), and you press any key on the keyboard, Rsh.exe may stop responding until you press ENTER. Additionally, you may receive an error message that is similar to the following:
Network write: The handle is invalid.
You may have to press ENTER to return to the command prompt.

Cause

This problem may occur if all the following conditions are true:
  • Rshexit.exe calls the TerminateThread function when the TerminalInputHandler thread is running.
  • The TerminalInputHandler thread owns a critical section object.
  • The TerminateThread function forces the TerminalInputHandler thread to close without releasing ownership of the critical section object.
  • You press a key while Rsh.exe was running. This creates a new input/output (I/O) thread that is captured by Rsh.exe.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces hotfix 330028.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size    File name
   ----------------------------------------------------
   06-May-2004  19:27  5.0.2195.6927  14,608  Rsh.exe

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For additional information about the new file naming schema for Microsoft Windows software update packages, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 837090 - Last Review: October 26, 2013 - Revision: 3.0
Applies to
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbwin2000presp5fix KB837090

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