Rozwiązywanie problemów ze zwalnianiem profilu

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 837115 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Symptomy

Przy wylogowywaniu się z komputera, na którym działa system Microsoft Windows Server 2003, Windows XP, Windows 2000 lub Windows NT 4.0, może wystąpić jeden (lub kilka) z poniższych symptomów:
  • Profil użytkownika nie jest zwalniany.
  • Profil użytkownika mobilnego nie jest uzgadniany.
  • Zostaje osiągnięty limit rozmiaru rejestru (RSL, Registry Size Limit).
  • Wylogowywanie się zajmuje dużo czasu i pojawia się następujący komunikat o błędzie:
    Zapisywanie ustawień…
Dodatkowo, w zależności od systemu operacyjnego, w dzienniku aplikacji może się pojawić jeden (lub kilka) z poniższych komunikatów dotyczących zdarzenia.

Windows XP i Windows Server 2003

Typ zdarzenia: Błąd
Źródło zdarzenia: Userenv
Kategoria zdarzenia: Brak
Identyfikator zdarzenia: 1517
Opis:
System Windows zapisał rejestr użytkownika nazwa_komputera\nazwa_użytkownika, kiedy aplikacja lub usługa nadal użytkowała rejestr podczas wylogowywania. Pamięć używana przez rejestr użytkownika nie została zwolniona. Rejestr zostanie zwolniony, kiedy nie będzie używany. Najczęstszą tego przyczyną są usługi uruchamiane z konta użytkownika. Spróbuj skonfigurować te usługi w taki sposób, aby były uruchamiane z konta usługi lokalnej (LocalService) lub usługi sieciowej (NetworkService).

Typ zdarzenia: Błąd
Źródło zdarzenia: Userenv
Kategoria zdarzenia: Brak
Identyfikator zdarzenia: 1524 Opis:
System Windows nie może zwolnić pliku rejestru klas — plik jest ciągle używany przez inną aplikację lub usługę. Plik zostanie zwolniony, gdy nie będzie używany.

Typ zdarzenia: Błąd
Źródło zdarzenia: Userenv
Kategoria zdarzenia: Brak
Identyfikator zdarzenia: 1500
Opis:
System Windows nie może wykonać logowania, ponieważ nie można załadować Twojego profilu. Sprawdź, czy masz połączenie z siecią i czy sieć działa poprawnie. Jeśli ten problem będzie się powtarzać, skontaktuj się z administratorem sieci.
Szczegóły:
------------------------------
Odmowa dostępu

Windows 2000

Typ zdarzenia: Błąd
Źródło zdarzenia: Userenv
Kategoria zdarzenia: Brak
Identyfikator zdarzenia: 1000
Opis:
System Windows nie może zwolnić pliku rejestru. Jeśli używasz profilu mobilnego, ustawienia nie zostaną zreplikowane. Skontaktuj się z administratorem.
Szczegóły:
------------------------------
Odmowa dostępu

Typ zdarzenia: Błąd
Źródło zdarzenia: Userenv
Kategoria zdarzenia: Brak
Identyfikator zdarzenia: 1000
Opis:
System Windows nie może zwolnić pliku klasy rejestru. Jeśli używasz profilu mobilnego, ustawienia nie zostaną zreplikowane. Skontaktuj się z administratorem.
Szczegóły: -
-----------------------------
Odmowa dostępu

Typ zdarzenia: Błąd
Źródło zdarzenia: Userenv
Kategoria zdarzenia: Brak
Identyfikator zdarzenia: 1000
Opis:
System Windows nie może wykonać logowania, ponieważ nie można załadować profilu. Skontaktuj się z administratorem sieci.

Windows NT 4.0

Typ zdarzenia: Błąd
Źródło zdarzenia: Userenv
Kategoria zdarzenia: Brak
Identyfikator zdarzenia: 1000
Opis:
System operacyjny nie może załadować profilu użytkownika. Skontaktuj się z administratorem sieci.
Szczegóły:
------------------------------
Odmowa dostępu.

Przyczyna

Ten problem może wystąpić, jeśli system Microsoft Windows lub programy innych firm, takie jak sterowniki drukarki lub skanery antywirusowe, nie kończą działania i nie zwalniają zasobów przy wylogowywaniu z komputera.

Rozwiązanie

Aby rozwiązać ten problem, należy skorzystać z narzędzia Microsoft User Profile Hive Cleanup Service (UPHClean). Narzędzie UPHClean monitoruje komputer podczas zwalniania przez system Windows profilów użytkownika i wymusza zamknięcie otwartych zasobów. Dlatego komputer może zwolnić i uzgodnić profile użytkownika.

Aby pobrać i zainstalować narzędzie UPHClean, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://www.microsoft.com/downloads/details.aspx?FamilyId=1B286E6D-8912-4E18-B570-42470E2F3582

Więcej informacji

Aby uzyskać dodatkowe informacje na temat narzędzia UPHClean, przejrzyj zawartość pliku Readme.txt. Aby pobrać ten plik, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://www.microsoft.com/downloads/details.aspx?FamilyId=1B286E6D-8912-4E18-B570-42470E2F3582

Właściwości

Numer ID artykułu: 837115 - Ostatnia weryfikacja: 29 maja 2006 - Weryfikacja: 4.2
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Słowa kluczowe: 
kbserviceprocess kbprofiles kbprb kbwinservperf KB837115

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com